Jump to content

sgbett

Members
  • Content Count

    3
  • Joined

  • Last visited

About sgbett

  • Rank
    Candidate
  1. i just noticed in my logs that my webserver was giving 404. link fixed now.
  2. sorry i dont speak german so i am only guessing what you said. The problem is with the 2.6.12 kernal series now uses "!S_ISSOCK(inode->imode)" instead of referring to inode->i_sock. diff /usr/src/linux-2.6.11-gentoo-r11/net/socket.c /usr/src/lin ux-2.6.12-gentoo-r4/net/socket.c 7c7 < * Ross Biro, <bir7@leland.Stanford.Edu> --- > * Ross Biro 290c290 < ei->socket.passcred = 0; --- > ei->socket.flags = 0; 440,441c440 < if (!inode->i_sock || !(sock = SOCKET_I(inode))) < { --- > if (!S_ISSOCK(inode->i_mode)) { 446a446 > sock = SOCKET_I(inode); 474d473 < inode->i_sock = 1; 996,997c995 < if (fna) < kfree(fna); --- > kfree(fna); i have created a small patch to the interceptor.c file in the module.linux directory which should enable the module to compile (Übersetzt?) correctly. kaspersky_2.6.12_no_struct_i_sock.patch 254a255 > struct inode *inode; 272c273,274 < if (std_in && std_in->f_dentry->d_inode && std_in->f_dentry->d_inode->i_sock) { --- > inode = std_in->f_dentry->d_inode; > if (std_in && inode && S_ISSOCK(inode->i_mode)) { HTH
×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.