Sign in to follow this  
Followers 0
kada0601

Trouble moving file back into system folder

7 posts in this topic

Hi everyone, first time posting on these forums, so I apoligize if this is in the wrong spot.

 

Last week Kaspersky Internet Security 2012 informed me that the file msvbvm60.dll in the folder C:\Program Files (x86)\Kaspersky Lab\Kaspersky Internet Security 2012\x86 needed to be quarantined. I followed all of the recommended actions, which included removing the file, disinfecting, and doing a scan.

 

Then, a week later (today) Kaspersky informs me that the file is not infected and can be placed back in its original location. I attempt to do so, and this is what happens:

 

-A window pops up stating "Destination Folder Access Denied - You'll need to provide administrator permission to move to this folder: x86"

-I click continue

-"You need permission to perform this action" Now the only options are "try again" and "cancel"

 

I am the administrator on this computer. I have the only account on the computer, in fact.

 

I tried opening windows explorer in administrator mode and changing the permissions on the folder to include write access for all users, and get the following error message: "Error Applying Security - An error occured while applying security information to ...<file name>... Access is denied" Trying to change the owner of the folder doesn't work either (SYSTEM is the current owner)

 

Sorry this is long, trying to be thourough. My question is, how can I get this file back in the folder where it belongs? Does it even matter? Haven't noticed any problems yet, but it's only been a week. Right now the file is just saved on my desktop.

Share this post


Link to post
Share on other sites

Welcome. Please make a note of the current Owner, then add owner: Everyone. Apply >ok all, then try again. If successful, please revert to to original owner, by removing Everyone.

Share this post


Link to post
Share on other sites

Here is what I am doing.

 

Right click on folder>properties>click on security tab>click advanced button>click on owner tab

 

It shows the surrent owner (SYSTEM) with my username in a field below as an option to change. The only option I see is "Edit." I clicked edit and then "Other users or groups" in the subsequent window. I typed in "everyone" and added it. Back at the first window, I try to change ownership to everyone and get the message that access is denied.

Share this post


Link to post
Share on other sites

Try this:

 

Right click on folder>properties>click on security tab>click advanced button>....

 

Change Permissions button > Add button > type in Everyone > Full Control/Allow checkbox > ok>ok>ok>ok, then try again.

 

If successful, please revert to to original configuration, by removing Everyone.

Share this post


Link to post
Share on other sites

Thanks for your help so far.

 

I was able to get to the step where I check the "Full Control" check box, then hit ok. Back at the Permissions window, hitting ok gives me this message: "Error Applying Security - An error occurred while applying security information to <file name>. Access is denied." This happens even when running Windows Explorer as an administrator.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0