Jump to content
Sign in to follow this  
jbendavid

Updates Stopped Working!

Recommended Posts

Ok,

Many of our machines running win2k sp4 have stopped updating. Auto updates no longer occur, the update button in the user interface is non-functional, and updates fail if triggered manually from the kaspersky admin kit. Most of these machines last updated successfully on June 27, 2005. Because a major security rollup for win2k sp4 was added to Windows update on June 28, I suspect that this windows update may have broken Kaspersky. Reinstalling KAV seems to fix the problem, but it would be nice to know what is causing this problem so we can prevent this from happening on other machines.

Share this post


Link to post

Do the client workstations get updates from the Admin Server or from the Kaspersky Labs Update Service? You can try running the following tracer.exe tool, enabling the Updater trace feature, (click the 'On' button next to its field), when the update fails collect the updater trace file in the C:\ folder (full pathname is displayed in the tool) and post it here.

 

http://www.ice-kav.com/downloads/util/tracer.zip

Share this post


Link to post

Ok, I've figured out what the problem is, as well as a workaround. I still don't know what caused/is causing it though. On all the machines where updates have stopped working, the default database update task is missing on the local machine. This is why the update button doesn't work. The admin kit seems to still show the missing task, but fails when it tries to start it. (Thanks for your help Mike, but there's nothing to run a trace on!)

 

So anyway, the workaround is to add a new custom update task to each individual user's machine. This works fine, and the updates proceed as usual. EXCEPT that the user still can't manually update using the "update now" button, they have to manual start that particular task. (Scheduling works fine though).

 

As I said before, reinstalling Kaspersky fixes the problem fully (since it recreates the missing task) But I'd still like to know what's causing the built-in update task to dissapear, and if there's a quick/easy way to restore it on the affected machines.

Share this post


Link to post

So you're saying that if you go to a local workstation and look at the Settings-User Tasks option, there is no "Auto-Update Kaspersky Anti Virus Database" listed and/or "Anti-virus database update"? (the former would be listed if you have configured updates to be auto-deployed upon completion of the download from the KL Labs Update Service to the Admin Server).

Share this post


Link to post

We have not configured updates to auto-deploy from the server, so the "auto updates" item does not appear on the local workstation. But that's right, the "Anti-virus database update" task is missing from the local workstation as well. (and it is this I'm certain that is causing the problem, though I can't figure out how it happened in the first place, or how to fix it without reinstalling kaspersky)

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.