Jump to content
Sign in to follow this  
martin.eichhorn

Update der Antiviren-Datenbank

Recommended Posts

Hallo,

 

seit längerem erhalten wir für sämtliche Clients die Meldung "Die Antiviren-Datenbanken wurden sehr lange nicht aktualisiert".

 

Für jede Gruppe wurde ein eigener Task eingerichtet, der die Updates verteilen soll. Dieser wird eigentlich alle 3 Stunden automatisch ausgeführt. Am Client selber kann man erkennen, dass auch etwas passiert. Allerdings bleibt der Status in der Administrator-Konsole bestehen.

 

Unter dem Punkt "Letztes Update" kann man sehen, das ganz aktuell etwas aktualisiert wurde. Doch warum verschwindet die Meldung nicht?

 

Der Clientstatus für die Gruppe sieht wie folgt aus:

- Vollständige Untersuchung liegt lange zurück: melden bei > 120 Tage

- Antiviren-Datenbank wurde lange nicht aktualisiert: > 14 Tage

 

Wir haben mehrere Gruppen mit jeweils unterschiedlichen KAV-Versionen:

- Kaspersky Administration Kit 6.0.1565

- Kaspersky Administratoragent 5.0.1152

- Kaspersky Administratoragent 6.0.1565

- Kaspersky Anti-Virus 5.0 for Windows File Server 5.0.77

- Kaspersky Anti-Virus 5.0 for Windows Workstations 5.0.712

- Kaspersky Anti-Virus 6.0 for Windows Workstations 6.0.3.837

 

Vielen Dank im Voraus.

Share this post


Link to post

Hallo Martin,

 

mach bitte als erstes ein Update des AdminKits.

 

Leider hast Du eine Version installiert, die nur 2 Tage zum Download bereit stand.

 

Hast Du Clients mit verschiedenen Versionen (5 und 6 gemischt) in einer Gruppe?

 

 

Share this post


Link to post

Hallo,

 

so wie du das beschreibt vermute ich das der Globale Task für das Internet (Virensignatur) nicht mehr vorhanden ist bzw. nicht wirklich funktioniert.

 

Bitte überprüfe mal es, evtl. liegt dort die Ursache.

 

Es gab auch eine Version die den Globalen Task löscht bei Funktionsstörung. (Update)

 

Du sollte wie schon oben beschrieben die aktuelle Version vom AdminKit nehmen.

 

Grüße.

 

Share this post


Link to post

Hallo,

 

mir scheint, dass es ein Problem mit der Datenbank (SQL/MSDE) gibt. Im Event-Log des Servers sind folgende Meldungen zu finden:

 

Database error occured: Fehlerinformationen: 1950/50000 (Generic db error: "Database error: code = 50000, message='IDispatch error #3092', description='Such task already exists

Such task already exists', source='Microsoft OLE DB Provider for SQL Server', GUID='{0C733A63-2A1C-11CE-ADE5-00AA0044773D}', LastStatement='{ call tsk_add_task(?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) }'"), O:\CS AdminKit\development2\server\db\ado\db_adoprepstmtimpl.cpp, 376.

 

Can't update retranslation list: Object not found

 

Über den Punkt "Updates empfangen" erscheint der Kontext zur Erstellungen eines Tasks. Wenn ich alle Daten (inkl. Proxy) eingetragen habe und auf "Fertig" klicke, bricht KAV den Vorgang mit der Meldung "Erstellen des neuen Tasks fehlgeschlagen" ab. Anschließend kann man im Event-Log die o.g. Meldung lesen.

 

SQL-Server ist ordnungsgemäß gestartet. Lokale Tasks am Admin-Server (der den KAV-Client ebenfalls installiert hat) lassen sich hingegen einrichten.

 

Leider hast Du eine Version installiert, die nur 2 Tage zum Download bereit stand.

 

Hast Du Clients mit verschiedenen Versionen (5 und 6 gemischt) in einer Gruppe?

 

Okay, dann werde ich die neueste Version mal installieren.

 

Zu den Gruppen: Nein. Die unterschiedlichen Versionen sind ordnungsgemäß getrennt worden (eigene Gruppe, eigene Richtlinien, eigene Gruppentasks).

Share this post


Link to post

Hi,

 

genau wie ich mir es gedacht habe. :)

 

Der Task ist in der SQL, aber wird nicht mehr angezeigt und wird nicht mehr ausgeführt im AdminKit.

 

Normalerweise wenn du den aktuellen AdminKit installierst, solltest du wieder den TASK erzeugen können.

 

Viel Glück dabei.

 

cu

 

Share this post


Link to post

Hallo,

 

puuuhhhh...zum Glück hat der Deinstaller noch einmal ein Backup angefertigt. Das wäre eine schöne Überraschung zum Feierabend geworden. ;-)

 

Hat super geklappt. Der Server läuft wieder und die Updates wurden nun korrekt geladen und werden an die Clients verteilt.

 

Besten Dank für die schnelle Hilfe.

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.