Jump to content

Kaspersky Endpoint Security 10 SP1 for Linux

Recommended Posts

Hi all, 

I am currently configuring Kaspersky Security Center 10 for a customer with trial licenses. After we know that it the solution will work as we want (Windows/Linux, offline updates), then we will purchase licensing.

I'm trying to install kesl 10 on Linux clients via netagent. It fails with error:

"Cannot find package file 'kesl-10.1.0-5960.x86_64.rpm". 


I can understand why it can't find it because I have not copied it anywhere. Exactly where do I copy the rpm to? When I install the rpm directly on the Linux host, it does not get the license, hence it shows as "protection off" on the administration console.

I'm confused as to how to deploy Linux packages. Your assistance is greatly appreciated. 

Share this post

Link to post

Hi Fatih, 

I have managed to create & deploy the task from KSC. On top of that, managed to install kesl via KSC as well, so my first issue is solved. 

Now, I have a problem with licensing :) 

As it is a trial, I have loaded the licences (not sure but have a few licenses, not sure how I got them). The Windows clients licenses are ok, however, on the Linux client:

/opt/kaspersky/kesl/bin/kesl-control --app-info
Name:                                       Kaspersky Endpoint Security 10 SP1 for Linux

Key status:                                 Invalid black list
License expiration date:                    2019-02-27

Storage state:                              No objects in Storage
Storage space usage:                        Storage size is unlimited

Last run date of the Scan_My_Computer task: Never run

Last release date of databases:             N/A
Anti-virus databases loaded:                No
Anti-virus database records:                N/A

KSN state:                                  Off

File monitoring:                            Unavailable due to databases issue

Integrity monitoring:                       Unavailable due to databases issue


From the "invalid black list" output of the license status, I assume the key is invalid? I am not sure if I have the correct licences (attached licences from KSC "KSC licences.JPG"). I have assigned the Linux package the "Kaspersky Security for WS and FS"). 




Share this post

Link to post


Invalid black list means that the up=to=date blak list was not downloaded. 

Please run the update task again. 


Share this post

Link to post

Hi, I have run the update task but the Linux client is still showing "invalid black list" for license. I think the trouble I am having is that I don't have a valid license for Linux clients. I am not sure which one of the licenses listed in the above screenshot is for Linux. I have tried all of these licenses for the Linux client. 

How can I add, and where can I get a trial license for Linux? "Kaspersky Endpoint Security 10 SP1 for Linux".



Share this post

Link to post

  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.