Jump to content
  • Announcements

    • Rodion Nagornov

      Долгое сохранение сообщений || Delays while posting (click here to read the full text RU/EN)   09/20/2017

      Due to some technical reasons visual delays are possible while message sending. Actually your message is published immediately - just interface works long. In such case, please, do not re-send your message immediately! Press F5 to reload the page and check if your message/topic is published. || По техническим причинам возможно визуально долгое отправление сообщений на форуме. Фактически ваше сообщение публикуется мгновенно - долго отрабатывает графика. В случае подобной ситуации, пожалуйста, сначала обновите страницу (F5) и проверьте, появилось ли ваше сообщение. Не пытайтесь сразу отправить его заново.
Timothy J

Safe money transaction issues

Recommended Posts

Duplicate payments/seller not notified on payment

I'm having issues with 'safe money' when paying by card online. On a number of sites safe money will open the protected browser during payment, particularly sites using Verified by Visa or Mastercard Securecode. After entering the security details, the payment is taken but I am not being redirected back to the seller's site, either in the protected or the unprotected browser, so it seems the seller doesn't receive notification of payment and the order is not processed.

This has resulted in payment being taken twice on the same reference as I have had to try again using the 'open in current window' option. Obviously this is completely counterproductive as it bypasses the security of 'safe money' and can end up with money disappearing! While I can obviously turn safe money off or use protected browser for everything, I would appreciate suggestions for a more reasonable plan of action that will avoid the above problems.

Unless I am missing something obvious, this looks like a serious failing in the whole 'safe money' concept and I would appreciate it if it could be addressed as soon as possible.

For the record I'm using Chrome browser and KSOS5 (though this also happened with KIS that we used previously). I have noticed this issue most when the Verified by Visa or Mastercard Securecode is displayed in a frame on the retailer's page (which seems pretty common) 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×