Jump to content
CthulhuHalo

Blocking league of legends? And firefox certificate issues. [moved]

Recommended Posts

Every time I try to open League of Legends, I have to completely disable encrypted connection scanning and leave it disabled or it permanently breaks my game and doesn't allow me to connect to any matches, or even log in. This is absurd, having to choose between security and the ability to so much as play a game without reinstalling it every time I accidentally start it up with ECS enabled or enable it while the game is running. It's already made me not even load in to three separate matches an forced me to add web exclusions for EVERY SINGLE site associated with League or Riot. I've had to uninstall and reinstall my game four times, uninstall and reinstall kaspersky once to update it because you guys don't know how to offer updates in-program, and restart my computer probably eight times trying to fix this over the course of the last three days and I'm quite upset. Reasonably so, I imagine. So please, can someone either fix this, or help me come up with a better work-around than "hope you get ingame and reinstall every time you don't" and "disable an integral part of your security system while playing"? It does the same time any time I try to connect to a minecraft server on Java edition, and I have to disable ECS when I do that as well. Absolutely absurd.

 

EDIT: I now also can't log in to the LoL support site, so even if the issue WAS on their end, I can't even tell them that because of this. And that's WITH ECS disabled. Holy freaking crap this is upsetting me so much, I don't need this raising my blood pressure any more than it already has. Someone, help me fix this before I end up throwing my computer out a window or dying of a stroke.

 

EDIT 2: I've also been having issues with firefox not accepting Kaspersky's certificates unless I have it set to scan ALL encrypted traffic. And even then it still won't connect to any HSTS sites.

Edited by CthulhuHalo

Share this post


Link to post

Since for some reason I can't edit the post anymore, I'll put my update here:

Edit 3: I now realize I posted this in the wrong subforum. Mods, please move this to the proper one- I'm not using the free version. I'm using a paid subscription of Kaspersky Total Security.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.