Jump to content
MMenzel

Selbstschutz verhindert Systemwiederherstellung

Recommended Posts

Guten Morgen,

 

ich müsste eine Systemwiederherstellung durchführen. Beim ersten fehlgeschlagenen Versuch erinnerte ich mich, dass Kaspersky da große Schwierigkeiten macht. Also Schutz deaktiviert, Starten mit Windows deaktiviert -> 2. Versuch. Erneut fehlgeschlagen und da dämmerte es mir, es gibt ja noch den Selbstschutz. Diesen deaktiviert, externe Steuerung gleich mit. Noch einmal mit Windows starten deaktiviert, Schutz anhalten, Kaspersky beenden -> 3. Versuch. Aber leider schlug auch dieser sowie ein 4. fehl, da Kaspersky immer wieder meine Einstellungen überschreibt und sowohl den Selbstschutz als auch das Starten mit Windows aktiviert.

 

Ich möchte ungern Kaspersky komplett deinstallieren, um eine Systemwiederherstellung durchführen zu können und ich erinner mich, dass ich früher bereits erfolgreiche Wiederherstellungen mit dem Deaktivieren der genannten Einstellungen durchgeführt habe...

 

Was läuft denn hier schief?

 

Danke und Gruß

 

MMenzel

Share this post


Link to post

Also bei mir hat immer das deaktivieren des Selbstschutzes ausgereicht um eine Systemwiederherstellung durchführen zu können.

Ein beenden von KIS oder sonstige Einstellungen waren nie nötig.

Edited by Superpeppi

Share this post


Link to post

Hi,

 

die Erfahrungen, die ich unter Windows 7 gemacht habe sind folgende:

 

Schlägt eine Systemwiederherstellung fehl, wartet bis die Festplattenaktivität nachgelassen hat (Ruhelage). Führt dann erneut eine Systemwiederherstellung auf den gleichen Punkt aus. Versucht nicht einen anderen Wiederherstellungspunkt zu wählen, denn diese schlagen dann auch fehl. Windows 7 braucht manchmal zwei versuche, vor allem wenn der Systemwiederherstellungspunkt etwas länger zurückliegt.

 

Vorher immer in der KIS den Selbstschutz deaktivieren und KIS beenden. Sicherheitshalber Internetverbindung trennen.

 

So bin ich bisher immer vorgegangen und es hat stets funktioniert. Vielleicht hilft es euch weiter.

 

Gruß Herzi73

 

Share this post


Link to post

Sorry... hatte das hier ganz vergessen, nachdem ich mein Problem auch ohne Systemwiederherstellung lösen konnte.

 

Doch heute musste ich an meinem Laptop eine Systemwiederherstellung durchführen, auch dort das selbe Problem. Ich deaktiviere den Selbstschutz, das mit Windows starten und den Schutz allgemein und beende Kaspersky. Nach fehlgeschlagener Wiederherstellung ist Kaspersky mit aktiviertem Selbstschutz gestartet.

 

Zum Testen habe ich einen Wiederherstellungspunkt selbst gesetzt und habe bewusst all diese Dinge vor dem Punkt setzen deaktiviert. Und zu diesem, NUR zu diesem Wiederherstellungspunkt kann ich auch wieder herstellen.

 

Windows 7 64bit (beide Systeme)

Kaspersky Internet Security 13.0.1.4190

Share this post


Link to post

Nachtrag: Auch über den abgesicherten Modus ist keine Systemwiederherstellung möglich. Kaspersky aus dem Autostart rausgenommen via msconfig, in Kaspersky selbst nochmal Selbstschutz deaktiviert und Start/Schutz deaktiviert, dann abgesichterter Modus, Wiederherstellung -> Fehler, Kaspersky läuft und der Selbstschutz ist aktiv.

 

Ich werd noch wahnsinnig. Dieses mal lässt sich der Fehler nur beheben, indem ich eine Wiederherstellung mache.

 

Ich gehe mal davon aus, es bringt nichts wenn ich Kaspersky deinstalliere?

Share this post


Link to post

Hallo MMenzel,

 

wenn Deine Schilderung so zutrifft, scheint mit dem System einiges nicht zu stimmen.

Möglicherweise würde auch eine Deinstallation der KIS scheitern.

 

Du kannst aber mal versuchen, im abgesicherten Modus die AVP.EXE umzubenennen. Falls Du die neueste Version installiert hast, findest Du sie in "C:\Program Files (x86)\Kaspersky Lab\Kaspersky Internet Security 15.0.2".

Mach aus der AVP.EXE einfach eine AVP.EX_. Negative Folgen dürfte es nicht haben, rückgängig machen kannst Du es auch. Wenn wirklich "nur" KIS der Verursacher ist, müsste die Systemwiederherstellung nach einem Neustart klappen. Melde Dich aber bitte mit einem Konto an, das über Adminrechte verfügt. "Ausführen als Admin" klappt nicht bei allem.

Share this post


Link to post

Hallo Schulte :)

 

Es sind ja inzwischen 2 Systeme, die mit dem selben Problem zu kämpfen haben. Beides Win7 (1x Ultimate SP1, 1x Pro SP1), KIS Versionen auf beiden identisch.

 

Nachdem ich fast 13 Stunden mit dem Laptop gekämpft habe, laufen zumindest das vergurgte Programm und der Treiber wieder in altem Zustand. Evtl. muss ich heute morgen noch ein weiteres Problem lösen, da ein 2. Programm im Zuge meiner "Bastelei" einen Schaden genommen hat, aber ich werde Deinen Tip heute einmal an meinem 3. Rechner ausprobieren, der auch mit der selben KIS läuft.

 

Ich sollte mir einfach für jeden Rechner 2 externe Platten besorgen und einmal im Monat ein komplettes Backup mit Acronis machen... Ich glaub das wäre einfacher, wenn ich mal wieder durch ein Update irgendwas zerschiesse (never change a running system!) :/

 

Als Admin bin ich übrigens immer angemeldet, ich hab gern die Kontrolle und mach gern was ich will ;)

 

Ach und er ist eine sie :P

Share this post


Link to post

@MMenzel,

 

Hi,

 

hast Du mal die Punkte beachtet, die ich weiter oben aufgeführt hatte??

 

Windows braucht teilweise 2 Versuche auf den gleichen Wiederherstellungspunkt. Es reicht hierbei auch aus, den Selbstschutz zu deaktivieren und KIS zu beenden. Du brauchst nicht den gesamten Schutz der KIS zu beenden. Auch brauchst Du KIS den Start mit Windows nicht zu unterbinden.

 

Ich habe dieses Verhalten der KIS und der Systemwiederherstellung vor einigen Monaten ausgiebig getestet, da ich die Probleme mit der Systemwiederherstellung auch einmal hatte. Mit dem weiter oben von mir beschriebenen Weg klappt es aber eigentlich immer. Auch an mehreren Rechnern getestet.

 

Hast Du zufällig den CCleaner bei dir auf dem Rechner? Auch hier kann man einen Trick anwenden. Nach zweimaligem fehlschlagen der Systemwiederherstellung erstellt man einen neuen Systemwiederherstellungspunkt. Im CCleaner gibt es nun die Möglichkeit den Systemwiederherstellungspunkt zum Rückgängigmachen, den Windows selbst erstellt hat, zu löschen. Rechner neu starten und anschließend kannst du erneut eine saubere Wiederherstellung auf den von dir gewünschten Punkt ausführen.

 

Hoffe habe alles verständlich erklärt ist schon spät. :rolleyes:

 

Edit: Ich sehe gerade, hast du noch die KIS2013 installiert?? Dort treten diese Probleme mit der Systemwiederherstellung vermehrt auf. Bei der KIS2015 hatte ich diese

Probleme noch nicht.

 

 

Gruß Herzi73

Edited by herzi73

Share this post


Link to post

Moin Herzi73,

 

Deine Methode mit 2x den selben Punkt wählen brachte bei mir auch keinen Erfolg. Ich habe inzwischen mit dem Support telefoniert und dort hat man mir dazu geraten, Kaspersky zu deinstallieren, um die Systemwiederherstellung erfolgreich abschliessen zu können und danach dann erneut zu installieren (bzw. dann die 2015 zu wählen).

 

Momentan läuft wieder alles so wie gewollt, muss nur hin und wieder den gewünschten Grafikchip auswählen, deshalb will ich jetzt erstmal nicht weiter am System rumbasteln, bis ich nächsten Monat eine 2. externe Platte für einen Mirror da habe ;)

 

Aber dann werd ich es mit der 2015 mal probieren und evtl. auch den Tip mit CCleaner (habe ich derzeit nicht installiert).

 

Allen vielen Dank für die Unterstützung, momentan (drei mal auf Holz klopf) läuft es ja wieder.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.