Jump to content
veteran kaspersky user

Kaspersky Password Manager not working in protected browser

Recommended Posts

After recently getting a notice of an update for Kaspersky Password Manager and installing the update, Kaspersky Password manager works in normal web browser for FireFox but does not in a secured browser via Kaspersky Safe Money. After downloading and installing the update, when I opened my FireFox web browser it prompted me to allow Kaspersky Password Manager, which I did, and the Password Manager works just fine in that web browser. After opening a link that is set for Kaspersky safe browser through Kaspersky Safe Money the link opened in a secured browser as it should, however Kaspersky Password Manager was not active but Kaspersky Protection is. I checked the Add Ons and Extentions and I saw the Kaspersky Protection add on extension was there and enabled, however there is NO add on extension for Kaspersky Password Manager to enable or disable. I've tried reinstalling Kaspersky Password Manager after re-downloading it from Kaspersky's web site and had the protected FireFox browse open hoping it would see the secured browser. During the installation it did, in fact, notice that FireFox was opened and prompted me to close it which I did by selecting "close all web browsers and continue." I then tried again to open a link in the protected web browser via Safe Money and Kaspersky Password Manager still is not there. Apparently there is a different web browser profile for the safe browser and Kaspersky Password Manager is NOT installing the add on to it now. Is there a way I can add the extension to the protected web browser when it's not even listed in add ons and extensions? As I've stated, Kaspersky Password Manager works fine in regular browser mode, it's extension and add on are visible in the default web browser with options to enable or disable it, however the SAFE web browser opened by Kaserpsky does NOT have the extension or add on listed at all.

I don't quite understand why Kaspersky Password Manager would not install in the safe browsing mode, as that would certainly be the browser used for storing passwords. Surely Kaspersky would know that stored passwords in Kaspersky Password Manager would most likely be used for websites ran through the safe browser, not just the default browser. All I need to know is how to install the Kaspersky Password Manager in the safe browser's add ons and extensions.

Edited by Veteran Kaspersky User

Share this post


Link to post
Share on other sites

Hello,

 

I am also having an autofill issue with Chrome and the update of KPM. The username and password won't fill automatically in my tax preparation site. neither while using an unprotected browser nor a protected browser in Safe Money.

 

On all other websites it fills fine. Just the one website is affected. The website is http://hrblock.com.

 

Thanks,

 

 

Share this post


Link to post
Share on other sites
:rolleyes: How's going @Ballistic

All what I'd suggest is : Open KPM-Main screen >>On the websites

list >>click on : http://hrblock.com >>click [Edit] Don't type anything

 

You'll see on the >>Middle of the screen [ ] Auto logon ? >>Tick

the [•] Auto logon and click [Done] Restart the computer

and open the hrblock-Site now..Any better after

 

Oops! is this happens in the : (8.0.6.485 or 8.0.6.538) versions

 

Hi Indio,

 

I tried that and it didn't help.

 

The version I am using is 8.0.6.538. I didn't have this issue before the upgrade from 8.0.5.485.

 

Any other ideas?

 

Thanks,

Share this post


Link to post
Share on other sites
After recently getting a notice of an update for Kaspersky Password Manager and installing the update, Kaspersky Password manager works in normal web browser for FireFox but does not in a secured browser via Kaspersky Safe Money. After downloading and installing the update, when I opened my FireFox web browser it prompted me to allow Kaspersky Password Manager, which I did, and the Password Manager works just fine in that web browser. After opening a link that is set for Kaspersky safe browser through Kaspersky Safe Money the link opened in a secured browser as it should, however Kaspersky Password Manager was not active but Kaspersky Protection is. I checked the Add Ons and Extentions and I saw the Kaspersky Protection add on extension was there and enabled, however there is NO add on extension for Kaspersky Password Manager to enable or disable. I've tried reinstalling Kaspersky Password Manager after re-downloading it from Kaspersky's web site and had the protected FireFox browse open hoping it would see the secured browser. During the installation it did, in fact, notice that FireFox was opened and prompted me to close it which I did by selecting "close all web browsers and continue." I then tried again to open a link in the protected web browser via Safe Money and Kaspersky Password Manager still is not there. Apparently there is a different web browser profile for the safe browser and Kaspersky Password Manager is NOT installing the add on to it now. Is there a way I can add the extension to the protected web browser when it's not even listed in add ons and extensions? As I've stated, Kaspersky Password Manager works fine in regular browser mode, it's extension and add on are visible in the default web browser with options to enable or disable it, however the SAFE web browser opened by Kaserpsky does NOT have the extension or add on listed at all.

I don't quite understand why Kaspersky Password Manager would not install in the safe browsing mode, as that would certainly be the browser used for storing passwords. Surely Kaspersky would know that stored passwords in Kaspersky Password Manager would most likely be used for websites ran through the safe browser, not just the default browser. All I need to know is how to install the Kaspersky Password Manager in the safe browser's add ons and extensions.

 

After struggling with Kaspersky Technical Support for four days with absolutely NO HELP WHATSOEVER from them I have found the resolution to the problem of Kaspersky Password Manager not installing in the safe web browser used by Safe Money on my own with the help of Google Search. This thread can now be closed.

 

The solution in FireFox is to open the safe web browser which does not have Password Manager listed in the add-ons and extensions then click on Tools>>Add-Ons and click on Extensions. In the Extensions window click on the gear icon and select Install Add-on From File... In the Open dialog box the user then must navigate to C:\Program Files (x86)\Kaspersky Lab\Kaspersky Password Manager 8.0.6 folder. From that folder the user should select kpm.xpi and click on add. This will add Kaspersky Password Manager to the protected web browser's list of add-ons.

 

Hope this helps anyone else with this issue/problem of not having Kaspersky Password Manager in their safe web browser after updating Kaspersky Password Manager to version 8.0.6.538. It is still a bug that Kaspersky needs to fix in the update, but at least there is a resolution to get Kaspersky Password Manager working again in the protected browser.

Edited by Veteran Kaspersky User

Share this post


Link to post
Share on other sites
:bs: KUDOS @VeteranKaspersky..

For successfully fix his own issue and No doubt this solution

will help other KPM-Users in similar situation. As for close

the thread, will keep it a bit longer in case the other

member -Ballistic- decide to follow up his Help

request too..Fix our bugs is reciprocal action

 

Hi Indio,

 

I'm working with Tech Support on my issue. They are evaluating logs and other info I sent them. I will post back with progress.

 

Regards,

Share this post


Link to post
Share on other sites
Berny   
The version I am using is 8.0.6.538

 

Hi Ballistic,

 

Did you install KPM 8.0.6.538 on top ?

 

Share this post


Link to post
Share on other sites
Hi Ballistic,

 

Did you install KPM 8.0.6.538 on top ?

 

Hi Berny,

 

When I got the notice that an update was available I let it install itself. Since then I've uninstalled and reinstalled. I've also uninstalled and reinstalled Chrome, to no avail.

 

This problem affects both Chrome and Internet Explorer, and it's just affecting one website, hrblock.com. On other websites the autofill works fine. Unfortunately I use this website for financial transactions and the autofill is great because of concerns about keyloggers.

 

Regards,

Share this post


Link to post
Share on other sites

Thank you for providing this solution. Tech support elevated my request but I have not heard back in over 7 days. Interesting note is that I use KPM on a Windows 7 computer and on a Windows 10 computer, both with Firefox. The windows 10 machine installed just like expected. The windows 7 machine did not until your suggested fix to add the extension manually.

 

Bravo!!

Share this post


Link to post
Share on other sites
Thank you for providing this solution. Tech support elevated my request but I have not heard back in over 7 days. Interesting note is that I use KPM on a Windows 7 computer and on a Windows 10 computer, both with Firefox. The windows 10 machine installed just like expected. The windows 7 machine did not until your suggested fix to add the extension manually.

 

Bravo!!

 

Hello,

 

Glad that worked for you.

 

I got a response from Tech Support informing me that my issue is a bug that will be fixed in the next version.

 

Regards to all,

Share this post


Link to post
Share on other sites
weblee   

Thank You So MUCH!!!

 

I am changing to Kaspersky for my family and this was show stopper for certain members of my family. The project goes ahead now!

 

Weblee

Share this post


Link to post
Share on other sites
After struggling with Kaspersky Technical Support for four days with absolutely NO HELP WHATSOEVER from them I have found the resolution to the problem of Kaspersky Password Manager not installing in the safe web browser used by Safe Money on my own with the help of Google Search. This thread can now be closed.

 

The solution in FireFox is to open the safe web browser which does not have Password Manager listed in the add-ons and extensions then click on Tools>>Add-Ons and click on Extensions. In the Extensions window click on the gear icon and select Install Add-on From File... In the Open dialog box the user then must navigate to C:\Program Files (x86)\Kaspersky Lab\Kaspersky Password Manager 8.0.6 folder. From that folder the user should select kpm.xpi and click on add. This will add Kaspersky Password Manager to the protected web browser's list of add-ons.

 

Hope this helps anyone else with this issue/problem of not having Kaspersky Password Manager in their safe web browser after updating Kaspersky Password Manager to version 8.0.6.538. It is still a bug that Kaspersky needs to fix in the update, but at least there is a resolution to get Kaspersky Password Manager working again in the protected browser.

 

 

 

Thanks so very much!!!! I had the exact problem and this was the fix. I have been working with Kaspersky support for several days with no solution yet. I will be responding with this post to let them know the solution. Thanks again.

Share this post


Link to post
Share on other sites
Thanks so very much!!!! I had the exact problem and this was the fix. I have been working with Kaspersky support for several days with no solution yet. I will be responding with this post to let them know the solution. Thanks again.

 

 

Many thanks. This also fixed the problem for me.

Share this post


Link to post
Share on other sites
IsaacV2   

same, i was looking for a solution for hours, after struggling with the virtualization in my bios settings.

everything works as intended now.

 

my info:
win10pro latest build
Kaspersky 2017 TS
Kaspersky PM 8.0.6.538

Share this post


Link to post
Share on other sites
pyor66   

I have the same problem. Unfortunately the proposed solution does not work for my system. PM works in unprotected mode but in protected mode it does not work but opens in on-scree keyboard mode. I note, kin passing that the file kpm.xpi is dated 01/02/2017 - seems a bit old.

My Info:

W10 Home version 10.00.15063

KIS 2018: version 18.0.0.405 (b)

Pass Man: 8.0.6.538

Any advice gratefully received.

Thanks.

 

Share this post


Link to post
Share on other sites
Berny   

Can you please check in FF your KMP extension version : ? 3.9.22 - May 6, 2017 ?

Share this post


Link to post
Share on other sites
pyor66   
41 minutes ago, Berny said:

Can you please check in FF your KMP extension version : ? 3.9.22 - May 6, 2017 ?

Thanks Berny. Version is 3.9.16 - August 13, 2017. Automatic updates: Default.

Share this post


Link to post
Share on other sites
pyor66   

I have had one or two sessions with Tech Support and have finally succeeded in opening my bank account in protected browser.  The first session below succeeded in opening in IE but not Firefox. The second solved the problem with Firefox.

!.       Close all browsers then open Kaspersky Password Manager, click the three horizontal stripes button at the bottom-right corner, then select Settings. On the left hand side, click on Browsers. Click the trash bin icon next to Mozilla Firefox and Internet Explorer to delete the Kaspersky Password Manager plug-in. Afterwards, select to reinstall it.

Then launch a browser, and recheck the situation. - FIREFOX STILL NOT WORKING.

2.   a. Open a Protected browser window using Firefox
       b. Go to C:\Program Files (x86)\Kaspersky Lab\Kaspersky Password Manager 8.0.6\
       c. Locate the file kpm.xpi
       d. Drag and drop it into the browser window
       e. You will be prompted to install the extension; accept the prompt

Restart the browser and recheck the issue. - Success.

Hope this may help others who are still struggling!

Regards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×