Jump to content
Leo95

Defining a "user-agent" when trying to download

Recommended Posts

Hi all!
I use Kaspersky Update Utility 3 for Linux behind a proxy server, this proxy server, denies all requests if they are not made through a specific browser, eg Mozilla. When you try to use Kaspersky Update Utility, it denies me the download because there is no (at least as far as I understand) a parameter in the updater.ini file where you can define a specific "user-agent". Checking the logs I can see that it uses the following string as user-agent:

Quote

GET http://dnl-06.geo.kaspersky.com/updaters/updater.xml.klz HTTP/1.0
Host: dnl-06.geo.kaspersky.com
Pragma: no-cache
Cache-Control: no-cache
Proxy-Connection: keep-alive
Connection: keep-alive
User-Agent: *BEdBAAAA6uKAAoLzrCguc38qVV_Z4LgsqcIGEVS5H-Rs-9PAZAAAAEAADAA=
[09:03:23.097]    0xfffffffff5405b40    updater    core: HTTP response received:
HTTP/1.1 403 Forbidden
Server: squid

Please, is there any way to define this parameter in the configuration file?
Thank you very much in advance.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.