Jump to content

Recommended Posts

Добрый день!

 

Готовится к выходу обновление open SSL

 

Планируемая дата релиза:

8 февраля 2016

 

Исправления:

новая версия open SSL (багфикс)

 

Файлы (располагаются в директории установки) :

- ssleay32.dll 1.0.2.5 (md5: f3078db35a2b5c4f8895903fd73e5f5f)

- libeay32.dll 1.0.2.5 (md5: deff52badfbf865505e8c7f6ed70499e)

 

Источник обновления:

http://dnl-test.kaspersky-labs.com/test/iro

для применения обновления необходимо перезапустить продукт.

 

Ссылка на FAQ по тестированию:

http://forum.kaspersky.com/index.php?showtopic=343577

 

Share this post


Link to post

KIS | Windows 10 (1511, x64)

 

Обновление исправляет этот баг?

KIS 16.0.1.445

 

Facebook не грузится
с загружденным КИС (вкл. и выкл.), стоит выгрузить (именно выгрузить!) КИС, фейс сразу открывается. Проблема воспроизводится 100% в релизном Edge 13 и в бете Хрома.

 

 

Обращение в ТП:
INC000005675908

 

Такая же проблема еще у одного:

У меня с этими базами проблема воспроизводится. При этом, если отключить в "Настрока\Параметры сети" параметр "Внедрять в трафик скрипт взаимодействия с веб-страницами", то уже прогружает часть страницы.

Edited by MASolomko

Share this post


Link to post

KIS | Windows 10 (1511, x64)

 

Не желает открывать gmail.com, постоянно висит на загрузке:

post-213200-1453843624_thumb.png

Видео: KIS.16.0.1.445a_01.26_23.22_video.mp4

Трассировки: KIS.16.0.1.445a_01.26_23.22_traces.zip

 

p.s. Параметр "Внедрять в трафик скрипт взаимодействия с веб-страницами" отключён.

Share this post


Link to post
KIS | Windows 10 (1511, x64)

 

Не желает открывать gmail.com, постоянно висит на загрузке:

post-213200-1453843624_thumb.png

Видео: KIS.16.0.1.445a_01.26_23.22_video.mp4

Трассировки: KIS.16.0.1.445a_01.26_23.22_traces.zip

 

p.s. Параметр "Внедрять в трафик скрипт взаимодействия с веб-страницами" отключён.

 

спасибо, будем разбираться.

воспроизводится только с новым open ssl или при обновлении с pub (например http://dnl-01.geo.kaspersky.com) тоже?

после выгрузки продукта всё работает?

Share this post


Link to post

С facebook не работало как с pub, так и с тестового (в своем первом сообщении допустил опечатку: не поставил знак вопроса), а вот с Gmail перестало работать уже после обновления с тестового сервера. Приостановка или выгрузка продукта оба ресурса работают. Дома перейду на pub и проверю, но это сегодня, поздно вечером.

Edited by MASolomko

Share this post


Link to post

попробуйте ещё повоспроизводить в следующих вариантах:

 

1. вкл\выкл Параметр "Внедрять в трафик скрипт взаимодействия с веб-страницами"

2. вкл\выкл мониторинг активности (System watcher)

3. вкл\выкл опции "Защита от сбора данных" в "защите приватности"

Share this post


Link to post

Обновил базы.

 

1. вкл\выкл Параметр "Внедрять в трафик скрипт взаимодействия с веб-страницами"
Выкл: Gmail и facebook не загружает:
post-213200-1453918549_thumb.png post-213200-1453918555_thumb.png

 

Вкл (перезапустил браузер): Gmail загрузился корректно, facebook аналогично.

 

p.s. Мониторинг активности: вкл.

 

2. вкл\выкл мониторинг активности (System watcher)
вкл./выкл.: аналогично, обе страницы не открываются.

Если подождать 1 минуту, то facebook частично прогрузился:

post-213200-1453918560_thumb.png

 

p.s. "Внедрять в трафик скрипт взаимодействия с веб-страницами": выкл.

 

3. вкл\выкл опции "Защита от сбора данных" в "защите приватности"
вкл.: аналогично, не открылись страницы.

выкл.: без изменений, страницы не открылись.

 

p.s. "Внедрять в трафик скрипт взаимодействия с веб-страницами": выкл.

Мониторинг активности: выкл.

 

---

Трассы же пока не нужны были?

Share this post


Link to post

Андрей, мне получилось выявить виновный компонент -- Сетевой экран (в используемой локализации "Мережевий екран).

 

Отключил все компоненты продукта, "Внедрять в трафик скрипт взаимодействия с веб-страницами" тоже отключён, даже отключил расширение Kaspersky Protection.

 

Открываю браузер Google Chrome (x64), facebook успешно открылся, закрываю браузер. Включаю только компонент Сетевой экран и повторяю, facebook не открывается.

 

Видео: KIS.16.0.1.445a_01.27_20.29_video.mp4

Трассировки: KIS.16.0.1.445a_01.27_20.29_traces.zip

 

---

Включил всё, кроме сетевого экрана -- проблема осталась... Получается, если активен компонент , который мониторит трафик, то возникает проблемы.

Жду Ваших советов :)

Edited by MASolomko

Share this post


Link to post
KIS | Windows 10 (1511, x64)

 

Обновление исправляет этот баг?У меня с этими базами проблема воспроизводится. При этом, если отключить в "Настрока\Параметры сети" параметр "Внедрять в трафик скрипт взаимодействия с веб-страницами", то уже прогружает часть страницы.

 

Обновление не исправляет проблему.

У меня по-прежнему подгружается лишь часть страницы, точно также, как и с боевыми базами КИС (см. скриншот).

 

Отключение «Внедрять в трафик скрипт взаимодействия с веб-страницами» частично решает проблему, подгружается первый пост в ленте.

 

Важное замечание для разработчиков:

Очень странно, почему отключение «Внедрять в трафик скрипт взаимодействия с веб-страницами» частично решает проблему, но при этом приостановка защиты КИС НЕ решает проблему. Выходит, что при приостановке работы КИСа (пауза, не выгрузка) КИС по-прежнему продолжает «Внедрять в трафик скрипт взаимодействия с веб-страницами». Это так и должно быть (дизайн)? Или это уже отдельный баг?

Edited by Michel

Share this post


Link to post
...но при этом приостановка защиты КИС НЕ решает проблему. Выходит, что при приостановке работы КИСа (пауза, не выгрузка) КИС по-прежнему продолжает «Внедрять в трафик скрипт взаимодействия с веб-страницами».
Браузер пробовал перезапускать после приостановки защиты?

У меня приостановка защиты проблему решает, как и выгрузка продукта.

 

По фейсбуку добавлю, Edge - влияет Внедрять в трафик скрипт..., IE1132/64=chrome(64) -... (только защита от сбора данных) , firefox(64) - вообще ничего не влияет фейс открывается.

Это при условии, что direct DHCP к прову через обычный свитч. Далее Фейс показывает протокол TLS 1.2, имеет ли это отношение к модулям кис open ssl?

 

Share this post


Link to post
Включил всё, кроме сетевого экрана -- проблема осталась... Получается, если активен компонент , который мониторит трафик, то возникает проблемы.

Жду Ваших советов :)

 

Спасибо за локализацию, добавлю инфу и новые трейсы в заведённый баг.

 

Поскольку топик всё-таки об обновлении open SSL - помогает ли решить проблему с gmail обновление с pub (http://dnl-01.geo.kaspersky.com) и перезапуск продукта?

Share this post


Link to post
Поскольку топик всё-таки об обновлении open SSL - помогает ли решить проблему с gmail обновление с pub (http://dnl-01.geo.kaspersky.com) и перезапуск продукта?
Сделал.

Сейчас Gmail открывает. Но у меня и на тестовых он как-то сегодня и вчера открывался. С facebook всё стабильно не открывает, ВК по защищённому протоколу загружает корректно.

 

Share this post


Link to post
Браузер пробовал перезапускать после приостановки защиты?

У меня приостановка защиты проблему решает, как и выгрузка продукта.

 

Пробовал перезапускать. При отключенном внедрении кода Фейсбук грузит лишь первый пост в ленте, а дальше все, как и прежде, с включенным инжектом скрипта. Так что реально отключение инжекта не помогает.

 

Кстати, обратил внимание, что после отключения инжекта страницы стали грузится существенно быстрее (субъективно).

Кто-нибудь замечал подобное явление?

Share this post


Link to post
Сделал.

Сейчас Gmail открывает. Но у меня и на тестовых он как-то сегодня и вчера открывался. С facebook всё стабильно не открывает, ВК по защищённому протоколу загружает корректно.

 

Появилась информация, что отключение скрипта как раз может провоцировать проблему, если из кэша загружается страница с инжектированным скриптом.

Попробуйте пожалуйста повоспроизводить проблему с выключенным кэшем в браузере.

 

Интересуют такие комбинации:

 

1. Включить "Внедрять в трафик скрипт взаимодействия с веб-страницами"

а. обновиться с http://dnl-01.geo.kaspersky.com, перезапустить продукт, проверить воспроизведение

b. обновиться с http://dnl-test.kaspersky-labs.com/test/iro, перезапустить проверить воспроизведение

 

2. Выключить "Внедрять в трафик скрипт взаимодействия с веб-страницами"

а. обновиться с http://dnl-01.geo.kaspersky.com, перезапустить продукт, проверить воспроизведение

b. обновиться с http://dnl-test.kaspersky-labs.com/test/iro, перезапустить продукт, проверить воспроизведение

 

заранее спасибо!

Share this post


Link to post
Появилась информация, что отключение скрипта как раз может провоцировать проблему, если из кэша загружается страница с инжектированным скриптом.

Попробуйте пожалуйста повоспроизводить проблему с выключенным кэшем в браузере.

 

Уточните, пожалуйста, как именно отключить кеш в Хроме и Едже?

 

Где-то говорится, что нужно просто очистить кеш.

Где-то требуют запустить Хром с --disk-cache-dir=null параметром.

Ещё есть рекомендация отключить кеш в инструментах для разработчиков.

 

В общем, сообщите что именно нужно сделать, чтобы в этих браузерах отключить кеш.

Edited by Michel

Share this post


Link to post
Уточните, пожалуйста, как именно отключить кеш в Хроме и Едже?

 

Где-то говорится, что нужно просто очистить кеш.

Где-то требуют запустить Хром с --disk-cache-dir=null параметром.

Ещё есть рекомендация отключить кеш в инструментах для разработчиков.

 

В общем, сообщите что именно нужно сделать, чтобы в этих браузерах отключить кеш.

 

достаточно будет чистить перед каждой новой попыткой загрузить страницу.

Share this post


Link to post
достаточно будет чистить перед каждой новой попыткой загрузить страницу.

 

ОК, через часа два-три смогу проверить.

Edited by Michel

Share this post


Link to post
Дополнение: сейчас на http://dnl-test.kaspersky-labs.com/test/iro выложили обновлённый конфиг обработки траффика, который возможно поможет решить проблему.

 

Бинго!

У меня Фейс теперь грузится нормально.

Режим «Внедрять в трафик скрипт взаимодействия с веб-страницами» включён.

Всё работает нормально.

 

Порядок действий:

1. Полностью очистил кеш Хрома и Еджа

2. Обновился в 17:40 по МСК с http://dnl-test.kaspersky-labs.com/test/iro

3. Перезагрузил ПК

4. Отключил самозащиту

5. Выгрузил КИС

6. Очистил содержимое C:\Users\All Users\Kaspersky Lab\AVP16.0.1\Bases\Cache

7. Загрузил КИС

8. Включил самозащиту

9. Зашел на Фейс из Хрома и Еджа.

Edited by Michel

Share this post


Link to post
Бинго!

У меня Фейс теперь грузится нормально.

Режим «Внедрять в трафик скрипт взаимодействия с веб-страницами» включён.

Всё работает нормально.

 

отличные новости, спасибо!

Share this post


Link to post

С ресурсом facebook проблема решилась даже без очистки кеша и с активным параметром «Внедрять в трафик скрипт взаимодействия с веб-страницами» :)

Share this post


Link to post
С ресурсом facebook проблема решилась даже без очистки кеша и с активным параметром «Внедрять в трафик скрипт взаимодействия с веб-страницами» :)

 

А с gmail больше не повторялась? Сейчас есть проблемы с тестового источника?

Share this post


Link to post
А с gmail больше не повторялась? Сейчас есть проблемы с тестового источника?

 

У меня с Gmail и с Inbox by Gmail и так не было проблем.

Фейс грузится корректно.

Share this post


Link to post

Андрей, несколько раз открывал и пока проблемы не наблюдал.

 

p.s. В патче "А" содержатся те же обновляемые модули, что и сервера */test/iro? Просто знать

 

Share this post


Link to post

Спасибо за информацию!

 

p.s. В патче "А" содержатся те же обновляемые модули, что и сервера */test/iro? Просто знать

патчи не содержат модули, там другие бинари.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.