Jump to content
j.guillot

Windows 10 Apps Load Slowly [In progress]

Recommended Posts

Windows 10 apps are extremely slow to startup. The moment I exit Kaspersky and I try the app again, it loads fine. I then turn Kaspersky back on and the app struggles to start up again.

 

Specifically, I have noticed this happen with the Mail app. This is a real problem especially when trying to use a system share function (such as the share button in Edge). When I select Mail as my share option, it will not load at all (assuming it times out).

 

I have also noticed this in other apps, such as the Store. The Store amongst other apps also seem to crash occasionally on first startup of the app. I do not know for sure if this is Kaspersky causing the crashes since it is only on first startup of the app sometimes.

 

Does anyone else have these problems?

Share this post


Link to post
Windows 10 apps are extremely slow to startup. The moment I exit Kaspersky and I try the app again, it loads fine. I then turn Kaspersky back on and the app struggles to start up again.

 

Specifically, I have noticed this happen with the Mail app. This is a real problem especially when trying to use a system share function (such as the share button in Edge). When I select Mail as my share option, it will not load at all (assuming it times out).

 

I have also noticed this in other apps, such as the Store. The Store amongst other apps also seem to crash occasionally on first startup of the app. I do not know for sure if this is Kaspersky causing the crashes since it is only on first startup of the app sometimes.

 

Does anyone else have these problems?

 

Hi,

 

Does it help to exit KES or un-install it?

 

Thank You!

Share this post


Link to post
Hi,

 

Does it help to exit KES or un-install it?

 

Thank You!

 

Yes, exiting KES does restore Windows 10 apps to a normal speed immediately. I did uninstall KES before and it helped at first but it wasn't long before I noticed app performance slowing again.

 

Thank you.

Share this post


Link to post
Hi,

 

Does it help to exit KES or un-install it?

 

Thank You!

Yes, exiting KES does restore Windows 10 apps to a normal speed immediately. I did uninstall KES before and it helped at first but it wasn't long before I noticed app performance slowing again.

 

Thank you.

 

I wanted to clarify my above statement, I uninstalled KES and the issue reappeared a short time after after re-installing it.

Share this post


Link to post
I wanted to clarify my above statement, I uninstalled KES and the issue reappeared a short time after after re-installing it.

 

Hello,

please try to disable every single component to recognize the problem one.

Thank you.

Share this post


Link to post
Hello,

please try to disable every single component to recognize the problem one.

Thank you.

 

I disabled each service from Endpoint Control and Protection one at a time. Each time I disabled a service, the apps would not load faster. Even after all services were disabled and no updates or scans were running, the apps did not load any faster.

 

I once again exited KES and almost immediately saw a drastic improvement in app startup times. After that, the apps consistently opened immediately.

 

I started KES again with no services running and tested the mail app. The app would take longer than 2 minutes to open. I closed the mail app and reopened it and again it took forever to open. This appears to be directly linked with whether or not KES is running.

Share this post


Link to post
I disabled each service from Endpoint Control and Protection one at a time. Each time I disabled a service, the apps would not load faster. Even after all services were disabled and no updates or scans were running, the apps did not load any faster.

 

I once again exited KES and almost immediately saw a drastic improvement in app startup times. After that, the apps consistently opened immediately.

 

I started KES again with no services running and tested the mail app. The app would take longer than 2 minutes to open. I closed the mail app and reopened it and again it took forever to open. This appears to be directly linked with whether or not KES is running.

 

Hi,

 

What mail map are you using exactly?

 

Thank You!

Share this post


Link to post
I am using the built in Windows Mail app.

 

Hello,

what's about CPU and RAM consumptions during mentioned slowdowns ?

Please attach screen shots of task manager which illustrate the situation.

Thank you.

Share this post


Link to post
Hello,

what's about CPU and RAM consumptions during mentioned slowdowns ?

Please attach screen shots of task manager which illustrate the situation.

Thank you.

 

Because of the attachment size limits, this post has two screenshots, the first is KES open and the Mail app opening. The second screenshot on this post is KES open and the Mail app finally open after a few minutes.

 

post-565856-1447257897_thumb.jpg

 

post-565856-1447257903_thumb.jpg

 

The second post will have a screenshot of KES closed and the Mail app open.

Share this post


Link to post
Hello,

what's about CPU and RAM consumptions during mentioned slowdowns ?

Please attach screen shots of task manager which illustrate the situation.

Thank you.

 

Here is the second post that has a screenshot of KES closed and the Mail app open.

 

post-565856-1447258371_thumb.jpg

Share this post


Link to post

Hi,

 

It seems that performance is not affected.

Once again, if KES is not running, is the problem still persist? Did you try to start different apps?

Could you disable all KES components except IM-antivirus? Will the problem appear?

 

BR

Share this post


Link to post
Hi,

 

It seems that performance is not affected.

Once again, if KES is not running, is the problem still persist? Did you try to start different apps?

Could you disable all KES components except IM-antivirus? Will the problem appear?

 

BR

 

Performance is greatly affected. If you look at the screenshot where the Mail app is opening, KES is using almost 30% of the CPU while loading the Mail app. The moment the Mail app is open (second screenshot), KES is using 0% of the CPU.

 

I have tried disabling all KES components and the problem is still present. The problem only goes away when KES is completed closed.

 

The problem seems to pretty consistent with many apps. I see similar situations with apps like the Store, Calendar, Maps, etc. The loading times on all apps vary depending on the app but they are definitely longer when KES is open than when it is closed.

 

In fact, I noticed when an app is stuck loading, everything else on the computer gets slow until the app is done loading or is closed. Even Task Manager won't open until the app is done.

Share this post


Link to post

I too am experiencing this same problem. When I uninstall Kaspersky and reinstall it, the apps work fine for a while, but eventually stop working. The apps I am talking about are the built in windows 10 apps, like mail, news, money, store...

Share this post


Link to post
I too am experiencing this same problem. When I uninstall Kaspersky and reinstall it, the apps work fine for a while, but eventually stop working. The apps I am talking about are the built in windows 10 apps, like mail, news, money, store...

 

I see the problem when I try to open some downloaded apps as well, such as myTube! and Twitter. But the slowness is definitely more prevalent with the built in apps (Mail and Calendar seems to be the worst).

Share this post


Link to post
I see the problem when I try to open some downloaded apps as well, such as myTube! and Twitter. But the slowness is definitely more prevalent with the built in apps (Mail and Calendar seems to be the worst).

 

Hi,

 

Have you tested KES protection components as mentioned above?

 

Thank You!

Share this post


Link to post
Hi,

 

Have you tested KES protection components as mentioned above?

 

Thank You!

 

Yes, I have tested the components and did not see any improvements. The problem still persists.

Share this post


Link to post

Hi,

 

In that case please collect KES traces while issue reoccurs.

Please inform us if you`ll need access to FTP to upload data.

 

Thank you!

Share this post


Link to post
Hi,

 

In that case please collect KES traces while issue reoccurs.

Please inform us if you`ll need access to FTP to upload data.

 

Thank you!

 

I have gathered trace files of the issue. How do I upload them to you?

Share this post


Link to post
I have gathered trace files of the issue. How do I upload them to you?

 

Hello,

the commercial release will be published soon.

Many bugs will be fixed in new build.

Would you mind to install upcoming KES version and check the performance issue ?

Thank you.

 

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.