Jump to content

KMS KIS for Android RazrI not working

Recommended Posts


i'm using a motorola razri and purchased a licence for Kaspersky Mobile Security about one month ago. i downloaded kaspersky mobile security version 10.4.47_de on kms.kaspersky.de and tried to install it. this worked fine, but when i try to launch, i only see a rotating circle with the message to wait for a moment but then nothing happens. i can only "kill" the software with stopping the task in task manager.


i wrote the kaspersky support about this problem and they answered that i have to be patient since 30.08.13. On this date, they release an update which is facing and solving this problem. it seems that this is a known bug with the motorola razri series.


ok, today i wanted to download the new version of kms on kaspersky but i didn't found kms anymore. now i only get redirected to KIS for Android in Version So I downloaded this version and tried to install it. After launching i get following message: "processor architecture of your device is not supported". after two more seconds the software automatically close.


So, what can i do now? is kms really the same as KIS android? is really the new version and why didn't it work as well? is this a problem only with motorola razri? is there any hope to use kaspersky on my mobile device?


Thanks for your answers.



Share this post

Link to post

I don´t think that Kaspersky Internet Security for Android is compatible with Atom processor.

Please, contact the support.

Share this post

Link to post
This topic is now closed to further replies.

  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.