Jump to content
BCurran

Kaspersky's Gmail certificate to Thunderbird invalid

Recommended Posts

Kaspersky submits a certificate to Thunderbird email client that is invalid. The exception is never retained. I have to click accept dozens of time a day and the popup takes focus away from my work. VERY annoying! Certificat attached.

gmailcom.crt

Share this post


Link to post

Please hover your mouse cursor over the red K tray icon and tell us the name and version and full build number of your Kaspersky product.

Share this post


Link to post

I have had this same problem.  All Thunderbird accounts asking for a Kaspersky certificate. I have latest Thunderbird and Kaspersky Total Securite 18.0.405 (c).

Share this post


Link to post

Hello, I too have the same problem, even with the patch C the problem is not solved.

Share this post


Link to post

I had this fix from Tech Support and it seems to work………….

Let's create an exclusion from within Kaspersky, so as not to scan network activity for Thunderbird. To do so, please follow the steps below:

1. Open the main Kaspersky window, if the main window of Kaspersky application is not on your desktop, bring it up by double-clicking the Kaspersky desktop shortcut (icon) or by double clicking on the Kaspersky icon in the bottom right corner of the screen.
2. Click on the Gear icon in the bottom left corner of the Kaspersky window.
3. On the left side menu select 'Protection'.
4. On the right side menu select 'Application Control'.
5. Click on 'Manage applications'.
6. In the list of installed applications:

- Find Mozilla and expand it by clicking on the small arrow to the left.
- Select 'Thunderbird' and right-click on it (if you do not find Thunderbird in the list, please start Thunderbird and it will appear).
- Select 'Details and rules'.
- Select 'Exclusions'.
- From the six checkboxes you see here, check the option 'Do not scan all traffic'.

Restart your computer and check if the issues persists.

Share this post


Link to post

OK, thanks Richchad, this function, but I do not diminish security by doing this maneuver?

Share this post


Link to post
1 minute ago, avgold said:

OK, thanks Richchad, this function, but I do not diminish security by doing this maneuver?

I have no idea really avgold, but I thought it was just switching network activity for the Thunderbird Application and therefore also certificate authorisation and as email scanning is still on it would be okay?

But then again I maybe wrong, so perhaps see if a fix comes out and switch network activity back on?

Share this post


Link to post

Hello!

We know about the situation.

As a workaraound: Open Thunderbird options - Advanced  - Certificates  - View Certificates - Import - select the following certificate:

C:\ProgramData\Kaspersky Lab\AVP18.0.0\Data\Cert\(fake)Kaspersky Anti-Virus Personal Root Certificate.cer

enable 3 (all) options on the next step.

Then reboot and check the issue again.

p.s. Ragarding fix: we will discuss the issue asap and I will return with the reply.

Share this post


Link to post

Hello, this does not work because this is what happens when I want to import the certificate a message says: This certificate cannot be installed because you do not have the corresponding private key that was created when the certificate was required.

Share this post


Link to post
51 minutes ago, avgold said:

Hello, this does not work because this is what happens when I want to import the certificate a message says: This certificate cannot be installed because you do not have the corresponding private key that was created when the certificate was required.

It does work, it wasn't made very clear that you have to import it into Authorities not certificates, you then get the 3 check boxes mentioned.

I have done it and undid the exclusion that I mentioned above, strange that two Tech Support Engineers gave different solutions, although both work for the time being.

Edited by Richchad

Share this post


Link to post

You have to make this under the "Authorities" tab, not "personal".

 

My concern is:

- yeah disable mail scan is working

- yeah exclude / add an exception for theses providers works

 

But it also looses totally the benefits of a protection.

@Mefodys any idea why it happens to some computers ? I imagine using the (fake)Kaspersky.crt is like having nothing. Will the next releases fix this automagically or have we to do something manually ?

 

Ps: i have downloaded Free version WHILE my computer is not able to do it in my native tongue (FR). Perhaps there is a geographic issue or something like this ?

Share this post


Link to post

@CCCF, hello!

You dont need to disable mail scan or set exclusions, all you need is to add K* cert to TB cert storage manually at this step.

I hope that the issue will be fixed with the next pathes (and K* cert will be installed in TB cert storage automatically). The question regarding implementing the feature in 2018 product line is under discuss.

I will update the thread when there will be any news.

 

 

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.