Jump to content
Xeevis

"Secure traffic scan in Firefox is limited" warning [cross posting > merged]

Recommended Posts

Hello I have a peculiar problem with encrypted connections scanning when running Firefox and Firefox Developer Edition together. When I run only one at the time all is fine. However when I run them together the second one throws error "Secure traffic in [Firefox/Firefox Developer Edition] for the default profile is not monitored".

I don't think I even need secure traffic in developer edition. I've tried adding an exclusion for it:

image.png.25e5f9c5491f60fa21fba6ecc33d2982.png

What this achieves is that when Developer Edition is launched second I won't get the error and all is fine. But when I launch them in reverse it will still cause the error for the Firefox.

Any idea how to make this work without turning off encrypted connections scanning completely? Thanks.

Share this post


Link to post

The problems with FFox Default profiles it doesn't appears totally related to kaspersky

so to start troubleshoot the issue, better contact "Firefox Support" either by phone

Chat session or Email : 1) Support link :  https://firefoxsupport.com/firefox-profile-support

2) Email contact :  info@firefoxsupport.com  - include screenshot on the problem description

Edited by Indio

Share this post


Link to post

In addition to indios post:


the current FF Developer Edition has the version 62.0 beta.
KL doesn't support beta versions. Neither with operating systems nor with browsers. That could be the reason for the message.

Share this post


Link to post

All errors are thrown by KIS and it's quite moody, often when I launch Firefox I get, it's as if it's barely compatible even with stable version. :(

image.png.548f2e8fc311ffcc4e5c8fb7ece83495.png

Share this post


Link to post

Hello, we know about the issue.

It should be improved in next product version.

As a workaround use only one FF instance per time.

Also the issue can occur if FF has more than one profile set (Run -> firefox -p). In this case its recommended to keep only one FF profile.

 

Share this post


Link to post

Hi, 

 

I have Kis2018 patch i and today and 7 days ago I have this message:

 

Secure traffic in Firefox for the default profile is not monitored  (restart firefox)

 

I read in another user topic that  he has the same problem, I have only 1 firefox profile, what is the problem? in that topic there was write that :

we know about the issue.

It should be improved in next product version.

 

so I have to wait another patch?

 

 

Share this post


Link to post

I am also facing the same problem. The error message while using Firefox is "Secure traffic in Firefox for the default profile is not monitored  (restart firefox) "

How to fix this issue? And what is the cause of this problem? I do not think that this is a Firefox issue as in other laptops running other Security Suites this issue is not reported.

Share this post


Link to post

Can we please have an update on this issue. Now everytime I update Firefox the message, "Secure traffic in Firefox for the default profile is not monitored. Restart Firefox" appears.

It does not seem to be a Firefox problem as on my friends laptops and my work laptop I do not have the same problem.

Share this post


Link to post

+1 for the problem. For me, it occurs when I start another Firefox instance. I just want to disable this useless error message. I added exclusions for both firefox.exe instances but that didn't help. Still the error occurs. It says: "Secure traffic in Firefox for the default profile is not monitored". Very confusing.

Share this post


Link to post
On 8/7/2018 at 3:22 AM, Mefodys said:

Hello, we know about the issue.

It should be improved in next product version.

As a workaround use only one FF instance per time.

Also the issue can occur if FF has more than one profile set (Run -> firefox -p). In this case its recommended to keep only one FF profile.

 

Quoted here and now to ease reference and discoverability. 

Share this post


Link to post

I have a similar error message...but it is for Thunderbird email. (I believe Mozilla underwrites/developed Thunderbird???)

"Secure traffic in Thunderbird for the default profile is not monitored. You need to restart Thunderbird."

Share this post


Link to post

I only had one profile in Firefox, I did not have multiple profiles. I had to uninstall Firefox on the directions of Kaspersky support due to another unrelated issue. But before I uninstalled it I did receive this error. Will update this thread once I reinstall Firefox and if I get this error message again.

Quote

 

Hello, we know about the issue.

It should be improved in next product version.

As a workaround use only one FF instance per time.

Also the issue can occur if FF has more than one profile set (Run -> firefox -p). In this case its recommended to keep only one FF profile.

 

 

Share this post


Link to post

KIS  19.0.0.1088(c)

In the "Recommendations" section of the KIS Notification Center I am given the recommendation "Secure traffic scan in Firefox is limited" (which isn't a recommendation).   Selecting "Learn more" takes me to page
https://support.kaspersky.com/us/common/error/other/14396?cid=KIS_19.0&utm_source=interceptor&utm_medium=product&utm_campaign=KIS_19.0
which describes a message received when opening FireFox or Thunderbird.  There is no mention of the message in the KIS Notification Center.  I do not get any warning when opening FireFox or Thunderbird so I suspect this web page does not apply to my situation.

Could this warning be related to my having selected "Do not scan encrypted connections"?  (If so, it would be nice if the warning mentioned that.)

Even though that "Learn more" page doesn't seem to apply, I read it and saw something disturbing: instructions to delete multiple FireFox profiles " except for the one you intend to use ".  I use multiple FireFox profiles.  Is this not supported in KIS?

Share this post


Link to post

Hello pokeefe0001.

Please update Firefox to the last version and try: Settings > Additional > Network > Scan encrypted connections upon request from protection components.
If nothing changes, please try to uninstall Firefox > reboot > install Firefox > reboot.

Share this post


Link to post

In addition to what The Shield posted above, 

You might want to try reinstalling Kaspersky's SSL certificate manually. It's easy enough to do and may help on this.

Copy the certificate to any easily accessible location, e.g. to Desktop. The certificated is located in the folder: С:\ProgramData\KasperskyLab\AVPX.0.0\Data\Cert\(fake)Kaspersky Anti-Virus Personal Root Certificate.cer where X stands for the application version.

ProgramData is a hidden folder. To access it, enable display of hidden files and folders.

Then in Firefox go to 'Options'. (Not sure what version of FIrefox you have, but), in the newer version of FF, go to 'Options' - 'Privacy and Security'. Go to bottom of screen where it shows 'Certificates'. Click the View Certificates. In that window, click the 'Your Certificates' and then do an Import. Find the certificate where you made a copy of it and import it. In this way, Firefox will re-establish the SSL certificate and bind it to the server and Firefox. It may work. Otherwise, if you have multiple profiles, having a master password for all profiles will work better in this regard of SSL certs and applying.

Share this post


Link to post

Actually, I tried that yesterday but FireFox said the certificate was already installed.  I didn't try uninstalling and reinstalling the certificate.  I don't particularly want to go the master password route.

Share this post


Link to post

Hello. Well you could try just deleting that Kaspersky SSL certificate. It will make a new one when it restarts. I had forgotten about that when I did my earlier reply. You do have multiple profiles right? I know you don't want to do the master password bit, and I probably wouldn't want to either, never been a fan of that stuff, but I believe the purpose of it is to allow Kaspersky more permissions to get involve with this. The default profile would work well, but the other's not the same. I believe Kaspersky sees the other profiles as other people and that might be the issue for not wanting to go there, not sure. Does that error you get show when you do have encrypted scanning enabled?

Share this post


Link to post

I tried enabling encrypted scanning - first "upon request ..." and then fully - but the message stayed ... even after reboot.

I had the Kaspersky browser extension disabled in the profile I use to access my router's GUI.  Enabling it did not make the warning go away.

 

Share this post


Link to post

Hello,

I have the same problem mentioned here and another similar.

En 7/8/2018 a las 5:22, Mefodys dijo:

As a workaround use only one FF instance per time.

Also the issue can occur if FF has more than one profile set (Run -> firefox -p). In this case its recommended to keep only one FF profile.

I have three profiles (1. Firefox v56, 2. Firefox v63, 3. Firefox Dev Ed) I'm a web designer so I need to have those three versions.

I did not have any problem with KIS v18.0.0.405 (f) but the next update became to "Firefox can not be protected due to an unknown error"  for every single version of FF.

Now, I've installed KIS 19.0.0.1088 (c) and I get two erros:  "Secure traffic scan in Firefox is limited" & "Secure traffic in Firefox for the default profile is not monitored"

En 7/8/2018 a las 5:22, Mefodys dijo:

Hello, we know about the issue.

It should be improved in next product version.

I hope so.

Pic4d-KIS-msg.png

Portapapeles01.jpg

Portapapeles02.jpg

Share this post


Link to post

I found a related issue to this, probably the same problem, I reproduce my comment

topic-398463-firefox-can-not-be-protected-secure-traffic-in-for-the-default-profile-is-not-monitored-merged

Quote

Hello,

I have the same problem mentioned here and another similar.

Quote

As a workaround use only one FF instance per time.

Also the issue can occur if FF has more than one profile set (Run -> firefox -p). In this case its recommended to keep only one FF profile.

I have three profiles (1. Firefox v56, 2. Firefox v63, 3. Firefox Dev Ed) I'm a web designer so I need to have those three versions.

I did not have any problem with KIS v18.0.0.405 (f) but the next update became to "Firefox can not be protected due to an unknown error"  for every single version of FF.

Now, I've installed KIS 19.0.0.1088 (c) and I get two erros:  "Secure traffic scan in Firefox is limited" & "Secure traffic in Firefox for the default profile is not monitored"

En 7/8/2018 a las 5:22, Mefodys dijo:

Hello, we know about the issue.

It should be improved in next product version.

I hope so.

 

Edited by Armando Islas
Insert a link

Share this post


Link to post

Check if Kaspersky Root certificate is installed inside FireFox certificates manager -> Authorities

Share this post


Link to post

Hello,

Today my KIS updated and I got a message that the addon in Firefox was installed (although it was already installed).

So now I got this message saying that "Secure traffic scan in Firefox is limited".

In Certificate Manager- Authorities there are three personal certificates under Kaspersky.

In Your Certificates I don't see anything.

I tried to delete the .cert like describe above by @plb4333 however I get a message that I need permission from the Administrators, despite the fact that this is the only account in Win7 I have and it has administrative rights.

I also tried importing the .cert file but again I get an error message saying that it can't be installed because I don't own the corresponding private key.

Any solutions? I didn't have any of these problems prior to the Kaspersky update.

Share this post


Link to post
En 26/11/2018 a las 1:41, The Shield dijo:

Hello Armando Islas.

The error "Can not protect FireFox due to unknown error" it's fixed in the patch D (now in Beta).
 

I'll be waiting anxiously for that version.  :-)

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.