Jump to content
Sign in to follow this  
biryukov

RHEL 7.4. Не появляется в KSC

Recommended Posts

 cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.4 (Maipo)

 

 /opt/kaspersky/klnagent64/bin/klnagchk
Starting klnagchk utility
Checking command-line arguments...OK
Initializing basic libraries...OK
Current host is '###'
Network agent version is '10.5.0.32'

Reading settings...OK
Checking settings...OK
Administration Agent settings:
  Server address: '####'
  Use SSL: 1
  Compress traffic: 1
  Server SSL ports: '13000'
  Server ports: '14000'
  Use proxy: 0
  Certificate: absent
  Open UDP port: 1
  UDP ports: '15000'
  Ping period, minutes: 15
  Conn timeout, s: 30
  RW timeout, s: 180
  HostId:
 

Deinitializing basic libraries...OK
 
В KSC нигде нет (в нераспределенных искал).
Никакие дополнительно порты не нужно открывать по сравнению с KESL 10? Что Антивирус 8.0 для Linux File Servers, что Endpoint Security 10 для Linux работали на этом сервере.

Share this post


Link to post

Здравствуйте,

Ели предоставлен полный вывод klnagchk, то klnagent похоже установился некорректно. Нужно больше информации как он был установлен, в идеале трэйсы нагента. Включить можно в консоли. 

sudo mkdir -p /etc/opt/kaspersky/klnagent/1103/1.0.0.0/Debug

sudo /bin/echo -n 5 > /etc/opt/kaspersky/klnagent/1103/1.0.0.0/Debug/TraceLevel

потребуется перезагрузка klnagent

трэйсы будут писаться в /opt/kaspersky/klnagent64/sbin

Если вывод klnagchk не полный, то между  “HostId:” и “Deinitializing basic libraries...OK “ должен быть вывод ошибки.  

Нет, дополнительно порты никакие не требуются. 

Share this post


Link to post

Николай,

удалил-поставил заново. Вывод консоли ниже. Сервер по 13000 порту доступен.

Сейчас включу дебаг

[root@### tmp]# rpm -qa klnagent64
klnagent64-10.5.0-32.x86_64
[root@### tmp]#
[root@### tmp]# rpm -e klnagent64-10.5.0-32.x86_64
Stopping klnagent:
Removing /etc/rc.d/init.d/klnagent64 (0)
[root@### tmp]#
[root@### tmp]# rpm -i klnagent64-10.5.0-32.x86_64.rpm
Kaspersky Network Agent has been installed successfully but
needs to be properly configured before using.
Please run
/opt/kaspersky/klnagent64/lib/bin/setup/postinstall.pl
script by yourself to configure installed software.
[root@### tmp]# /opt/kaspersky/klnagent64/lib/bin/setup/postinstall.pl
Please enter Administration Server DNS-name or static IP-address
#########
Please enter Administration Server port number [14000]:
Please enter Administration Server ssl port number [13000]:
Please enter 'Y' to confirm that you want to use SSL encryption
or enter 'N' to use non-encrypted communication [Y]:
The Network Agent being installed can be used as connection
gateway. It will allow you to connect to Administration Server
using the specified connection gateway.
1) Do not configure connection gateway
2) Do not use connection gateway
3) Connect to server using connection gateway
4) Use as connection gateway
Please choose connection gateway mode: [1]:
Starting klnagent:
Kaspersky Network Agent is installed.
Binaries were installed in /opt/kaspersky/klnagent64/bin
[root@### tmp]# /opt/kaspersky/klnagent64/bin/kl
klmover   klnagchk
[root@### tmp]# /opt/kaspersky/klnagent64/bin/klnagchk
Starting klnagchk utility
Checking command-line arguments...OK
Initializing basic libraries...OK
Current host is '#########'
Network agent version is '10.5.0.32'

Reading settings...OK
Checking settings...OK
Administration Agent settings:
  Server address: '#########'
  Use SSL: 1
  Compress traffic: 1
  Server SSL ports: '13000'
  Server ports: '14000'
  Use proxy: 0
  Certificate: absent
  Open UDP port: 1
  UDP ports: '15000'
  Ping period, minutes: 15
  Conn timeout, s: 30
  RW timeout, s: 180
  HostId:

Connecting to server...OK
Connecting to the Administration Agent...OK
Administration Agent is running
Acquire Administration Agent statistics...OK
  Administration Agent statistics:
  Ping count: 0
  Succ. pings: 0
  Sync count: 0
  Succ. syncs: 0
  Last ping:

Deinitializing basic libraries...OK
[root@### tmp]#

Share this post


Link to post

Дебаги отправил личным сообщением. Не хочу в публичный форум выкладывать

Share this post


Link to post

Сервер появился в нераспределенных, но что-то с ним не то - задача по распространению ключа вот уже минут 10 отрабатывает.

UPD, А вот и устройство стало недоступным (по проверке доступности из KSC) 

Edited by biryukov

Share this post


Link to post

Добрый день!

В Beta-версии продукта не поддерживаются коммерческие ключи.

Для анализа, почему хост недоступен, необходимо включить Debug продукта и klnagent  без их переустановки, снять и прислать трэйсы в момент недоступности хоста.

Спасибо!

Share this post


Link to post

Виталий, 

а причем тут коммерческие ключи? Я тестовый ключ распространял. В один-то сервер успешно (в разделе про успешное тестирование отписывал).

Дебаги сейчас сделаю, если места хватит в разделах.

Share this post


Link to post

Пока сервер на связи. Отладка включена, надеюсь, места на выходные хватит. В понедельник отпишу - пропал или все ок.

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.