Jump to content
Mikhail_Yaroslavl

Ошибка при установке Агента администрирования KSC 10.2.434 [Решено] [1731592]

Recommended Posts

36 минут назад, Evgeny_E сказал:

Попробуйте использовать данную утилиту https://support.kaspersky.ru/13088

Если после применения возникнет проблема при установке потребуется новый отчет GSI он будет содержать необходимые журналы. 

Супер! После использования данной утилиты Агент администрирования и клиент встали без проблем.

Спасибо!

Share this post


Link to post

Доброго времени суток...

Возникла подобная проблема. Ни в какую не хочет устанавливаться агент KSC 10.2.434

Как все происходило :

У нас в организации производилась миграция на новый домен. Все рабочие станции и сервера успешно переехали в плоть до самого сервера на котором установлен KSC 10.2.434

Все компьютеры  и серверы благополучно через ГП удалили старых агентов и установили новых с настройками из нового домена.

Но как бывает один сервер (до миграции естественно работал, т.е. стоял агент и KES 10)

Старый агент благополучно удалился при выходе из старого домена, а новый благополучно установился но...

Консоль KSC показала что он не установлен и соответственно и сам KES 10 типа тоже, ну и естественно перестал обновляться.

Ну я тут наверное погорячился не спорю, решил его удалить и поставить по новому. Все благополучно, без ошибок, удалилось и агент и антивирус.

Попробовал его не через политики удаленно установить, он опять таки благополучно установился, но KSC опять показал, что типа нет........

Решил его удалить и установить с помощью политики. Он опять удалился без ошибок.

А теперь не хочет устанавливаться ни в какую. Пробовал очистить утилитами cleaner.exe с обеими ключами и kavremvr.exe  и неоднократно

после этого ни политикой ни удаленно ни локально не хочет устанавливаться .....

Конечно поспешил, нужно было решить вопрос почему не видит его KSC ну теперь пока возник этот вопрос.

Единственное что могу сказать, что при запуске локального установщика выдает ошибку: 

         -----   Не удалось однозначно определить состояние  установленной программы. Удалите программу вручную или воспользуйтесь утилитой деинсталляции.

Хотя он без ошибок удалился и после этого я уже раза три чистил утилитами, ну ни ставиться хоть ты тресни. Та же ошибка.

Пробовал запускать и от локального пользователя, результат тот же.

Прикладываю логи установки удаленной и локальной ошибка похожая.

00000EF4.00001538 L1  KLERR: #1, Error was caught in CInstaller::Initialize, .\installer.cpp@198. Error params: (1181/0x648 ("System error 0x648 (Unknown property.)"), "KLSTD", ..\..\..\extern\installer\install_utils.cpp@684)

 

В логах сервера вот такие события:

1. Программа: Агент администрирования Kaspersky Security Center - Ошибка при удалении.

2. Windows Installer removed the product. Product Name: Агент администрирования Kaspersky Security Center. Product Version: 10.2.434. Product Language: 1049. Manufacturer: ЗАО "Лаборатория   Касперского". Removal success or error status: 1603.

3. Ending a Windows Installer transaction: {ed1c2d7e-5c7a-48d8-a697-57d1c080aba7}. Client Process Id: 896.

4. Программа: Агент администрирования Kaspersky Security Center - Ошибка 25002. В процессе установки произошла ошибка: System error 0x3 (The system cannot find the path specified.).

 

Сервер Windows 2008 R2 Enterprise SP1 x64

Подскажите в чем может быть проблема 

 

 

 

 

 

$klnagent-setup-2018-12-19-18-49-42.log

$klnagent-setup-2018-12-19-19-29-32.log

Share this post


Link to post

Добрый день.

Пришлите, пожалуйста, GSI отчет с компьютера где возникла проблема , включите сбор событий Windows при формировании отчета. 

Используйте последнюю доступную утилиту http://media.kaspersky.com/utilities/ConsumerUtilities/GetSystemInfo6.2.zip

Share this post


Link to post
11 часов назад, Evgeny_E сказал:

Добрый день.

Пришлите, пожалуйста, GSI отчет с компьютера где возникла проблема , включите сбор событий Windows при формировании отчета. 

Используйте последнюю доступную утилиту http://media.kaspersky.com/utilities/ConsumerUtilities/GetSystemInfo6.2.zip

К сожалению эта утилита не запускается на сервере, прямо заколдованный ......

ругается "Unable to unpack critical file GsiSharp.bin".

Пришлось собрать информацию используя утилиту удаленной диагностики Klactgui

Утилита показывает что ничего связанного с KES не установлено....

 

0001-sysinfo-result.cab

0005-$klriwrp.cab

0006-$klrbtagt.cab

Share this post


Link to post

Доброго еще раз.

Короче все разрешилось. !!!!!   Ура .....

Отменил ГП установки агента, применил политику. Перезагружать не стал.

Удалил ветки реестра:

HKEY_CLASSES_ROOT\Installer\Products\E7D2C1DEA7C58D846A79751D0C08BA7A

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\E7D2C1DEA7C58D846A79751D0C08BA7A

Как я заметил они появляются после применения политики установки агента и как выясняется является сигналом о неопределенном

состоянии установки для локального инсталлятора  Агента администрирования.

И после этого процесс локальной установки пошел.

Все установилось и увиделось в KSC.

Далее уже с KSC установил KES как обычно, все ......

Вернул политику обратно, что бы не удалился после перезагрузки :) 

Странно почему через ГП перестал устанавливаться, непонятно, может потому что второй раз установил удаленно, 

ну да бог  с ним, больше разбираться некогда.

 

Спасибо за помощь и попытку разобраться.

 

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.