Jump to content
Halfer

Ошибка после обновления.

Recommended Posts

А в сети не ограничений на прокси/firewall/по трафику/наличию интернета нет?

 

:-)

Нет. Более того, если бы это в AVP работало корректно, то Вы бы не просили присылать тоже самое на ваш ftp.

 

Share this post


Link to post

Всем привет,

 

Как оказалось, проблемы были не в апдейте - это ошибка в антивирусном движке, которую пропустили при тестировании новых версий продуктов. Причин две:

 

- переход на новую версию компилятора (MSVC 8.0).

- тесты для конкретного куска кода не проводились.

 

Дело в том, что если раньше старые версии MSVC компилировали этот конкретный кусок кода, на котором и проявилась ошибка, корректно, то новая же версия перестала это делать, при этом она не выдавала никаких предупреждений (линуксовые компиляторы выдавали на этот код предупреждение - и в линуксовом движке этой ошибки нет). Про тестирование данного кода мы просто не подумали, поскольку написан он был аж в 1996(!) году и был тестирован не один десяток раз, но под старыми компиляторами.

 

Естественно, что уже приняты все необходимые меры для предотвращения подобных инцидентов в будущем: исправлены тест-планы (ручные и автоматические), составлен краткосрочный и долгосрочный план работ по улучшению качества разработки и тестирования наших продуктов и технологий.

 

Приношу свои извинения за доставленные проблемы :-(

 

Share this post


Link to post

Евгений Валентинович, а ошибка движка будет исправлена в МП1?

Edited by Umnik

Share this post


Link to post
Евгений Валентинович, а ошибка движка будет исправлена в МП1?

В 7.0 MP1 эта ошибка исправлена. В WKS / FS 6.0 исправление войдет в следующий MP/CF (не знаю, что и когда будет).

Share this post


Link to post
В 7.0 MP1 эта ошибка исправлена. В WKS / FS 6.0 исправление войдет в следующий MP/CF (не знаю, что и когда будет).

 

Извините за назойливость, но но могли бы Вы попросить ответить здесь того, кто знает когда будет? На что нам расчитывать?

 

Share this post


Link to post

В тему, может интересно будет. У меня на одном сервере стоит Enterprise Edition 6.0.0.454 так вот он работал нормально.

Share this post


Link to post
В тему, может интересно будет. У меня на одном сервере стоит Enterprise Edition 6.0.0.454 так вот он работал нормально.

У меня тоже

Но на всякий случай я его тоже перезагрузил (под шумок ;)), да и давно пора было по др. причинам

 

Объявил всем пользователям, что для усиления защиты от вирусов, крайне необходимо перезагрузить компы

До обеда не перезагрузились только 2 (ну им по некоторым причинам - надо было доработать до обеда)

 

В обед выгнал всех из сети и перезагрузил 2 раб.станции и сервер

Edited by Kapral

Share this post


Link to post
Извините за назойливость, но но могли бы Вы попросить ответить здесь того, кто знает когда будет? На что нам расчитывать?

WKS 6.0 MP4 выйдет вместе с Админ Китом 7.0 осенью 2008 года.

Share this post


Link to post
WKS 6.0 MP4 выйдет вместе с Админ Китом 7.0 осенью 2008 года.

 

У меня эта проблема вылезла в пятницу, но более-менее порешалась, сервера не вешались, но ошибку выдавало, после какого-то из обновлений админкита и станций все пришло в норму. Сегодня остатки (по симптомам) вылезли еще на двух машинах (сервер и рабочая станция). Перезагрузки не помогли. На рабочей станции переинсталлировал поверху антивирус - все порешалось. На сервере проблема более серьезная. Сервер находится далеко (канал 64к). В субботу его вырубили. Включили в понедельник, отработал нормально. Сегодня начались проблемы , канал загружен сервер тормозит. Оказалось антивирус выдает ошибку (как в пятницу), забил своими дампами весь диск c: и при попытке обновиться с админкита продолжает выдавать ошибку и пытаться записать дампы. Пока не вырубил админкит (чтобы сервер не тянул обновления) не мог зайти на его консоль, теперь качаю антивирус для сервера,чтобы заинсталить поверху. Уже полдня прошло. Пока не закачал.

 

Вопрос. Должна же быть возможность, чтобы админ зная пароль мог остановить антивирус на сервере. Она есть или будет?

 

P.S. Думал обновить версии антивирусов на серверах, теперь не знаю, стоит ли...

 

Share this post


Link to post
P.S. Думал обновить версии антивирусов на серверах, теперь не знаю, стоит ли...

 

Стоят WKS 6.0.2.690, собрался было переходить на 6.0.3.837, но начались проблемы с обновлениями через АдминКит.

Пришлось отложить эту затею...

 

Теперь думаю, стоит ли переходить?

Edited by derxyz

Share this post


Link to post
WKS 6.0 MP4 выйдет вместе с Админ Китом 7.0 осенью 2008 года.

Замечательно! :bravo:

А до тех пор нам что делать? Откатиться на пятую версию?

Share this post


Link to post
Замечательно! :bravo:

А до тех пор нам что делать? Откатиться на пятую версию?

А в чем проблема с версией 6.0?

Та ошибка, которая случилась, это исключительный вариант. Сценарий тестирования баз по этой ошибке добавлен.

Share this post


Link to post
А в чем проблема с версией 6.0?

Та ошибка, которая случилась, это исключительный вариант. Сценарий тестирования баз по этой ошибке добавлен.

Ситуация такая: продукт Kaspersky Business Space Security, лицензия на 60 рабочих станций, а именно Антивирус Касперского для Windows Workstations версий 6.0.3.830 и 6.0.3.837, админкит версии 6.0.1572, Windows 2000 Professional SP4 + все заплатки от Microsoft, Office XP (2002) со всеми заплатками от Microsoft. В установленном антивирусном продукте используются все модули, Анти-спам интегрирован с Office Outlook, созданы правила для Антиспама. Начиная с пятничного утра продолжается кавардак. Все машины при включении по 5-15 минут загружались, после старта, если у пользователя хватало терпения дождаться такой загрузки, Outlook был недоступен, сеть недоступна, машины в полузависшем положении. Далее. Делаем кнопкой рестарт, загружаемся без сетевого шнура (патч-корд вынимаем) нормально. При этом, если подключить обратно сетевой провод, все продолжает работать. Методом проб и ошибок находим, что если удалить компоненты Антиспам, Антишпион, Антихакер и Проактивную защиту, то можно загрузиться и в нормальном режиме. Можно даже и работать нормально. Однако, после перезагрузки в некоторых случаях операционка опять не может нормально загрузиться. Не везде. На каких-то компьютерах загружается. Закономерность пока выявить не удалось. При этом почти все машины с Windows XP Professional нормально работают со всеми компонентами защиты, кроме одной, которая зависала при обновлении антивируса. За пятницу, понедельник и сегодняшний день перепробованы, кажется, все мыслимые варианты сочетания компонентов Антивируса Касперского, версий 830 и 837, вариантов переустановки и установки после деинсталляции. К сожалению, по-прежнему не каждая перезагрузка (или просто включение) рабочей станции оканчиваются нормальной загрузкой операционной системы. Иногда, после долгого ожидания, приходится пользоваться кнопкой. :angry:

Share this post


Link to post

При обновлении локальной машины с инета вылетает ошибка обновления компонента AVS и AS , при этом ругается на подписи файлов. Что это значит? Логи нужны?

Share this post


Link to post
При обновлении локальной машины с инета вылетает ошибка обновления компонента AVS и AS , при этом ругается на подписи файлов. Что это значит? Логи нужны?

Присылайте логи и трассировки.

Share this post


Link to post
Ситуация такая: продукт Kaspersky Business Space Security, лицензия на 60 рабочих станций, а именно Антивирус Касперского для Windows Workstations версий 6.0.3.830 и 6.0.3.837, админкит версии 6.0.1572, Windows 2000 Professional SP4 + все заплатки от Microsoft, Office XP (2002) со всеми заплатками от Microsoft. В установленном антивирусном продукте используются все модули, Анти-спам интегрирован с Office Outlook, созданы правила для Антиспама. Начиная с пятничного утра продолжается кавардак. Все машины при включении по 5-15 минут загружались, после старта, если у пользователя хватало терпения дождаться такой загрузки, Outlook был недоступен, сеть недоступна, машины в полузависшем положении. Далее. Делаем кнопкой рестарт, загружаемся без сетевого шнура (патч-корд вынимаем) нормально. При этом, если подключить обратно сетевой провод, все продолжает работать. Методом проб и ошибок находим, что если удалить компоненты Антиспам, Антишпион, Антихакер и Проактивную защиту, то можно загрузиться и в нормальном режиме. Можно даже и работать нормально. Однако, после перезагрузки в некоторых случаях операционка опять не может нормально загрузиться. Не везде. На каких-то компьютерах загружается. Закономерность пока выявить не удалось. При этом почти все машины с Windows XP Professional нормально работают со всеми компонентами защиты, кроме одной, которая зависала при обновлении антивируса. За пятницу, понедельник и сегодняшний день перепробованы, кажется, все мыслимые варианты сочетания компонентов Антивируса Касперского, версий 830 и 837, вариантов переустановки и установки после деинсталляции. К сожалению, по-прежнему не каждая перезагрузка (или просто включение) рабочей станции оканчиваются нормальной загрузкой операционной системы. Иногда, после долгого ожидания, приходится пользоваться кнопкой. :angry:

Попробуйте одну машину обновить с ftp://dnl-test.kaspersky-labs.com/beta_updates/tim2 и перегрузить машину. Проблемы исчезнут?

Share this post


Link to post

Такая же фигня, все компьютеры стали загружать по 5-10 минут. До последних обновлений все было нормально. Еще сегодня стали жаловать что стал зависать TheBat! при сканировании почты в момент получения!!! Что не нормальное твориться последние деньки. УЖЕ ВСЕ ЭТО РАЗДРАЖАТЬ НАЧИНАЕТ!!!!

Share this post


Link to post
Присылайте логи и трассировки.

Какой утилитой собрать?

 

Share this post


Link to post
Такая же фигня, все компьютеры стали загружать по 5-10 минут. До последних обновлений все было нормально. Еще сегодня стали жаловать что стал зависать TheBat! при сканировании почты в момент получения!!! Что не нормальное твориться последние деньки. УЖЕ ВСЕ ЭТО РАЗДРАЖАТЬ НАЧИНАЕТ!!!!

 

Теперь еще и зависают, помогает толька хард ресет!!!!

Share this post


Link to post

Наталья, собрать не получится. Только что обновление прошло успешно. Просит перезагрузку. Проверим... Если что - выложу. Еще раз спасибо.

Share this post


Link to post

А у меня уже с неделю при первом запуске Win 2000 Pro WKS 6.0.3.830 явно зависает служба DNS, в ивентах стоит, что групповые политики не применились :(

Сеть при этом есть, интернета нет, tracert висит напрочь.

Перезагрузка обычно помогает., но нормально выключить компьютер никак не удается, похоже не может сохранить профиль.

Share this post


Link to post
А у меня уже с неделю при первом запуске Win 2000 Pro WKS 6.0.3.830 явно зависает служба DNS, в ивентах стоит, что групповые политики не применились :(

Сеть при этом есть, интернета нет, tracert висит напрочь.

Перезагрузка обычно помогает., но нормально выключить компьютер никак не удается, похоже не может сохранить профиль.

Попробуйте одну машину обновить с ftp://dnl-test.kaspersky-labs.com/beta_updates/tim2 и перегрузить машину. Проблемы исчезнут?

Share this post


Link to post
Попробуйте одну машину обновить с ftp://dnl-test.kaspersky-labs.com/beta_updates/tim2 и перегрузить машину. Проблемы исчезнут?

(Кстати, симптомы, указанные Peskind, у меня тоже в наличии, только началось это шоу в пятницу.)

 

Попробовал. Перезагрузился пять раз - пока полет нормальный. Утро покажет, как говорится. Если все будет хорошо, завтра попробую еще несколько машин обновить не с сервера администрирования, а с этого источника.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.