Jump to content
Sign in to follow this  
burkm

Problem Boot time defrag Diskeeper

Recommended Posts

Hi there,

 

has the problem been resolved in the meantime not being able to defrag during boot time because KIS is accessing the disk ?

 

I followed the suggestions given in some earlier post by adding DKService.exe to the trusted applications list. No success...

 

I use KIS 7.0.123.

 

Thanks - burkm

Edited by burkm

Share this post


Link to post
hello

i have no problems doing boot time defrags with both diskeeper & o &o defrag. TRy upgrading to build 125, maybe it helps

396210[/snapback]

 

OK.

 

But where do I find .125 ?

I bought mine in a store.

 

burkm

Share this post


Link to post
hello

i have no problems doing boot time defrags with both diskeeper & o &o defrag. TRy upgrading to build 125, maybe it helps

396210[/snapback]

 

Well, after installing KIS 7.0.0125 nothing has changed.

DkService is in the trusted apps list.

Diskeeper 10 still tells me, that another program is accessing the disk during boot time defrag and stops working.

 

So the problem still persists.

 

Would You please provide any settings on Your side for getting the program to run.

 

burkm

Edited by burkm

Share this post


Link to post
does uninstalling kis help (have you checked that)?

396256[/snapback]

 

Hi Lucian,

 

deinstalling KIS 7.0.0.125 immediately allowed Diskeeper 10 boot time defrag to run without problems.

Reinstalling KIS afterwards let to the same problems again... no more boot time defrag.

Diskeeper is delivering the message:

"Some other program is using the disk. Diskeeper needs exclusive access to the disk and the MFT to continue. Arborted. Press ESC to reboot."

 

Any idea or remedy ?

 

burkm

Edited by burkm

Share this post


Link to post

Maybe not the perfect "solution" ... but I use PerfectDisk and have the same problem with the Boot time defrager.

 

My solution is to pause KIS (with the option of "By User Request Only") *before* I let PerfectDisk shutdown the computer. Doing this allows the B-T-D to run uninterrupted and as soon as windows boots back up ... I unpause KIS.

 

As a background, I am running Vista Ultimate 64 and KIS 7.0.0.125.

Share this post


Link to post
Maybe not the perfect "solution" ... but I use PerfectDisk and have the same problem with the Boot time defrager.

 

My solution is to pause KIS (with the option of "By User Request Only") *before* I let PerfectDisk shutdown the computer. Doing this allows the B-T-D to run uninterrupted and as soon as windows boots back up ... I unpause KIS.

 

As a background, I am running Vista Ultimate 64 and KIS 7.0.0.125.

396758[/snapback]

 

Nice workaround...

 

But I would rather have an automatic approach, because I might forget to reenable KIS after the following boot. One never knows....

 

burkm

Share this post


Link to post

Hi!

This thread seems to have gone dead but I am experiencing the same problem.

 

Using Diskeeper 10 with KIS 2009 - can not Boot time defrag the system partition without uninstalling KIS - not a practical solution.

 

I am a big fan of KIS but this is a HUGE shortcoming of the software - can anyone help from Kerpersky?

 

Share this post


Link to post

Just another small bump because I just ran into this problem myself for the first time.

 

I've never had this issue before, and I've been using both KIS and Diskeeper together for a couple of years now.

 

I rebuilt my system this weekend, and today I installed v.8.0.0.506 (newest release as of today) whereas the last version I manually installed fresh was v.8.0.0.454. If last week (when everything was still working fine) I was actually running v.8.0.0.506 due to KIS' updates (I always have it run in automatic mode), I couldn't say. Will KIS update itself automatically, or does that only apply to the virus databases?

 

 

have you tried putin klif to run on demand?

 

boot in safe mode, there open regedit through start->run, type in regedit and press ok.

in the left side navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Klif

in the right side you will see a Start entry with the value 1, double click it and set the value to 3. close regedit and reboot

 

That just gives you this:

 

kiserrorrk4.jpg

Edited by Zach

Share this post


Link to post
why did you bother to post in someone else's topic?

I used the search function to find a solution to my problem and found this thread which is identical to my problem. :rolleyes: Why start a new thread? Odds are I would be told to use the search function anyway. Catch-22, I guess. :dash2:

 

 

are you sure you set it to 3 and not 4?

Yes.

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.