Jump to content
sonofanarchy

Not able to visit a lot of HTTPS websites ERR_SSL_VERSION_INTERFERENCE [merged]

Recommended Posts

Can anyone please help me with this question that's bugging me. I am not an expert so I couldn't find the answer myself. Why this problem sometimes happen and sometimes don't. The Kaspersky algorithm isn't changed, website certificate's the same, Chrome settings are the same. What is missing here?

Edited by temp2018

Share this post


Link to post
50 minutes ago, cc2150dx said:

Same issue with KIS 2019(c) . Tech support told me to disable TLS within Chrome. The issue is fixed for now.

So they told you to disable Chrome attempting to always make a secure connection. While that does stop the error, it does make your browser less secure as you are now no longer attempting to use https automatically, but allows Kaspersky to check the page without problems.  That's not really a good solution, but it allows Support to say they "fixed" the issue, while leaving you using unencrypted connections.

I'm having the same issue with Firefox, so it's not really Chrome issue, it's a Kaspersky issue.

Edited by The Iron Man

Share this post


Link to post

Hello, i have the same problem. And i´ld like to try the solution of MorLipf, uninstall and new install KIS. I know how to uninstall, but how can i install new when its uninstalled? Sorry for the question, but i´m someone what wie call a "DAU" (most stupid user) in Germany ;-)

Thank for your help

Share this post


Link to post
1 hour ago, The Iron Man said:

 

I'm having the same issue with Firefox, so it's not really Chrome issue, it's a Kaspersky issue.

I'm not having any issues with Firefox, just Chrome.

TLS 1.3 to be exact

Edited by cc2150dx

Share this post


Link to post

Kaspersky 2019 is having problems with TLS 1.3/Chrome since May and until now the bug wasnt fixed.

 

It is a very know issue and yet Kaspersky Lab seems to simple ignore it; Tech Support wont be of a help because it isnt a individual problem but the Kaspersky's method of  man-in-the-middle attack to check out https connections. 

Share this post


Link to post

For Firefox

Open Firefox > Go to "about:config" > search for "security.tls.version.max" > change the value from 4 to 3 > Restart Browser after.

Hope this will help :)

Share this post


Link to post

Disabling TLS 1.3 degrades the security of your https connection.  It is not a solution, it is a workaround that compromises the security and performance of your https connection in favour of having Kaspersky inspect the data.

Share this post


Link to post
59 minutes ago, The Iron Man said:

Disabling TLS 1.3 degrades the security of your https connection.  It is not a solution, it is a workaround that compromises the security and performance of your https connection in favour of having Kaspersky inspect the data.

 

55 minutes ago, nathan1992 said:

Yes it is, but it's a workaround for now :)

I agree with "The Iron Man". And till now I realized there are 4 solutions:

1- Disabling TLS in Chrome (not a good idea)

2- Disabling scan encrypted connections in Kaspersky (not a good idea)

3- Temporary adding the sites you trust to exclusions list in Kaspersky

4- Reinstalling Kaspersky (liked "MorLipf" said)

I installed Kaspersky 3 weeks ago why should I reinstall it? And then do all the settings. It's one thing if I was 100% sure it's gonna work, but I'm not. Sad part is what "xXDarkStalkerxX" said. This issue was in KIS 19 from the very beginning, and it's not been solved yet. I'm not sure Kaspersky is gonna do anything about it in the near future.

Edited by temp2018

Share this post


Link to post
4 hours ago, Glubb said:

Hello, i have the same problem. And i´ld like to try the solution of MorLipf, uninstall and new install KIS. I know how to uninstall, but how can i install new when its uninstalled? Sorry for the question, but i´m someone what wie call a "DAU" (most stupid user) in Germany ;-)

Thank for your help

Hello! To uninstall Kaspersky follow these steps: https://support.kaspersky.com/12783  (Don't forget step 7 for license information)

To install it follow this instruction: https://support.kaspersky.com/14109

If you are from Germany choose "European Union" version (for General Data Protection Regulation (GDPR)).

Edited by temp2018

Share this post


Link to post

Just to add to the numbers, Same problem here so that Kaspersky are aware.

Till Kaspersky fix this I have installed a trail version of another product (which works fine)

Edited by zooburner

Share this post


Link to post
11 hours ago, The Iron Man said:

So they told you to disable Chrome attempting to always make a secure connection. While that does stop the error, it does make your browser less secure as you are now no longer attempting to use https automatically, but allows Kaspersky to check the page without problems.  That's not really a good solution, but it allows Support to say they "fixed" the issue, while leaving you using unencrypted connections.

I'm having the same issue with Firefox, so it's not really Chrome issue, it's a Kaspersky issue.

Wrong. With no TLS 1.3 Chrome will use TLS 1.2..and the connection will be secured.

I myself disabled 'scan encrypted connections' and 'browser script injection'.

These are of no use.

Edited by alex5723

Share this post


Link to post

"Anti-Banner" seems to be the problem and a temporary fix by disabling it.

Share this post


Link to post
On 10/5/2018 at 7:42 PM, ignacio16589 said:

Same over here. I "solved" this by telling KIS not to analyze my encrypted connections. I hope that tech support found a real solution to this problem soon.

Hi

 

FYI i got a "resolution" (which ended up needing to uninstall and reinstall, but there is another offer of solution which may work for you):

 

A. Please reinstall our certificate:

Press Win+R - type certmgr.msc - expand Trusted Root Certification Authorities - Certificated - on the right-side find and delete our Kaspersky Anti-Virus Personal Root Certificate. Then right-click on Certificates on the left side - All tasks - Import - click Next - Browse... - specify path to C:\ProgramData\Kaspersky Lab\AVP19.0.0\Data\Cert - on the bottom right side click on dropped menu and choose All files - double-click on appeared 1.cert file - Next - Next - Finish. Click OK on appeared message about successful adding of certificate.

Restart browser and check whether the problem persists.

B. Also please disable all plugins except ours and check the problem reproduction.

C. If the problem still continues, please reinstall Kaspersky like so:

STEP #1

1. Place the pointer of your mouse over the Computer icon (on your Desktop or in the Start menu) and right click on it. Select Properties from the sub menu that will appear.
[http://www.howtogeek.com/wp-content/uploads/2009/08/15.png]

2. A new window will come up on your Screen. From the left hand list on the new window please select "System Protection"
[cid:pic2.png]

3. A secondary small window will come up. In the bottom of that Window there is a Button titled "Create" to create a Restore point.
[cid:pic3.png]

If the "Create" button is greyed out above the "Create" button there is a button titled "Configure". Please click on "Configure" and then select "Turn On System Protection" Now the "Create" button will be accessible.

STEP #2

Please remove all remnants of previous Kaspersky installations with the help of our Kavremover utility by performing the following:

1. Download the Kaspersky Kavremover utility via the link: http://media.kaspersky.com/utilities/ConsumerUtilities/kavremvr.exe
"How to use the utility” guide can be found here: http://support.kaspersky.com/common/service.aspx?el=1464#block1

2. Run the Kavremover.exe utility in the following manner. Accept the agreement for the tool to begin.
[http://support.kaspersky.com/images/common_1464_0113-195948.png]
The goal is to remove any Kaspersky product that was at any point installed in the operating system: Kavremover may automatically detect any installed Kaspersky product or its remnants if found, such product is displayed in the lower drop-down menu. In that case, enter the captcha (characters from the picture) into the specified field and proceed with removal.
[http://support.kaspersky.com/images/common_1464_0213-195654.png]

3. After completing the removal, please reboot your PC

[http://support.kaspersky.com/images/common_1464_0313-195951.png]

STEP #3
1. Download the latest version of Kaspersky Internet Security 2019 via direct link
https://products.s.kaspersky-labs.com/homeuser/kis2019/19.0.0.1088a/english-gb-0.1248.0/united%20kingdom%28en-gb%29/kis19.0.0.1088aen_14168.exe


2. After downloading run the downloaded file.
If you cannot see the file that has been downloaded please press on your physical keyboard CTRL & J simultaneously.
That will open a list of all the files that you have downloaded.
You will see a filename beginning with: kis19.0.0.1088aen_14168.exe place the pointer of your mouse over it and double-click it.

3. Follow the setup wizard by pressing Next, Allow, OK and Accept, when prompted;
You need to accept all the messages for the program to be installed

4, Put in your activation code when prompted

Share this post


Link to post
3 hours ago, alex5723 said:

Wrong. With no TLS 1.3 Chrome will use TLS 1.2..and the connection will be secured.

I myself disabled 'scan encrypted connections' and 'browser script injection'.

These are of no use.

TLS 1.3 has been implemented for quite some time because it provides significant performance and security improvements over 1.2.  Disabling 1.3 to go back to 1.2 is a regression in terms of security.

Share this post


Link to post
1 hour ago, Skipy said:

"Anti-Banner" seems to be the problem and a temporary fix by disabling it.

I've always had that disabled and I am having the SSL problem.

Share this post


Link to post

Well being the impatient sort, I tried the various suggestions:

1.  Reinstalling the Kaspersky cert doesn't work (because it's already installed).

2.  Removing and then reinstalling the Kaspersky cert doesn't work.

3.  Uninstalling Kaspersky, rebooting, installing Kaspersky, updating to 1088c, then rebooting again DOES WORK.  So if you're willing to lose all your settings (I only kept the licence information), it seems full removal and installation does the trick.

It should not be the case that this problem comes up ever few months, and there's no way to fix it except for an uninstall/reinstall.  While this is not a big deal in itself, losing all your settings and all the exceptions a user has set up over the months is a real pain and not a good solution for an ongoing problem that is seen time and time again.

Hope that helps someone.

Share this post


Link to post
Le 05/10/2018 à 14:52, alex5723 a dit :

Settings - Additional - Network - Do not scan encrypted connections

Thanks a lot! This was so f*** annoying! searched a lot for the problem. Only Facebook was blocked here!
Has to be fixed very soon.  

Share this post


Link to post

Experiencing the same problem here. Chrome and Firefox.
I'm running Win7 64bit and KIS 19.0.0.1088(c).

While disabling TLS 1.3 is a workaround for the time being... it's not a fix (as it degrades security quite a bit).
Hope to see a fix soon :/

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.