Jump to content
jrp1416

KES11 blocking access to USB Camera

Recommended Posts

Good Afternoon,

We have a device that we recently installed KES11 on. This device has software that needs to access a USB camera in order to function. Once we installed KES11, the software would no longer show the video from the camera. I removed KES11, and the software and camera work correctly. How do I set KES11 to allow this application to access this USB camera? Also worth noting that this is on a Windows 10 system. Thanks.

Share this post


Link to post

We don't use device control or application control, so I can't figure out why it would be stopping this application from access this USB camera.

Share this post


Link to post

@Nikolay Arinchev yes, the executable of the file is in both scan exclusions and trusted zone. This did not resolve the issue. Thanks.

I also placed the folder containing the settings for the application in the exclusions at the request of the software maker, with no change.

Edited by jrp1416
Add more information

Share this post


Link to post

Thank you for that info!

Could you please clarify is there any particular KES component causes the problem or only KES uninstallation solves the problem?

Thank you!

Share this post


Link to post

@Nikolay Arinchev there could be some settings change or disabling a component that would fix this, but the only resolution I've found so far is removing KES11. That obviously doesn't resolve my issue, so I'm hoping there's something I can change within KES to get this to work. Thanks.

Share this post


Link to post

The component causing this specific problem is the BadUSB Component in the KES 11 Policy. 

 

  1. Open the Policy
  2. Go to Essencial Protection Against Threats
  3. Select The BadUSB Attack Prevetion
  4. Clear the Prohibit use of On-Screen Keyboard for authorization of USB devices check box if you want to allow the use of the On-Screen Keyboard for authorization.
  5. Save the Policy

Hope it helps

Share this post


Link to post
2 часа назад, jrp1416 сказал:

@Konstantin Antonov I am unfamiliar with how to do this.

 

@stefano_dottori That option was already not enabled.

Hello!

To disable the policy for this machien only please go to the policy settings, open the list of machines this policy is applied to and then remove the machine from the list. 

Thanks!

Share this post


Link to post

@Konstantin Antonov when I disabled all the components, it acted like it was going to work, but when we attempted to use the camera it went back to the black screen it shows when Kaspersky is not allowing the program to access the camera.

Share this post


Link to post

Hi,

In that case please collect KES traces while you are trying access web-camera.

Since KES traces are too large to be attached to the forum, please use any file sharing resource and provide us with a link.

Thank you!

Share this post


Link to post

Thank you all for your assistance, but at this time that department has elected to remove the system from the network. As part of that, Kaspersky has been removed from this machine, so I no longer need assistance.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.