Jump to content

Recommended Posts

I have Windows Server 2012 R2, Kaspersky Security Center 10.4.343. SQL Server is installed on another server. All things going well but a week ago there is an issue in backup task.

When I run backup task it gives an error "System Error 0x5 (Access is denied)". When I take backup through klbackup utility it successfully takes backup.

The user has administrator rights, member of Administrator group, member of KLAdmins group.

I have also taken traces of klbackup but I will not share it publically, so please tell me how to deliver these traces to you.

backup.gif

Share this post


Link to post
Цитата

I cannot provide you full gsi report.

Is there a technical problem of some sort?

Please provide us with klbackup logs.

Thank you!

Share this post


Link to post

Could you please clarify that Admin server account have sufficient privelegies to access a folder you are trying to save backup?

Thank you!

Share this post


Link to post
1 hour ago, myousufhk said:

yes it has all the rights of that folder

There is a clarification to the above suggestion: both KSC and the database server account must have RW access to the folder (as stated in the klbackup article). If using the utility, the user who runs klbackup and the database server should have access.

Please make sure the database server account has the access; if the error persists, try performing the backup using the utility and let us know the result.

Thank you.

Share this post


Link to post
1 hour ago, myousufhk said:

both also have RW access, both have full control over the folder

Please clarify what path is being used for storing backups (and in which format it is specified in the task properties). For proper operation, the path should be specified in UNC format (e.g. \\servername\$share), and the folder be a network share with explicitly stated permissions.

Thank you.

Share this post


Link to post

The backup folder is in server where KSC installed. Folder path: D:\Backup\

SQL is installed in another server.

Share this post


Link to post
7 hours ago, myousufhk said:

The backup folder is in server where KSC installed. Folder path: D:\Backup\

SQL is installed in another server.

Do you have running AV and firewalls in KSC and DBMS servers ?

Is it possible to move "backup storage" to DBMS server for troubleshooting ?

Thank you.

 

Share this post


Link to post
On 8/26/2017 at 2:31 AM, Kirill Tsapovsky said:

Please clarify what path is being used for storing backups (and in which format it is specified in the task properties). For proper operation, the path should be specified in UNC format (e.g. \\servername\$share), and the folder be a network share with explicitly stated permissions.

Thank you.

Hi Krill,

Thank you so much for the help. Issue solved. When I gave UNC path it showed me the error "Invalid destination folder", then I change folder rights to everyone and backup successfully created on KSC server.

When I run backup and give folder rights to specific user it gives me error that "SQL database not have write access". So the main issue was UNC path of the destination folder.

Other errors can be troubleshoot easily.

Edited by myousufhk

Share this post


Link to post
Posted (edited)

i know this is an old thred, but i have the same error configuring backup of KSC 10.5.1781.

 

I set correct authorization in the destination folder for user running KSC, and use the folder as UNc path \\servername\backup\

 

Only setting everyone as authorized the backup works correctly but it's not the best solution, so i found another solution, i set the authorization for read and write in the folder for the "computer name" of the SQL server DB server. The question is, which user Kaspersky use for backup the DB from an external DB Server?

Edited by vashthestampede

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.