Jump to content
honkman

Microsoft SSRS/ "Socket access refused" [In progress]

Recommended Posts

I'm using SQL Server Reporting Services. The reports are also intergrated in a .Net application we've developed. Accessing the reports using a web browser is working just fine. But when I try to open that reports in the .Net application I get an error. Error: "An attempt was made to access a socket in a way forbidden by its access permissions".

It's just the standard .Net SSRS control. NOthing special.

 

How to get the reports working again? Why are this reports blocked? The .Net component is just accessing the internal SSRS server.

 

When I disable Kapsersky on a client, reports are worling fine inside the application.

 

BR

CG

Share this post


Link to post

Yes. It is the "Mail-Anti-Virus" which causes this problem. Seems kind of strange because this has nothing to do with Email.

 

I have also no idea how to define a rule on how to enable SSRS.

 

BR

CG

Share this post


Link to post

Sorry. It seems to be the "Web-Anti-Virus". That makes more sense.

 

But: I tried to define the URL as secure it the settings. But this isn't solving the issue. Any idea how to allow this reports? Again: Opening the reports in the webbrowser using the same URL is working fine.

 

BR

CG

Share this post


Link to post

Hi,

 

I have the same problem going on for months! I have to uninstall KES 10 SP1 M2 (most of the time it does not uninstall and I have to reboot first and try again) and re-install again. Everything works great for a couple of month and then it happens again on the same machine (Windows 10 Pro). The problem is affecting all the PCs (I am using KSC to deploy) not just one.

 

Please help as we have 20 PCs and I am thinking to go for a different Anti-Virus.

 

Thanks

 

Share this post


Link to post
Hi,

 

I have the same problem going on for months! I have to uninstall KES 10 SP1 M2 (most of the time it does not uninstall and I have to reboot first and try again) and re-install again. Everything works great for a couple of month and then it happens again on the same machine (Windows 10 Pro). The problem is affecting all the PCs (I am using KSC to deploy) not just one.

 

Please help as we have 20 PCs and I am thinking to go for a different Anti-Virus.

 

Thanks

 

Hello,

 

please describe the exact technical problem which you've faced.

Please attach KL software report and full GSI report from the problem host.

Thank you.

Share this post


Link to post

20 PC (Win10) and 1 Server (WS2012R2) with SQL Server Reporting Services 2014 on the same LAN.

Bespoke .NET application which connect to the server to display SSRS reports.

 

The following error happens randomly on any PC every 1/2 months:

 

System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions "Server IP":80

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at Microsoft.Reporting.WinForms.Internal.Soap.ReportingServices2005.Execution.RSExe

cutionConnection.GetSecureMethods()

at Microsoft.Reporting.WinForms.Internal.Soap.ReportingServices2005.Execution.RSExe

cutionConnection.IsSecureMethod(String methodname)

at Microsoft.Reporting.WinForms.Internal.Soap.ReportingServices2005..Execution.RSEx

ecutionConnection.SetConnectionSSLForMethod(String methodname)

at Microsoft.Reporting.WinForms.Internal.Soap.ReportingServices2005.Execution.RSExe

cutionConnection.ProxyMethodInvocation.Execute[TReturn](RSExecutionConnection connection, ProxyMethod`1 initialMethod, ProxyMethod`1 retryMethod)

at Microsoft.Reporting.WinForms.Internal.Soap.ReportingServices2005..Execution.RSEx

ecutionConnection.LoadReport(String Report, String HistoryID)

at Microsoft.Reporting.WinForms.SoapReportExecutionService.LoadReport(String report, String historyId)

at Microsoft.Reporting.WinForms.ServerReport.EnsureExecutionSession()

at Microsoft.Reporting.WinForms.ServerReport.SetParameters(IEnumerable`1 parameters)

 

 

Current Fix (very annoying):

 

Uninstall of KES 10 SP1 M2 (working only after a reboot)

Install of KES 10 SP1 M2

 

The fix works for 1/2 months and then same error on the same PCs

 

"Please attach KL software report and full GSI report from the problem host."... How can I do that?

 

Many Thanks

Omar

 

Share this post


Link to post
20 PC (Win10) and 1 Server (WS2012R2) with SQL Server Reporting Services 2014 on the same LAN.

Bespoke .NET application which connect to the server to display SSRS reports.

 

The following error happens randomly on any PC every 1/2 months:

 

System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions "Server IP":80

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at Microsoft.Reporting.WinForms.Internal.Soap.ReportingServices2005.Execution.RSExe

cutionConnection.GetSecureMethods()

at Microsoft.Reporting.WinForms.Internal.Soap.ReportingServices2005.Execution.RSExe

cutionConnection.IsSecureMethod(String methodname)

at Microsoft.Reporting.WinForms.Internal.Soap.ReportingServices2005..Execution.RSEx

ecutionConnection.SetConnectionSSLForMethod(String methodname)

at Microsoft.Reporting.WinForms.Internal.Soap.ReportingServices2005.Execution.RSExe

cutionConnection.ProxyMethodInvocation.Execute[TReturn](RSExecutionConnection connection, ProxyMethod`1 initialMethod, ProxyMethod`1 retryMethod)

at Microsoft.Reporting.WinForms.Internal.Soap.ReportingServices2005..Execution.RSEx

ecutionConnection.LoadReport(String Report, String HistoryID)

at Microsoft.Reporting.WinForms.SoapReportExecutionService.LoadReport(String report, String historyId)

at Microsoft.Reporting.WinForms.ServerReport.EnsureExecutionSession()

at Microsoft.Reporting.WinForms.ServerReport.SetParameters(IEnumerable`1 parameters)

Current Fix (very annoying):

 

Uninstall of KES 10 SP1 M2 (working only after a reboot)

Install of KES 10 SP1 M2

 

The fix works for 1/2 months and then same error on the same PCs

 

"Please attach KL software report and full GSI report from the problem host."... How can I do that?

 

Many Thanks

Omar

 

Hello,

 

the problem arises randomly and approximately twice a month.

Why do you think that KES is guilty ? Please explain.

Is it acceptable to upgrade KES to MR3 ?

Thank you.

Share this post


Link to post

because if I disable a few components on KES or uninstall KES I dont get the error and the .NET application works fine and display the reports

Share this post


Link to post

I just created the package on KSC but it says: "The installation packacge..... for Kaspersky Endpoint Security 10 Service Pack 1 Maintenance Release 2 for Windows v. 10.2.5.3201 has been successfully created.

 

.... it was supposed to be Maintenance Release 3?!?!?! What's wrong with you guys at KL?!?!

Share this post


Link to post
The following error happens randomly on any PC every 1/2 months:

Current Fix (very annoying):

Uninstall of KES 10 SP1 M2 (working only after a reboot)

Install of KES 10 SP1 M2

The fix works for 1/2 months and then same error on the same PCs

 

 

I think I have the same issue as mentioned by others in this thread.

I am fighting with an issue for several months that is intermittent but is DEFINITELY caused by Kaspersky KES10. It has something to do with certain HTTPS/encrypted connections. I have not been able to use KSC policies/exceptions/whitelists to solve the issue because it affect programs that install into USER profiles and one application uses non-static directories that change over time.

I was hopeful that the issue would be addressed in MR3 because I saw a PF that mentioned “connections to GoToMeeting being blocked”. (which was one of the apps involved.)

I have started rolling out KES10 MR3 a few weeks ago, and came across another computer with this problem. So I opted to run an upgrade TASK from KSC to update MR2 to MR3 on that computer. But the HTTPS problem still existed.

 

The temporary ‘fix’, is to manually uninstall Kaspersky Endpoint 10 using Windows Control Panel (add/remove), then reboot, then reinstall it. Then the symptoms are gone, and memory usage is back to normal, for a few months at most...

Are there any Private Fixes (PFs) that didn’t make it into KES10 MR3 that involve solving an issue with four interrelated components: IM AV, WEB AV, EMAIL AV, and WEB CONTROL on Windows 10 64bit?

 

Additional details:

I’ve been keeping notes. The first time it happened was in April (5 months ago) on the first computer I upgraded to Windows 10 (1511) along with KES10 MR2 (10.2.4.674).

Here is a list of things this issue has affected: (and in all cases, the problem goes away if I disable IM AV, WEB AV, EMAIL AV and WEB CONTROL components.) All four must be disabled.

1. GoToMeeting - Connection errors. Exiting KES10 allowed connection to continue.

2. Skype - Didn’t record the exact errors. Exiting KES10 allowed connection to continue.

3. Our accounting software. It uses HTTPS and .NET to make connections internally. Reporting Services error says “Unable to connect to the remote server. An attempt was made to access a socket in a way forbidden by its access permissions. IP: xxx.xxx.xxx.xxx:443”

4. Remote Desktop software. (3rd party, not Microsoft.) I was able to confirm KES10 was at fault multiple times.

5. Parts of DELL.COM website. Tried adding website to Web Control policy as an exception. Nothing in logs indicating a problem. Exit KES10, worked fine. Restarted KES10, stopped working.

 

In all cases, uninstalling, rebooting and reinstalling KES10 MR2/MR3 cleared up the issue temporarily as it seems to return in several weeks or a few months. (Well, I haven't had a documented 'repeat' with MR3 yet, but only time will tell. But since I 'upgraded' an affected workstation from MR2 to MR3 (using KSC task) and the problem remained intact, I am not confident MR3 doesn't have the same issue.)

 

Share this post


Link to post
I just created the package on KSC but it says: "The installation packacge..... for Kaspersky Endpoint Security 10 Service Pack 1 Maintenance Release 2 for Windows v. 10.2.5.3201 has been successfully created.

 

.... it was supposed to be Maintenance Release 3?!?!?! What's wrong with you guys at KL?!?!

 

Actually, that's a 'feature'. They purposely did that to fast-track MR3 out the door for the Anniversary Update and to allow the Policies/Tasks/etc of KSC to remain 100% compatible with MR2 stuff.

At least that is what I read earlier in the forum. Still looked a bit unprofessional, regardless.

Share this post


Link to post
Actually, that's a 'feature'. They purposely did that to fast-track MR3 out the door for the Anniversary Update and to allow the Policies/Tasks/etc of KSC to remain 100% compatible with MR2 stuff.

At least that is what I read earlier in the forum. Still looked a bit unprofessional, regardless.

 

Reports work correctly, but after two weeks reports don't work completely.

After that you reinstall KES and reports work correctly next two weeks and the error repeats.

Is it correct ?

Thank you.

 

Share this post


Link to post

I also noticed when running Integrity Check task on the affected PC I get these warnings:

 

Event type: Module signature check failed

Application\Name: Kaspersky Endpoint Security 10 for Windows

Application\Path: c:\program files (x86)\kaspersky lab\kaspersky endpoint security 10 for windows sp1\

User: REGENTGAS\PMandair (Active user)

Component: Integrity check

Result\Description: Failed

Object: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\kneps_x64_602\kneps.sys

Object\Type: File

Object\Path: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\kneps_x64_602\

Object\Name: kneps.sys

 

Event type: Module signature check failed

Application\Name: Kaspersky Endpoint Security 10 for Windows

Application\Path: c:\program files (x86)\kaspersky lab\kaspersky endpoint security 10 for windows sp1\

User: REGENTGAS\PMandair (Active user)

Component: Integrity check

Result\Description: Failed

Object: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\klwfp_x64\klwfp.sys

Object\Type: File

Object\Path: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\klwfp_x64\

Object\Name: klwfp.sys

 

Event type: Module signature check failed

Application\Name: Kaspersky Endpoint Security 10 for Windows

Application\Path: c:\program files (x86)\kaspersky lab\kaspersky endpoint security 10 for windows sp1\

User: REGENTGAS\PMandair (Active user)

Component: Integrity check

Result\Description: Failed

Object: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\klim6_x64_602\klim6.sys

Object\Type: File

Object\Path: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\klim6_x64_602\

Object\Name: klim6.sys

 

Event type: Module signature check failed

Application\Name: Kaspersky Endpoint Security 10 for Windows

Application\Path: c:\program files (x86)\kaspersky lab\kaspersky endpoint security 10 for windows sp1\

User: REGENTGAS\PMandair (Active user)

Component: Integrity check

Result\Description: Failed

Object: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\klfltdev_x64_602\klfltdev.sys

Object\Type: File

Object\Path: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\klfltdev_x64_602\

Object\Name: klfltdev.sys

 

Event type: Module signature check failed

Application\Name: Kaspersky Endpoint Security 10 for Windows

Application\Path: c:\program files (x86)\kaspersky lab\kaspersky endpoint security 10 for windows sp1\

User: REGENTGAS\PMandair (Active user)

Component: Integrity check

Result\Description: Failed

Object: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\klif_x64_nt602\klflt.sys

Object\Type: File

Object\Path: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\klif_x64_nt602\

Object\Name: klflt.sys

 

Event type: Module signature check failed

Application\Name: Kaspersky Endpoint Security 10 for Windows

Application\Path: c:\program files (x86)\kaspersky lab\kaspersky endpoint security 10 for windows sp1\

User: REGENTGAS\PMandair (Active user)

Component: Integrity check

Result\Description: Failed

Object: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\klif_x64_nt602\klif.sys

Object\Type: File

Object\Path: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security 10 for Windows SP1\klif_x64_nt602\

Object\Name: klif.sys

 

 

so it looks like KES get corrupted after a few weeks!

Share this post


Link to post

Thanks for the Tip. Never used Integrity check before. On unaffected computer, it comes up clean. On an affected computer, it shows 'module signature check failed' on 239 of 270 modules, with a result of 'write error'. Now I have a way to check the status of my KES10 clients remotely and not involving the users. Thanks. If anyone else is having this issue, please add a comment, even if it is just "me too".

Share this post


Link to post
Thanks for the Tip. Never used Integrity check before. On unaffected computer, it comes up clean. On an affected computer, it shows 'module signature check failed' on 239 of 270 modules, with a result of 'write error'. Now I have a way to check the status of my KES10 clients remotely and not involving the users. Thanks. If anyone else is having this issue, please add a comment, even if it is just "me too".

Hi,

 

Please collect GSI report with enabled event logs and kes traces in moment of reproduction.

You can provide it through any filesharing resource, just give us a link to the files.

 

Thank you!

Share this post


Link to post

Any solutions from Kaspersky? It#s a little bit annoying that they can't provide a solution for that problem. That's a critical issue for my customers and I don't want to chnage to another Virus protection. This means a lot of effort for me.

 

Share this post


Link to post
Any solutions from Kaspersky? It#s a little bit annoying that they can't provide a solution for that problem. That's a critical issue for my customers and I don't want to chnage to another Virus protection. This means a lot of effort for me.

Hi,

 

If you want to know solution or workaround we need more information.

 

Hi,

 

Please collect GSI report with enabled event logs and kes traces in moment of reproduction.

You can provide it through any filesharing resource, just give us a link to the files.

 

Thank you!

 

Thank you!

Share this post


Link to post

I created one of these GSI reports about 3 years ago and spent hours redacting usernames, computernames, domain names, etc from the files. I think it was the one from the KSC server, so it basically mapped out my entire network in too much detail for my comfort. Even this GSI report I ran today on a workstation, wow, it'll take me several hours with Notepad++ to search/replace information in the 54+ files involved. I'm considering creating a temporary local non-domain account on the affected computer and re-running the GSI program in order to save time redacting. Maybe I'm being a bit Tin Foil Hat, but I wonder how many people put these GSI reports up on public forums on public file-sharing services, using their real names and email addresses. I'll be uploading mine via CompanyAccount if I ever get around to it.

 

I think we've been pretty descriptive in our explanation of the problem. Even without a GSI report, do you have access to internal bugfix/privatefixes/etc progress from the developers? (For KES10 SP2 or whatever is next) Has anything like this been reported and recreated successfully at Kaspersky Labs yet? I can confirm that this is a Windows10-only thing. Windows 7 does not seem affected.

 

I just had ANOTHER confirmed glitch caused by this issue today. It was affecting GOOGLE EARTH this time. (First time for that one.) Ran Integrity Check, gave the errors. So I had the end-user disable/exit KES10, then Google Earth worked fine. Spent the next 15 minutes of my life running an UNINSTALL KES and REBOOT task, waiting for it to complete, then running a KES10MR3 installation task. Ran the definition updates. Integrity check is good now. User is able to use Google Earth again *WITH* KES10 running. (Please see my original post in this thread where I list 5+ different types of software affected by this.)

 

Thanks in advance for any info you can provide to give us hope. (While I work on redacting the GSI file.) Cheers,

Edited by J. Earnhart

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.