Jump to content
Sign in to follow this  
ThorstenRay

Hohe Lastspitzen durch Administrationsagent

Recommended Posts

Hallo zusammen,

 

 

wir haben seit vielen Monaten sehr hohe Lastspitzen (Lese und Schreibvorgänge) auf unserem SAN Storage.

 

Das Problem verfolgt uns schon seit Monaten und wir kommen trotzd zuhilfenahme durch den Kaspersky-Support nicht wirklich weiter.

 

Unser SAN besteht aus einem NetApp MetroCluster und hat eigentlich genug Dampf um all unsere Anfoderungen abbilden zu können.

 

Wir haben schon weiß Gott was versucht um herauszufinden was das Problem sein könnte.

 

Auch jedes Mal nach einem Update das KSC und des Network Agents hofften wir auf Besserung - das Problem blieb uns jedoch erhalten.

 

Und zwar tritt das Problem immer zu Regelmäßigen Zeit auf. Die Anzahl der Lese- und Schreibvorgängen wärend dieser Phasen ist

so enorm, dass es sogar zu sehr starken Verzögerungen beim arbeiten mit Serverbasierten Anwendungen kommt.

 

 

Wir haben verschiedene Maßnahmen durchgeführt und konnten als verursachende Komponente den Kaspersky Network Agent ausmachen.

 

Wenn der Virenschutz selbst nur deaktiviert wird, dann gehen die Lastspitzen nur begrenzt zurück.

Wenn wir aber nur den Network Agent deaktivieren und den Virenschutz weiter laufen lassen, dann sind die Lastspitzen vollkommen weg.

 

Ich habe mir im KSC auch die Einstellungen des Agents nochmals angeschaut.

 

Dort finde ich leider nichts auffälliges.

Einstellungen wie bei Datenverwaltung (Informationen über installierte Anwendungen, Microsoft Windows-Updates und Software-Schwachstellen) sind deaktviert.

Sämtliche Einstellungen die nicht direkt mit Kaspersky in Verbindung gebracht werden können (WSUS, etc.) sind deaktiviert.

 

Was also tut dieser Agent um solche Spitzen zu verursachen.

 

Das Produkt Kaspersky wird dadruch derzeit in Frage gestellt.

 

Es liegt definitv am Agent. Aber was der tut und warum das so ist, kann mir keiner sagen. Ist der Agent deaktiviert ist alles gut.

Läuft er (was er ja eigentlich tun sollte), dann gibt es Lastspitzen das es kracht.

 

Kennt jemand so ein Problem?

 

Wie gesagt, dass ist jetzt schon seit mehreren Network Agent Versionen so.

Es wurde nicht besser sondern gefühlt schlechter.

 

Wir haben hier echt ein großes Problem.

 

Vielleicht hatte schon mal jemand ein solches oder ähnliches Problem.

 

VG

Thorsten

 

 

 

 

 

 

 

 

 

 

Share this post


Link to post

Eigentlich macht der Agent ja nicht soviel. Liegt es vielleicht am Task "Suche nach Schwachstellen und Programm-Updates"?

 

Wann tritt denn das Problem auf? Unter regelmäßig kann man recht viel verstehen? Mal geschaut ob ein bestimmter Task läuft der sonst nicht läuft?

Share this post


Link to post

Der Task "Suche nach Schwachstellen und Programm-Updates" ist deaktiviert in der Richtlinie für den Agent.

 

Das Problem tritt stündlich auf im kur vor der vollen Stunde und geht dann bis kurz nach der vollen Stunde (ca. 10 Minuten vor und nach der vollen Stunde).

 

Es läuft aber definitv kein Task zur jeden Stunde.

 

Die Updates auf den Servern werden alle 8 Stunden verteilt. Immer um 6, 14 und 22 Uhr.

 

Wie gesagt, deaktivieren wir den Agent auf allen Serven, dann hat das SAN so gut wie keine Last.

Auch wenn der Virenschutz weiter läuft.

 

Es liegt definitv am Agent. Egal mit welcher Version des Agents wir arbeiten. Das ist seit längerer Zeit so.

Viel aber erst mit dem neuen SAN auf, weil wir hier seht gute Auswertungsmöglichkeiten gegeben sind.

 

Niemand eine Idee?

 

Es sieht so aus, als ob der Agent immer zur vollen Stunde irgendwelche Log-Files oder ähnliches schreiben würde.

Wir sehen aber nichts....

 

Agent aus, alles OK. Agent an, nichts geht mehr.

 

 

Share this post


Link to post
Der Task "Suche nach Schwachstellen und Programm-Updates" ist deaktiviert in der Richtlinie für den Agent.

 

Das Problem tritt stündlich auf im kur vor der vollen Stunde und geht dann bis kurz nach der vollen Stunde (ca. 10 Minuten vor und nach der vollen Stunde).

 

Es läuft aber definitv kein Task zur jeden Stunde.

 

Die Updates auf den Servern werden alle 8 Stunden verteilt. Immer um 6, 14 und 22 Uhr.

 

Wie gesagt, deaktivieren wir den Agent auf allen Serven, dann hat das SAN so gut wie keine Last.

Auch wenn der Virenschutz weiter läuft.

 

Es liegt definitv am Agent. Egal mit welcher Version des Agents wir arbeiten. Das ist seit längerer Zeit so.

Viel aber erst mit dem neuen SAN auf, weil wir hier seht gute Auswertungsmöglichkeiten gegeben sind.

 

Niemand eine Idee?

 

Es sieht so aus, als ob der Agent immer zur vollen Stunde irgendwelche Log-Files oder ähnliches schreiben würde.

Wir sehen aber nichts....

 

Agent aus, alles OK. Agent an, nichts geht mehr.

 

Hallo Thorsten,

 

kannst du bitte noch Angaben zu den eingesetzten bzw. aktuell betroffenen Produkt-Versionen machen? Bitte exportiere und poste auch mal die Richtlinien und Aufgaben aller auf den Servern eingesetzter Produkte inkl. KSC (Richtlinie) - kannst du mir auch gern per PM schicken, falls dir das hier zu öffentlich ist. Allerdings bin ich gerade etwas "Land-unter", kann ein paar Tage dauern bis ich das prüfen kann.

Habt ihr die NetApp auch im Schutz? Welches Produkt (genaue Version inkl. Patchlevel), Welche Lizenz?

 

Grüße

Alex

 

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.