Jump to content
KJIsaacson

FF 43 & Kaspersky disabled

Recommended Posts

Firefox just updated to 43.0, and upon restarting it reported that "Kaspersky Protection cound not be verified for use in Firefox and has been disabled."

 

What now?

Share this post


Link to post

There's certainly an irony to all this for me. I left Norton 3 weeks ago due to this same problem with them, NIS not working with Firefox since an update months ago and them still (as far as I can see) not being able to sort it out.

 

I guess I should have checked more fully to see whether Kaspersky was having similar issues, or whether they were also very slow at solving this issue for their paying customers.

 

I guess I will look around some more and see whether any of the other well-reviewed security suites around are able to work without problem on Firefox. It is very disappointing that, in this modern technical world, such issues happen so frequently, making the seemingly good value price of a security suite less than good value when you have to spend so much time farting around with problems such as this which, from what I've read, are quite easily solved by big companies with many experts such as Kaspersky (and, indeed, Norton).

Share this post


Link to post
@KenIsaacson. In addition to harlan4096-Useful link. I share my experience on this issue

Read about new FFox Update was available. So that I open the browser and went to settings

>> Add-Ons > Extensions> > FFox Auto start install 43 Update > Closed screen

 

Open FFox Homepage--A notification says, some extensions were disabled. When goto settings

again >> Add-Ons >> Extensions it shows in red "Kaspersky protection and KPManager disabled"

 

I clear the cache and flush DNS >> Reboot >> Open FFox now Kaspersky Protection

appears "Enabled" but KPM still disabled. Well let's wait for the Klab Fix. Regards <Indio>

 

Hi Indio,

 

This one says it's enabled but the blockings are disabled. And yes KPM didn't work.

 

Maybe this would help.

 

Type "about:config" in the url bar and hit enter.

 

State "I'll be careful, I Promise" to continue

 

Then search for the entry "xpinstall.signatures.required"

 

Browse to the bottom part.

 

Right click on TRUE and Click "Toggle"

Although it still shows them as disabled in the extensions. It is working now.

(It should now say proceed with caution)

Share this post


Link to post
There's certainly an irony to all this for me. I left Norton 3 weeks ago due to this same problem with them, NIS not working with Firefox since an update months ago and them still (as far as I can see) not being able to sort it out.

 

I guess I should have checked more fully to see whether Kaspersky was having similar issues, or whether they were also very slow at solving this issue for their paying customers.

 

I guess I will look around some more and see whether any of the other well-reviewed security suites around are able to work without problem on Firefox. It is very disappointing that, in this modern technical world, such issues happen so frequently, making the seemingly good value price of a security suite less than good value when you have to spend so much time farting around with problems such as this which, from what I've read, are quite easily solved by big companies with many experts such as Kaspersky (and, indeed, Norton).

 

Kaspersky is the best out there but nobody is 100% perfect. All security suites have problems similar to this and a good many times it's not the fault of the security vendor. Many times they aren't notified in enough advance to do a patch in time for a release of a new version browser or whatever program. I've been using Kaspersky since 2006 and have never had to reinstall Windows because of malware.

I am having this same issue right now too but I am patient and know Kaspersky is working on a fix. In the mean time I can always use IE if I need to.

Edited by ENIAC 2

Share this post


Link to post
Hi Indio,

 

This one says it's enabled but the blockings are disabled. And yes KPM didn't work.

 

Maybe this would help.

 

Type "about:config" in the url bar and hit enter.

 

State "I'll be careful, I Promise" to continue

 

Then search for the entry "xpinstall.signatures.required"

 

Browse to the bottom part.

 

Right click on TRUE and Click "Toggle"

Although it still shows them as disabled in the extensions. It is working now.

(It should now say proceed with caution)

 

This worked for me in 43.0.1 only after I changed the setting in Protected Browser mode.

 

Share this post


Link to post

This directions to change "xpinstall.signatures.required" to FALSE worked fine.

However, this begs the question, Will there ever be an appropriate time to change back to TRUE given FF is continually updating????

Share this post


Link to post

Upcoming "Kaspersky Protection" add-on that will come with new Kaspersky 2016MR1, probably in January 2016, is already signed.

Share this post


Link to post

I'm having issues with the Kaspersky Protection add-on in Firefox. According to Firefox "Kaspersky Protection could not be verified for use in Firefox; The add-on will be disabled." I went into Firefox configuration and disabled the check in XPINSTALL and the add-on started to work again....temporarily. It is now causing me issues again and I can no longer run my financials in the Safe Money browser because of this issue. Every time I open it up I get the orange box around the browser window and a message that "Kaspersky Total Security is not providing complete protection on your data: extension is disasbled." However even after disabling the XPINSTALL configuration when I go into my add-ons I see the message "Kaspersky Protection could not be verified for use in Firefox. Proceed with caution", but the add-on is grayed out.

 

Does anyone have a clue what the heck is going on? It is extremely frustrating since it was working for a little while but Firefox and Kaspersky continue not to play nice together. I am running Firefox version 43.0.4 and Kaspersky Total Security 2016. I really prefer to use Firefox, but I need for this to work correctly otherwise Kaspersky was a waste of money for me.

 

I'm now having the exact same problems with my Chrome extensions as well. What heck is going on? Are these add-ons/extensions not validated for any browser? PLEASE HELP!!!!

Edited by ScottStoef

Share this post


Link to post

In addition to the add-on being grayed out I can no longer change click on it and change the settings like I was able to do in the past. I tried to install and unistall the extensions multiple times and I even deleted every possible extension to make sure there wasn't a conflict causing it, but still no luck. Here is the message from Firefox and I did the override they were talking about but that is no longer working either.

 

 

What can I do if Firefox disables an installed add-on?

 

You can remove the add-on from Firefox and then reinstall a signed version from the Mozilla Add-ons site if one is available.

 

If a signed version is not available, contact add-on developer or vendor to see if they can offer an updated and signed version of that add-on. You can also ask them to get their add-on signed.

Override add-on signing (advanced users)

 

You can override the setting to enforce the add-on signing requirement by changing the preference xpinstall.signatures.required to false in the Firefox Configuration Editor (about:config page). Support is not available for any changes made with the Configuration Editor so please do this at your own risk. Additionally, Mozilla is planning to remove this override in a future version of Firefox so this is only a temporary solution.

Share this post


Link to post
However even after disabling the XPINSTALL configuration when I go into my add-ons I see the message "Kaspersky Protection could not be verified for use in Firefox. Proceed with caution", but the add-on is grayed out.

 

Once FF xpinstall setting is set to false, You have to enable manually "Kaspersky Protection" add-on.

 

Also, for "Safe Money" session with FF, You should disable xpinstall setting, because this is a different and protected instance of FF.

 

2016MR1 is coming soon, with signed new "Kaspersky Protection" add-on.

Share this post


Link to post

I would if I could, but the add-on is no longer working at all anymore. It is showing up as enabled in the add-on screen, but when I try to click on the icon in my browser it is grayed out and I cannot change any settings on it.

 

I tried to switch to Chrome and it is doing the exact same thing! ARGH!!!!

 

Share this post


Link to post

If You get the same issue in Chrome, it seems You have a different problem...

 

Please check in Settings -> Protection -> Web Anti-Virus module is on, and enabled: Automatically active Kaspersky Protection extensions in browsers.

Edited by harlan4096

Share this post


Link to post

I've already done that and everything is setup correctly. I actually restarted the computer this morning and now the one in Chrome seems to be working correctly. The icon is green and I can click on the icon to change the settings. I went back into Firefox and it appears to be working correctly as well. Now that is really weird to say the least!

 

I had some weird stuff going on last night too. My network connection was getting really slow and then going to 'Limited Access'. I would then disconnect the network and log back in and it would work for about 15-20 minutes and do it again. I switched to my 5G band and that seemed to fix the issue. however when I got up this morning it was back on the 2.4G band and I didn't change it. HMMMMMMMM........

 

Just so you know this is a brand new laptop that was recently added to my network after a complete reset of the cable modem and router. All other computers on the network have been reimaged as well because something got behind my firewall. The only things that were no reimaged were my iOS devices and ancillary devices (TVs, printers, blu-ray players, etc.).

Edited by ScottStoef

Share this post


Link to post
Welcome. Please describe the issue. What error do you see?

I guess, after the upgrading FF to version 43.x, KIS 2016 plugins are no longer listed in 'Extensions' or 'Add-Ons' menu items in the FF browser.

 

Even I am facing the same issue and would like to know if there was a way to protect internet usage via FireFox browser and NOT to install KIS package (re-installation will force to re-download signatures all over again on a metered connection).

 

Appreciate if someone can help FF users.

 

Thanks, Mitesh.

Share this post


Link to post

This is ridiculous - why is Kaspersky dragging behind on this?

 

I purchased a license from Kaspersky thinking it was a reputable firm, but it is not willing to sign the add on so I do not have protection in my new version of FIrefox (43). It worked fine in the older version of FF.

 

I have paid for protection that I am not receiving. Will Kaspersky be refunding part of the fee - this has been going on for about a month or so now... It shouldn't take that long to verify the add on.

Edited by richbuff
Welcome. The fix is coming soon-ish, when it is ready. This is closed until then.

Share this post


Link to post

So Dangerous Website Blocker, Safe Money and Virtual KB almost Never work, as soon as you update firefox (and that is often) they are rendered useless (see pic), and while being useless they still perform the function of being a pain in the ass, I get drop down massages saying some of my plugins are not working and have been disabled.

I can't disable the plugins permanently, I can't remove them, I can't remove them via Total Security, I like Kaspersky, but these plugins are the most irritating pieces of crapware I have on my computer... literally, they are Kasperskys own virus...

 

How the hell to I remove this junk? I have it off in Total Security, yet there they are... functioning like they never do...

 

 

 

kps_by_carnage2k4-d9ppssq.jpg

Share this post


Link to post

I merged your new topic, replete with inflammatory rant topic title, to here, this pre-existing topic thread, that does not have an inflammatory topic title.

 

Please see the instructions in the quote below:

 

Type "about:config" in the url bar and hit enter.

 

State "I'll be careful, I Promise" to continue

 

Then search for the entry "xpinstall.signatures.required"

 

Right click on TRUE and Click "Toggle"

 

This is closed, as instructions and available information has been posted. :)

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.