Jump to content
prabin

error loading:libQtCore.so.4

Recommended Posts

./UpdateUtility-Console: error while loading shared libraries: libQtCore.so.4: annot open shared object file: No such file or directory

 

 

Update Utility Error: System Exception in Ubuntu

 

Using Kaspersky Update Utility 3.0 via console

Edited by prabin

Share this post


Link to post

Please post the exact version of your UBUNTU and the build of the updater.

 

The latest version 3.1.0.25 is available.

Share this post


Link to post

Please try the following command:

 

sudo apt-get install libqtgui4 or sudo apt-get install libqtgui4:amd64

Share this post


Link to post
Please try the following command:

 

sudo apt-get install libqtgui4 or sudo apt-get install libqtgui4:amd64

 

 

Hello,

 

I tried installing on both Ubuntu & CentOS.

 

Get the same error "Update Utility error: System Exception"

 

And when I checked the trace.log, get the below msg.

 

[04:21:38.597] 0xffffffffb77fe6d0 UpUt UpdateProcessor() ResultCodeException - Can't get IServiceHolder: ResultCodeInfo: 0x8000004c (Not found). At /tmp/tfs-build/150418.233417.1584502696/updateutility/updateutility/UpdaterFramework/Sdk/UpdateProcessor.cpp(185)

 

Using the latest Updater Utility 3.1.0-25

Centos Version 6.0

Ubuntu 14.04

 

 

Thanks

Share this post


Link to post
Please try an older version of UBUNTU.

 

Hello,

 

I tried in Ubuntu 12.04. Here received no error & nor any report/trace log is generated. I have attached the updater.ini

Utility version updateutility 3.1.0-25

 

Waiting for your reply

updater.zip

Share this post


Link to post

Your answer shows that UBUNTU 14.04 is not supported.

Share this post


Link to post
Please try an older version of UBUNTU.

 

You told & I tried, may be it support or not that version. Please help me to resolve this issue.

 

Thanks :rolleyes:

Share this post


Link to post

In this case only the developers can help you.

 

Please open a case on your CA.

Share this post


Link to post

Can you try this: sudo apt-get install libqtgui4.i686

Share this post


Link to post
Can you try this: sudo apt-get install libqtgui4.i686

 

 

Hello, I tried but not success. Also tried in CentOs 7. Same error "Update Utility error: SystemException"

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.