Jump to content
Democide

'This Connection is Untrusted' certificate error in Firefox in Yahoo and Google.

Recommended Posts

I've just installed the latest version of KIS 15.0.1.415 and now I've noticed that I get a "This Connection is Untrusted" error in Firefox whenever I try to go to either of those websites.

If I uninstall KIS then I can connect to those websites without any problems.

Share this post


Link to post
I've just installed the latest version of KIS 15.0.1.415 and now I've noticed that I get a "This Connection is Untrusted" error in Firefox whenever I try to go to either of those websites.

If I uninstall KIS then I can connect to those websites without any problems.

 

Hi even though your problem can be more complicated than this. As I have read about the same problem in some previous forum posts , but many a times un checking 'scan encrypted connections' under settings > additional > network > Encrypted connections scanning > uncheck mark 'Scan encrypted connections' had solved the problem for many users with same problem. Try it :)

 

 

Share this post


Link to post

New to forums so not sure how this all works. I found the problem to be caused by the web anti virus. If you go to settings-protection and turn off the anti virus I was able to get google to work, but I want anti virus. Haven't figured out how to fix this. Need help.

Share this post


Link to post

Hi.

(English is not my native language.)

In Firefox, there is a certificate manager. (Somewhere in the settings)

 

There you will find one or more "KasperskyAnti-VirusPersonalRootCertificate"

 

Delete them.

 

Then import the certificate that you will find in:

C:\ProgramData\Kaspersky Lab\AVP15.0.1\Data\Cert\ (fake)Kaspersky Anti-Virus Personal Root Certificate.cer

 

Important: You have to configure your computer to show you "hiddenfiles" before.

 

 

Kilauea

 

 

Share this post


Link to post

Hi Kilauea,

(English is not my native language.) for me too.

 

U simply can't import the certificate u mention just before, because u then receive as answer:

 

"Ce certificat personnel ne peut être installé car vous ne possédez pas la clé privée correspondante qui a été crée lorsque le certificat a été requis"

Which means +/- "that u don't have the private key created when the certificat was required"

 

and now ??

Edited by Astro48

Share this post


Link to post

You have to import the certificate via Firefox.

 

Open Firefox -> settings -> find the certificate tab -> and then import the certificate.

 

(No double click on the certificate <-> use Firefox to import)

 

Do you tried this way ?

 

 

Kilauea

 

 

 

Share this post


Link to post

Well, the fix is for KIS 15.0.1.415 and Firefox 33.0

 

Are you using this versions?

Is the time on your computer ok ? 16.10.2014

 

Make shure you choose the right tab, see screenshot

 

post-370-1413476678_thumb.jpg

 

 

Kilauea

 

 

Share this post


Link to post

Win pro 8.1 64Bits

Kiss 15.0.1.415

Firefox (french) 33.0

ok for the tab

certicate founded ((fake)Kaspersky Anti-Virus Personal Root Certificate)

ok for "import"

then u got the messy that u don't have the private key to use this certificate.

 

in the same directory u have "KLSSL_privkey.pem" and that's all

 

Share this post


Link to post

OK, i use Win 7 but that is a firefox issue....

 

When you import the certificate, there a three options:

 

trust websites

trust mail user

trust software vendors

 

I have only marked -> trust websites

 

If that won´t help, i am running out of ideas...

 

 

Kilauea

 

 

 

Share this post


Link to post

Wawwww

 

U DID IT !! great !!! many many thanks Kilauea !!!!

(btw: my mistake: I didn't "check" any option... stupid !)

 

It's working now, thanks to U

Have a nice Day.

Bye.

Share this post


Link to post

Thanks Kilauea, that seems to have fixed it for now but I hope Kaspersky will update KIS soon to fix it properly because we shouldn't have to go through all those steps just to browse those two websites.

Share this post


Link to post

If Safe Money is turned on I always get the message "This connection is untrusted" in Firefox version 33 when trying to connect to any financial site. This does not affect IE 11 or Chrome. I am using the current KIS version 15.0.1.415 and have tried everything I can find here to correct the problem to no avail. Support just says KIS cannot keep up with the Firefox updates and recommends an earlier version, which is not acceptable. Has anyone solved this incompatibility or will Safe Money just have to stay deactivated?

Edited by Jack4

Share this post


Link to post

Welcome,

 

in Firefox options please go to Advanced -> Certificates -> View Certificates. There import the following certificate as authority (set "Trust this CA to identify websites"):

C:\ProgramData\Kaspersky Lab\AVP15.0.1\Data\Cert\(fake)Kaspersky Anti-Virus Personal Root Certificate.cer

Share this post


Link to post

I have very huge problem with firefox 33 and Kis 15.0.1.415, when try to load a simple web page: google.com, untrusted connections apears(very slow, lag) and the problem get solved when exit kis, I have the lastest windows 8.1 64 bit version with all updates, drivers,etc, with kis 15.0.0.463 everything is ok

Edited by alexmircea

Share this post


Link to post
Hi,

 

Please uninstall Kis 15.0.1.415 then reboot, install Kis 15.0.1.415 update, reboot as it needed.

 

Hello,

 

Before installing kis 15.0.1.415 I've done this:

 

1.remove kis 15.0.0.463 then restart as required

2.clean the registry with last version off cclener

3.download from here : http://www.kaspersky.com/downloads/internet-security

4.installed kis 15.0.1.415 update then restart

Share this post


Link to post

Thanks JanRei! That worked. However, even though a new protected browsing window opens I get an additional tab in the original Firefox window with the following Run Error: "Failed to run Protected Browser : Safe Money plugin is not installed or disabled." But it is installed and enabled. Other than that it works well.

 

Share this post


Link to post

If haven't done so already, you can try to close Firefox and try again. Otherwise, please check that in Safe Money mode the Kaspersky extensions are activated and the Kaspersky plugins are set to always active (in particular the Online Banking plugin).

Share this post


Link to post
Welcome,

 

in Firefox options please go to Advanced -> Certificates -> View Certificates. There import the following certificate as authority (set "Trust this CA to identify websites"):

C:\ProgramData\Kaspersky Lab\AVP15.0.1\Data\Cert\(fake)Kaspersky Anti-Virus Personal Root Certificate.cer

 

I have the same problem but am using Windows 7 Home Edition. There is no path and no certificate on my computer. Could you please point me to the location of the certificate

 

Thanks

 

Share this post


Link to post

Just updated to Kaspersky 2015 and now get the error message "This Connection is Untrusted" whenever attempting to go onto any website.

How do I configure Kaspersky settings to end this problem?

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.