Jump to content
nirvanastarr

Pure 4 - I know: ready WIIR but...

Recommended Posts

Knowing well that Pure 4 will be released when ready. But it seems strange that this time are needed so many months. It is now about a year and a half that Pure 3 has been released. I have the feeling that Kaspersky wants to end the development of Pure and continue with the other products, released in these days (KIS, KAV, KTS). Am I wrong ??

Share this post


Link to post

Also,

 

Quote: "I have the feeling that Kaspersky wants to end the development of Pure and continue with the other products, released in these days (KIS, KAV, KTS). Am I wrong?"

 

PURE has name change. PURE is now named Kaspersky Total Security.

 

PURE = KTS.

 

KTS 2015 is eagerly anticipated soon, somewhere around WIIR. ツ

Share this post


Link to post

Hello,

 

The name should be as Total Security for home because one kaspersky solution is already named as Total Security for Business.

post-488545-1410367859_thumb.png

Share this post


Link to post

The name itself is Kaspersky Endpoint Security. As far as I know 'KTS for Business' is not an official name of the product, it is just pointing out that this package includes of layers of security.

 

Let's see what they will come up with at the end. They are very likely aware of that.

Share this post


Link to post

I would also like to know one thing: the new version will solve the problem of addon updating for different browsers or as is the case today, after the browser's update will no longer be working ??

I think it's a difficult problem to solve because I imagine that every time the browser is updated, even the plugins must be recompiled at least in part. Or am I wrong ??

Share this post


Link to post

The problem mainly affects Firefox. At the moment the add-ons need to be adapted for every new major Firefox version. In the upcoming PURE version the add-ons were reworked. Usually they should not break anymore when a new Firefox version is released.

Share this post


Link to post
The problem mainly affects Firefox. At the moment the add-ons need to be adapted for every new major Firefox version. In the upcoming PURE version the add-ons were reworked. Usually they should not break anymore when a new Firefox version is released.

 

 

If they are working on a fix to prevent incompatibility with the latest browser add-ons, and especially password manager (For Firefox, Chrome and IE), I am happy to wait. More testing = a more reliable product before RTM.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.