Jump to content
felixinasa

problemas con Delphi Xe5

Recommended Posts

Hola

 

Tengo instlado kaspersky pure 3 y cuando compilo una aplicación con Delphi xe5 me tarda mucho, si paro el antivirus funciona normal.

He añadido el ejecutable de Delphi a la zona de confianza

 

Gracias

Share this post


Link to post

Hola,

 

Te recomiendo que revises las normas del foro, te serán de gran ayuda.

 

Muevo tu consulta al foro de productos domésticos, ya que el Pure es un producto doméstico no es un producto corporativo.

 

Elimino el hilo duplicado con un hilo por consulta es mas que suficiente. Y por lo que veo también has realizado la misma consulta en el foro beta inglés :dash2: .

 

Sube toda la información que en ellas se pide (Versión y build de Kaspersky instalado, S.O. y servicepack instalados, sube tu getsysteminfo (gsi) utilizando la ultima versión disponible del mismo, debes enviar la dirección URL de la Web que se genera con el informe, sube tu avzlog para revisarlo, etc...) para que te podamos ayudar.

 

Para generar el getsysteminfo (gsi) revisa este enlace: http://support.kaspersky.com/sp/faq/?qid=208281645

Getsysteminfo (GSI) descarga directa: http://www.getsysteminfo.com/download/GetSystemInfo.exe

 

Además de adjuntar el fichero gsi, es recomendable enviar el enlace-dirección URL de la Web que se genera con el informe, para facilitar la labor.

 

Para generar el avz log revisa estos enlaces: http://support.kaspersky.com/sp/faq/?qid=208282267 y http://forum.kaspersky.com/index.php?showtopic=116409

AVZ descarga directa: http://www.z-oleg.com/avz4.zip

 

Saludos

Edited by Caos

Share this post


Link to post
Hola,

 

Te recomiendo que revises las normas del foro, te serán de gran ayuda.

 

Muevo tu consulta al foro de productos domésticos, ya que el Pure es un producto doméstico no es un producto corporativo.

 

Elimino el hilo duplicado con un hilo por consulta es mas que suficiente. Y por lo que veo también has realizado la misma consulta en el foro beta inglés :dash2: .

 

Sube toda la información que en ellas se pide (Versión y build de Kaspersky instalado, S.O. y servicepack instalados, sube tu getsysteminfo (gsi) utilizando la ultima versión disponible del mismo, debes enviar la dirección URL de la Web que se genera con el informe, sube tu avzlog para revisarlo, etc...) para que te podamos ayudar.

 

Para generar el getsysteminfo (gsi) revisa este enlace: http://support.kaspersky.com/sp/faq/?qid=208281645

Getsysteminfo (GSI) descarga directa: http://www.getsysteminfo.com/download/GetSystemInfo.exe

 

Además de adjuntar el fichero gsi, es recomendable enviar el enlace-dirección URL de la Web que se genera con el informe, para facilitar la labor.

 

Para generar el avz log revisa estos enlaces: http://support.kaspersky.com/sp/faq/?qid=208282267 y http://forum.kaspersky.com/index.php?showtopic=116409

AVZ descarga directa: http://www.z-oleg.com/avz4.zip

 

Saludos

 

Lo primero pedir perdón por equivocarme al publicar el hilo en un foro que no corresponde (no había leído lo de beta tester)

 

Actualmente tengo instalado Windows 8.1 con Kaspersky pure

la url generada por GSI es http://www.getsysteminfo.com/read.php?file...52d84942b791eeb

Adjunto el fichero creado con AVZ.

El problema es que cuando ejecuto una aplicación por sencilla que sea desde el entorno integrado de Delphi Xe5, tarda mucho en arrancar. Si paro el antivirus la velocidad buena

 

Gracias

sysinfo.zip

Share this post


Link to post

Hola,

 

Desinstala el posible software incompatible: Wajam

 

Ademas de agregar Delphi Xe5 a programas de confianza, te recomiendo que crees las exclusiones correspondientes para los ejecutables y procesos/programas relacionados con Delphi Xe5.

En KIS 2013 estaría localizado en configuración > Configuración avanzada > Amenazas y exclusiones > Exclusiones > Configuración.

 

Saludos

Edited by Caos

Share this post


Link to post

Hola

he desinstalado Wajam, ha añadido la carpeta en la que genero el ejecutable como regla de excusión. Tengo puesto que no analice nada de Delphi Xe5 ni subprocesos, ni actividad de red...

Pero sigo igual.

Tengo alguna forma de ver que es lo que está haciendo kasrpersy pure cuando ejecuto la aplicación desde el IDE de Delphi?

 

gracias

Share this post


Link to post

Hola,

 

Adjunta captura de pantalla de las exclusiones, y aplicaciones de confianza que tienes añadidas y con que reglas. No creo que sea suficiente con agregar la carpeta en la que se genera, hay que ver que procesos, etc... son los que realiza el Delphi y ralentiza Kaspersky al analizarlos.

 

Prueba a desactivar módulo a módulo para ver cual puede estar causandote la ralentización en dicho proceso.

 

Saludos

Share this post


Link to post

Hola Caos

 

Esta mañana iba a hacer lo que me has comentado pero antes he probado otra vez. Ahora me va bien, no sé lo que habrá pasado esta noche, ya que ni siquiera he apagado el ordenador.

He reiniciado también por si acaso y sigue yendo bien, así que de momento no te puedo decir nada más, seguiré probando y si vuelve a ralentizarse escribiré otra vez. pregunta, en el mismo post o abro otro nuevo?

 

Gracias

Share this post


Link to post

Hola,

 

Me alegro que ya te funcione bien. Si se repite continua este hilo mejor.

 

Saludos

Share this post


Link to post

Hola

 

He vuelto a probar y los problemas continúan.

He ido desactivando módulos y los que causan problemas son 2 control de aplicaciones y firewall. Si activo cualquiera de los 2 se ralentiza.

Te adjunto capturas de pantalla

El primero el la carpeta donde se genera el ejecutable, pero esta mañana (cuando iba bien) el ejecutable lo podía generar en cualquier carpeta y se no se ralentizaba

 

Gracias

post-495488-1387280357_thumb.jpg

post-495488-1387280365_thumb.jpg

Share this post


Link to post

Puedes probar también a añadir las Exclusiones vía Control de Aplicaciones de cada uno de los ejecutables/servicios del Entorno Delphi.

 

Saludos.

Share this post


Link to post

Hola,

 

Revisa si tienes algo en restricción mínima, o máxima. Sube captura de pantalla en caso afirmativo.

 

Sube capturas de pantalla en las que se vea la ruta completa de la exclusión/aplicación de confianza y como la has configurado, revisa los procesos porque creo que hay que añadir algo mas que solo el ejecutable de Delphi.

 

Saludos

 

 

Share this post


Link to post

Hola de nuevo

 

sigo igual, me va bien a ratos y no sé de que depende, ya sé que no te estoy ayudando mucho pero es así.

Si desactivo el control de aplicaciones y el firewall, es inmediato

 

gracias

Share this post


Link to post

Como comenté en mi anterior post, prueba a crear exclusiones de los ejecutables/servicios del Delphi desde sus fichas de Reglas de Aplicación del Control de Aplicaciones, te muestro un ejemplo con el InterNet Explorer:

 

post-5997-1387383524_thumb.png

 

Saludos.

Edited by harlan4096

Share this post


Link to post

Hola,

 

Revisa como te he indicado si tienes algo en restricción mínima, o máxima. Sube captura de pantalla en caso afirmativo.

 

Creo que el problema es que te faltara de crear alguna exclusión para algún proceso de Delphi.

 

De todas maneras puedes abrir un caso en el helpdesk de Kaspersky, a través de mi cuenta Kaspersky https://my.kaspersky.com/ o directamente en http://support.kaspersky.ru/helpdesk.html?LANG=sp

 

Saludos

Share this post


Link to post

En control de aplicaciones.

 

post-59156-1387385774_thumb.jpg

 

Sube capturas de pantalla de lo que te aparece para revisarlo.

 

Saludos

Edited by Caos

Share this post


Link to post

Tienes que pulsar el botón aplicaciones, para poder ver todo :)

 

Saludos

Share this post


Link to post

En restricción mínima tengo bastantes cosas, en máxima nada, en no confiable tenia el nombre del ejecutable que me generara el delhpi, ahora está en restricción mínima pero sigue igual

SAlu2

post-495488-1387386650_thumb.jpg

Share this post


Link to post

Mueve todos los programas/procesos de delphi al grupo de confianza.

 

Saludos

Share this post


Link to post

He movido el project1.exe que es el ejecutable que se genera al grupo de confianza, pero cuando vuelvo a compilar se mueve a restricción mínima ( se ve que no le gusta)

Share this post


Link to post

Eso es normal, pues no tiene firma digital ni tampoco está (obviamente) en las listas blancas, pero lo importante es que muevas a Confiable los ejecutables/servicios y demás archivos que pertenezcan al entorno del Delphi, no los que generas tú al compilar, etc...

 

Saludos.

Edited by harlan4096

Share this post


Link to post

Tienes que quitar de restricción mínima todos los programas legales, ya que sino puedes tener problemas a la hora de ejecutarlos.

 

Mueve todo lo necesarios, crea una nueva captura de pantalla, subela, y prueba de nuevo.

 

Crea una exclusión para cada uno de los ejecutables necesarios, sube capturas de pantalla de las mismas.

Edited by Caos

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.