Jump to content
robertmac

agent not reporting AV is installed

Recommended Posts

I've not come across this before but it is annoying me now as nothing I have tried has worked.

I am using the Service Provider Security Centre, but I dontt beleive the problem is related to that.

 

what is happening is, the agent and Endpoint 8 are being installed onto a WinXP workstation.

the agent connects to the security centre and reports itself as being installed, however it will not report that Endpoint is installed and therefore I cannot apply licenses/updates etc or run tasks that are relating to Endpoint because it believes it isnt installed.

checked the registry location at HKEY_LOCAL_MACHINE\SOFTWARE\KasperskyLab\Components\34\1103\1.0.0.0\Statistics\AVState

and the values there also dont believe that Endpoint is installed/running or does ithave any bases downloaded.

 

"Protection_AvInstalled"=dword:00000000

"Protection_AvRunning"=dword:00000000

"Protection_BasesDate"=""

 

I am led to believe from other posts that those 3 values are important to what is reported.

I cant set them because they will revert back to 0/blank when it next Syncs.

 

I've completely uninstalled it, reinstalled endpoint and agents, no dice.

 

I had a cunning plan that I could license it manually and then run an update, but cant do that.

it licences ok but says databsaes are out of date.

so I tried to create an update task but there are no update sources and clicking Add to add one does nothing at all.

even when I manually try to choose a region, it has the region drop down greyed out.

 

I've never had so much bother trying to get one of these working before.

 

I would initially think it is a client PC problem but all the workstations at this office have the same issue, which sort of indicates a server side problem or bad packages but the endpoint package is used for other customers without any problem.

 

anyone got any ideas or pointers ?

 

if you need more info, let me know and I shall provide :)

 

 

thanks

 

robert

Share this post


Link to post

I completely uninstalled network agent and KES, deleted all remaining registry and file whats left behind (and all temp folder), rebooted and reinstalled all stuff. Now its working, but sometimes KES 8 freeze down, and even its restarted after many messageboxes, server report that no KES installed on that computer, until i restart complete computer.

Share this post


Link to post

Hello,

 

are you installing the KES8 over a KAV6?

 

I saw this happening when installing KES8 over a KAV6 when the agent would change to the new version the KSC would recognize the new agent but would stay on KAV6. When the system reboots after KES8 install the KAV6 disappears in the KSC but KES8 won`t be recognized. Some time later after forcing several resyncs and reboots it would detect.

 

The way i found works the best for me, is to really uninstall KAV6 before installing KES8.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.