Jump to content
Hermann

Outlook 2010 und KIS 2011, Add-In

Recommended Posts

Hallo,

 

scheinbar ist es Kaspersky immer noch nicht gelungen, folgenden Fehler bei Imap-Konten zu beheben:

 

Fehler (0x800CCC0F) beim Ausführen der Aufgabe "Abonnierte Ordner für 'MEIN_KONTO' werden synchronisiert": "Von Outlook können keine abonnierten Ordner für 'MEIN_KONTO' synchronisiert werden. Fehler: Dieser IMAP-Befehl kann nicht zum Server gesendet werden, bevor die Verbindung beendet wurde. Wenn Sie diese Meldung weiterhin erhalten, wenden Sie sich an den Serveradministrator oder Internetdienstanbieter."

 

Ich habe 4 Imap-Konten eingerichtet, Fehlermeldung kommt sporadisch für 1-4 Konten, wodurch dann natürlich keine weiteren Daten mehr aktualisiert werden. Der Spuk in Outlook hört erst auf, wenn ich beide KIS-Addins (Anti-Virus, Anti-Spam) deaktiviere.

 

Ist hier noch eine Lösung in Sicht??

 

Achja: Win7, 32bit, Office 2010, KIS 2011

 

Mfg

Hermann

Edited by Hermann

Share this post


Link to post

Hallo,

 

so, Antwort vom Support ist da.

 

------------------------------------------------

löschen Sie bitte die Temporären Dateien, in dem Sie die Datenträgerbereinigung starten, die Sie unter "Start -> Alle Programme -> Zubehör -> Systemprogramme" finden.

 

Führen Sie daraufhin bitte folgende Schritte durch:

 

1. Öffnen Sie Ihr Kaspersky-Programm

2. Klicken Sie auf "Einstellungen" -> auf das Symbol "Erweiterten Einstellungen" (Karton) -> "Netzwerk" -> "Auswählen..."

3. Entfernen Sie hier die Haken bei Port 143 und Port 993 4. Schließen Sie nun alle Fenster mit "OK"

 

Trotz dieser Änderung sind Sie geschützt. Daten, die über die Ports 143 und 993 eintreffen, werden weiterhin von der Komponente ''Datei-Anti-Virus'' untersucht.

 

Führen Sie zusätzlich bitte noch folgende Schritte aus:

 

1. Öffnen Sie Kaspersky Internet Security 2. Klicken Sie auf der rechten Seite auf "Einstellungen" - "Anti-Hacker" - "Einstellungen"

3. Klicken Sie auf die Registerkarte "Zonen" und ändern Sie den Status Ihres lokalen Netzwerkes durch klicken auf "Ändern" zu "Vertrauenswürdig"

--------------------------------------------------

 

Das zweite war zwar nicht ganz einfach zu finden (hab kein Anti-Hacker??), hab aber dann doch noch das mit den Zonen gefunden. Bis jetzt schauts mal nicht schlecht aus...

 

Mfg

Hermann

Share this post


Link to post

Gemeint war natürlich die Firewall und der Reiter "Netzwerke". Der Supportmitarbeiter hat wohl in seinem Gedächtnis etwas zu weit zurückgeblättert; vor vielen Jahren hiess die Firewall tatsächlich "Anti-Hacker". :)

Share this post


Link to post
... Der Supportmitarbeiter hat wohl in seinem Gedächtnis etwas zu weit zurückgeblättert; vor vielen Jahren hiess die Firewall tatsächlich "Anti-Hacker". :)

... oder er war aus der anderen Abteilung. Wenn ich mich an die letzte Business-Beta richtig erinnere, heißt es da noch immer so.

Share this post


Link to post

Nun ist einige Zeit vergangen. KIS 2011© und Outlook 2010 sind immer noch zwei Feinde.

Nachdem ich alles, was zuvor geschrieben wurde durchprobiert habe, muss ich feststellen, dass mein Outlook 2011 mit den IMAP-Konten mit KIS 2011 nicht läuft. Mal erscheint die Fehlermeldung von Hermann mal erscheint sie nicht.

Mit Outlook 2007 und KIS2011 laufen die IMAP-Konten einwandfrei. Bei beiden Outlook-Programmen habe ich die gleichen Einstellungen und das Betriebssystem ist bei beiden auch Winx64 Home Permium.

 

Ich gehe mal davon aus, dass Kaspersky dieses nicht in Griff bekommen hat.

 

Gruß Feuerwehrmann

Share this post


Link to post

Hallo,

 

schieb das Thema mal wieder nach oben. Leider ist das Problem mit der 2012 immer noch vorhanden. Gibts denn da gar keine Aktivitäten zur Lösung?

 

Mfg

Hermann

Share this post


Link to post

Hallo Hermann,

 

nur mal kurz meine Gedanken zu Deinem Problem. Ich arbeite auch mit IMAP (allerdings nur ein Konto plus einige POP) und habe keinerlei Probleme mit KIS. Soweit ich weiß ist KIS, bis auf ESET, das einzige Programm welches IMAP unter SSL/TLS verarbeiten kann.

 

Also meine Gedanken:

 

Hast Du in den IMAP-Kontoeinstellungen SSL bzw. TLS aktiviert?

Dann vielleicht in den KIS-Einstellungen die Untersuchung von geschützten Verbindungen nicht aktiviert (Reiter Karton und Netzwerk)?

 

Viele Grüße

Rolf

 

 

Share this post


Link to post

Hallo Hermann,

 

falls es Dir hilft, auch bei mir funktioniert Outlook 2010 mit SSL-verschlüsselten IMAP-Konten weiterhin nicht zuverlässig mit KIS 2012 (12.0.0.374 a.b.c.d). Es hat sich diesbezüglich auch nichts gegenüber KIS 2011 bzw. Outlook 2007 geändert. Wie in diesem Forum an unterschiedlichen Stellen von diversen Anwendern erwähnt, bleibt sporadisch die Abfrage der IMAP-Konten "hängen".

Ich denke auch nicht, dass sich hier jemals was ändern wird, denn auf Grund der SSL-Verschlüsselung kann es mit dem derzeitigen Ansatz von Kaspersky gar keine technische Lösung geben. Eventuell funktioniert es, wenn man das "Fake-Zertifikat" für die Verschlüsselung von Kaspersky installiert. Der Experte SebastianLE hat in diesem Forum mehrfach die Vor- und Nachteile eines solchen Zertifikats erwähnt. Für mich überwiegen auf Grund seiner Beschreibung die Nachteile und deshalb verzichte ich auf die Installation des Zertifikats. Ergo kann Kaspersky keine SSL-verschlüsselten Verbindungen und damit die IMAP-Konten nicht untersuchen. Somit muss ich auch akzeptieren, dass KIS keine Spam-Filterung bei verschlüsselten Konten vornehmen kann (ist bei mir kein Problem, weil alle meine Provider hervorragende Spam-Filter haben und um den kleinen Rest, der dort wirklich durchschlupft, kümmert sich mein individuell angepasster Outlook-Junk-Mail-Filter).

 

Das eigentliche Problem ist, dass Kaspersky hier falsche Standard-Einstellungen verwendet:

a: KIS erzwingt die Installation seiner beiden Outlook Anti-Virus und Anti-Spam Addins

b: KIS hat unter Netzwerk standardmäßig die Ports 993 (IMAP-SSL) und 995 POP3-SSL) aktiviert

c: KIS hat unter Netzwerk standardmäßig "Geschützte Verbindungen untersuchen" deaktiviert (was hoffentlich auch so bleibt)

 

Diese Kombination führt nun bei der Abfrage von SSL-verschlüsselten IMAP-Konten bei Outlook zu unregelmäßigen Timing-Problemen, d. h. die Konten-Abfrage bleibt hängen. Wenn bei den zu untersuchenden Ports 993 und 995 deaktiviert werden, gibt es keine Probleme. Alternativ kann man auch in KIS die beiden Outlook-Addins für Mail-Antivirus und Anti-Spam deaktivieren (siehe auch Post http://forum.kaspersky.com/index.php?showt...&p=1589716).

 

Wie gesagt, ohne Installation des Kaspersky-SSL-Zertifikats (obiger Punkt c) kann KIS keine geschützten Verbindungen untersuchen, ergo sollten in der Default-Einstellung auch die Ports 993 und 995 (obiger Punkt b ) deaktiviert sein.

 

Viele Grüße

Kurt

 

Share this post


Link to post

Hallo,

 

Diese Kombination führt nun bei der Abfrage von SSL-verschlüsselten IMAP-Konten bei Outlook zu unregelmäßigen Timing-Problemen, d. h. die Konten-Abfrage bleibt hängen. Wenn bei den zu untersuchenden Ports 993 und 995 deaktiviert werden, gibt es keine Probleme.

Viele Grüße

Kurt

 

ich nutze die Standardeinstellung von Outlook, also Port 143 und Port 25 (TLS). somit sollte die SSL-Thematik hier nicht zutreffen. Ich habe auch schon alle Überprüfungen von KIS (25, 143, 465, 993) deaktiviert, trotzdem bleibt die Kontensynchronisation sporadisch (eher mehr wie weniger) hängen. Das ganze mit allen möglichen Einstellungen in Outlook (143,993). Keine Veränderung. Die Deaktivierung der Untersuchung der Ports 993/995 bringt keine Verbesserung. DAs ganze habe ich auch schon auf einem neu installierten System versucht (Problem hab ich ja schon ne zeitlang....), auch da das gleiche Dilemma.

 

Mfg

Hermann

Share this post


Link to post

Hallo,

 

Also meine Gedanken:

 

Hast Du in den IMAP-Kontoeinstellungen SSL bzw. TLS aktiviert?

Dann vielleicht in den KIS-Einstellungen die Untersuchung von geschützten Verbindungen nicht aktiviert (Reiter Karton und Netzwerk)?

 

Viele Grüße

Rolf

 

ich hab in Outlook beim smtp-Server den Port 25, somit TLS. In KIS ist die Untersuchung der geschützten Verbindungen nicht aktiviert.

 

Mfg

Hermann

Share this post


Link to post

Hallo Hermann,

 

sorry, dass Du TLS als Verschlüsselung verwendest war mir bisher nicht bewusst. Grundsätzlich gilt bei TLS das Gleiche, was Rolf bereits bzgl. der Untersuchung von geschützten Verbindungen in KIS erwähnt hat. TLS ist quasi die Weiterentwicklung von SSL, wobei die Spezifikation von TLS 1.0 der von SSL 3.1 entsprechen soll. Ob Kaspersky auch TLS-geschützte Verbindungen untersuchen kann weiß ich nicht. Auf die Schnelle habe ich dazu keine detaillierte Aussage gefunden. Im Zweifelsfall einfach mal beim Kaspersky Support nachfragen.

 

Falls KIS die Untersuchung von TLS-verschlüsselten Verbindungen unterstützt und Du möchtest, dass KIS dieses beim Empfang von Deinen E-Mails auch tut, musst Du das Kaspersky-Zertifikat installieren.

 

Falls Du nicht möchtest, dass Kaspersky verschlüsselte Verbindungen untersucht, könnte das Outlook-Timing-Problem gelöst werden, wenn Du die entsprechend bei Dir verwendeten IMAP- und SMTP-Ports in KIS Listes der zu überwachenden Ports deaktivierst. Ganz bestimmt helfen sollte, wenn Du die in KIS die beiden Outlook-Addins unter Mail-Antivirus und Anti-Spam deaktivierst (entspricht meiner bevorzugten Lösung und die funktioniert bei mir 100 %).

 

Viele Grüße

Kurt

Share this post


Link to post

KAV/KIS sollte das TLS-Protokoll unterstützen.

 

Mir war bisher nicht bekannt, dass es bei diesem Problem einen Zusammenhang mit den zur Datenverkehruntersuchung ausgewählten Ports gibt. Es wäre daher interessant, ob der Vorschlag, die beteiligten Ports zu deaktivieren, auch bei Hermann hilft.

 

Normalerweise sollte dies allerdings nicht zu Problemen führen. Wenn KAV/KIS den Datenverkehr nicht untersuchen kann, wird er einfach direkt weitergeleitet.

Share this post


Link to post

Hallo,

 

die Untersuchung der geschützten Verbindungen hatte ich damals schon deaktiviert, die Ports hatte ich ebenfalls aus der Untersuchung ausgenommen. Hat damals nicht geholfen. Die Deaktivierung der beiden Addins funktioniert schon, aber das ist doch das Gegenteil, was ich möchte. Hab nun gestern nochmal die Einstellungen angeschaut (sind ja mittlerweile doch ein paar Tage vergangen), nochmal alle Haken raus (Portüberwachung und Überwachung geschützter Verbindungen). Komischerweise funktionierts bis jetzt??? Werde das mal die nächsten Tage beobachten.

 

Edit: Ums vielleicht nochmal zu verdeutlichen: Wenn die Addins deaktiviert sind, gibts keine Synchronisierungprobleme. Ich möchte das Anti-Spam-Addin aber aktiviert haben. Und dann traten bisher die genannten Probleme auf.

 

Mfg

Hermann

Edited by Hermann

Share this post


Link to post
Ich möchte das Anti-Spam-Addin aber aktiviert haben. Und dann traten bisher die genannten Probleme auf.

 

Wenn du TLS nutzt, aber die geschlüsselten Verbindungen nicht untersuchen lässt bringt es aber nichts und kann keinen Spam prüfen.

Share this post


Link to post

Hallo,

 

Wenn du TLS nutzt, aber die geschlüsselten Verbindungen nicht untersuchen lässt bringt es aber nichts und kann keinen Spam prüfen.

 

Da hätt ich doch mal 2 Fragen:

 

1. TLS wird für smtp genutzt, das Addin wird doch für eingehende Mails verwendet. Oder doch nicht?

2. Die Untersuchung auf SPAM erfolgt doch erst, wenn die Mail im Postfach ist, sprich bereits heruntergeladen wurde. Weil dann ja erst in den von mir definierten Ordner verschoben wird. Oder bin ich hier auch aufm Holzweg?

 

Und als bestes, der Fehler tritt immer noch auf ;-(

 

Fehler (0x800CCC0F) beim Ausführen der Aufgabe "Abonnierte Ordner für 'mein@konto.de' werden synchronisiert": "Von Outlook können keine abonnierten Ordner für 'mein@konto.de' synchronisiert werden. Fehler: Dieser IMAP-Befehl kann nicht zum Server gesendet werden, bevor die Verbindung beendet wurde. Wenn Sie diese Meldung weiterhin erhalten, wenden Sie sich an den Serveradministrator oder Internetdienstanbieter."

 

Mfg

Hermann

 

Share this post


Link to post

Hallo,

 

hab jetzt mal auch die TLS-Verbindung in Outlook in eine ungeschützte Verbindung umgestellt. Problem ist nach wie vor vorhangen...

 

Mfg

Hermann

Share this post


Link to post

Hallo Hermann,

 

weil Du lobenswert so "hartnäckig" an diesem Problem dran bleibst, habe ich meine alten Aufzeichnungen zu dem Thema hervorgeholt und da wird es jetzt etwas peinlich für mich. Eine erneute Auswertung meiner Aufzeichnungen, die bis Oktober 2010 zurückreichen zeigt, dass ich das Problem mit dem Synchronisieren der abonnierten IMAP-Ordner-Strukturen (Outlook-Fehler 0x800CCC0F) nur durch gleichzeitiges Deaktivieren der beiden Kaspersky Plug-ins für Outlook 2010 dauerhaft vermeiden konnte. Dabei hat es ausgereicht diese Plug-ins in KIS zu deaktivieren (entspricht meinem Workaround 2).

Ein Deaktivieren der entsprechenden Firewall-Ports 465 und 993 in KIS bei den zu überwachenden Ports (Workaround 1) hat zwar zu einer Verbesserung geführt, d. h. das Problem ist weit weniger oft aufgetreten, aber es war keine hundertprozentige Lösung. Es kann aber auch sein, dass der Fehler in Outlook weiter aufgetreten ist, weil ich damals den Port 25 in KIS nicht aus der Überwachung genommen, aber mit TLS bei einem meiner Konten verwendet hatte.

Also, Asche auf mein Haupt, der Workaround 1, welcher laut Deiner Aussage ursprünglich vom deutschen Kaspersky Support stammt, funktioniert auch bei mir nicht zuverlässig.

 

Was ich damals auch erfolglos getestet hatte und zu Deiner letzten Aussage passt, war ein kurzzeitiger Verzicht auf die SSL-Verschlüsselung bei IMAP/SMTP. Allerdings habe ich diese Konfiguration nach dem ersten Auftreten des Fehlers nicht weiterverfolgt und bin sofort wieder zum Workaround 2 zurückgekehrt.

Damals hatte ich auch bemerkt, dass jede diesbezügliche Konfigurationsänderung in KIS sich bei meinen Tests erst nach einem PC Reboot ausgewirkt und damit die Sache zusätzlich erschwert hatte.

 

Bei genauerer Überlegung bin ich mir nun nicht mehr sicher, ob die Problematik mit dem Outlook-Fehler überhaupt etwas mit der Verschlüsselung in KIS zu tun hat.

 

In einem weiteren Forumsbeitrag zu dieser Problematik hat Rene-gad Anfang des Jahres auf den Mircosoft-Link http://support.microsoft.com/kb/813514/de verwiesen. In diesem Microsoft-Artikel steht ziemlich viel weniger Brauchbares für die Lösung dieses Problems. Allerdings könnte der dortige Hinweis auf die "Servertimeout-Einstellung" bei den Outlook-Konten ziemlich am Ende des Artikels eine Lösung bringen. Ich hatte vor langer Zeit in Zusammenhang mit KIS 2010 mit diesem Timeout erfolglos gespielt, aber diese Option bei KIS 2011 und 2012 nicht mehr geprüft. Ich werde es die Tage bei mir mal testen.

 

Viele Grüße

Kurt

 

 

Share this post


Link to post

Hallo,

 

habe den Timout auch schon auf 3 Minuten eingestellt, keine Änderung ;-(

 

Mfg

Hermann

Share this post


Link to post

Ich habe mich nach dem Status des Problems erkundigt. Demnach konnte es zumindest teilweise reproduziert werden. Die Entwickler sind der Ansicht, dass es durch ein fehlerhaftes Verhalten von Outlook verursacht wird, und rechnen mit einer Fehlerbehebung durch Microsoft.

Share this post


Link to post

Hallo JanRei,

 

vielen Dank für die Auskunft. Über einen zeitlichen Rahmen bis zur Beseitigung von MS weiß man aber wohl nix, oder?

 

Mfg

Hermann

Share this post


Link to post

Man hat wohl die Hoffnung, dass dies mit einem der nächsten Hotfixes oder dem nächsten Service Pack behoben wird.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.