Jump to content

Recommended Posts

@winux

Wenn du den Haken nicht findest hast du sicher weder AntiSpam, noch AntiBanner noch die Kindersicherung aktiviert.

 

In diesem Fall führe bei deaktiviertem Selbstschutz die angehängte zip Datei aus und starte KIS neu - dann findest du die Einstellung. (RegDatei ist nur für 64bit!!!)

 

Sniffer64.zip

Share this post


Link to post
Und was ist wenn man die Fortschrittsbalken ein/ausklappen kann und nur der standardmäßig angezeigt wird, welcher als letztes gestartet wurde?

 

Ich habe diesen Vorschlag mal mit einbezogen - mir gefällt das Ergebnis:

 

1. Standardansicht - kein Scan läuft: Wie bisher, nur jetzt mit Start-Button, da der Klick auf den jeweiligen Scan eine Detailansicht öffnet/schließt:

 

post-78003-1250154154_thumb.jpg

 

2. Standardansicht - Scan läuft:

 

post-78003-1250154594_thumb.jpg

 

3. Detailansicht: Scan läuft nicht. (Das blaue "i" öffnet gleich den passenden Bericht)

 

post-78003-1250154202_thumb.jpg

 

4. Detailansicht: Scan läuft

 

post-78003-1250154244_thumb.jpg

 

Alternativ habe ich überlegt, anstelle des "Start/Stop" Schalters ein "+/-" für die Detailansicht einzubauen und die Scans wie bisher über Klick auf den Text zu starten - finde die Lösung per Start/Stop aber besser.

Share this post


Link to post

Ich finde die Buttons noch übertrieben groß. Die Hälfte in Länge und Breite wäre nicht schlecht - und ich würde es dann oben rechts in die Ecke packen. Sozusagen originalbenuzungsstil nur mit optischer Veranschaulichung was der Button jetzt bei nem Klick macht.

Share this post


Link to post
Ich finde die Buttons noch übertrieben groß. Die Hälfte in Länge und Breite wäre nicht schlecht - und ich würde es dann oben rechts in die Ecke packen. Sozusagen originalbenuzungsstil nur mit optischer Veranschaulichung was der Button jetzt bei nem Klick macht.

 

Also die Buttons sind original KL, wie sie in den ersten Betas der 2010 waren. Habe nur das grün etwas angepasst.

 

Kleiner wäre kein Problem, aber: es ist eben nicht der Original Benutzungsstil mit optischer Veranschaulichung, sondern "Scan starten" klappt nur über die Buttons (klick im großen Button blendet Details ein und aus) - von daher ist die Größe IMO vielleicht doch gut.

 

Werde Ende nächster Woche mal was neues zum Testen bereitstellen - wenn ich das Schutz Center umgebastelt habe.

Share this post


Link to post

:bravo: Guter Wurf. So hätten es eigentlich die Profis von KL hinbekommen sollen. Danke.

Edited by Schulte

Share this post


Link to post

Die Startseite gefällt mir so richtig gut :ay:

 

Was mich aber noch stört: die grünen Pfeile und EInstellungssymbole. Irgendwie ist das fast das erste Programm wo ich es sehe, dass beim rüberfsahren die Symbole kleiner werden. Normalerweise ist es ja eigentlich so, das wenn man mit dem Finger püber irgendetrwas fährt das eingedrückt wird und nicht umgekehrt ;). Besser wäre da, wenn sich einfach die Farben leicht ändern würden.

Share this post


Link to post
Die Startseite gefällt mir so richtig gut :ay:

 

Danke - ist an dorsch und Pipkin's Weiterentwicklung davon angelehnt.

 

Was mich aber noch stört: die grünen Pfeile und EInstellungssymbole. Irgendwie ist das fast das erste Programm wo ich es sehe, dass beim rüberfsahren die Symbole kleiner werden. Normalerweise ist es ja eigentlich so, das wenn man mit dem Finger püber irgendetrwas fährt das eingedrückt wird und nicht umgekehrt ;) . Besser wäre da, wenn sich einfach die Farben leicht ändern würden.

 

Hast du nen Touchscreen, wenn du mit dem Finger drüberfährst? :laugh3:

Ne Spass beiseite: Also die Farben ändern sich ja leicht bei den Play und Stop Buttons. Das die Icons bei mouseover größer werden kann ich abstellen - mal sehen wie es generell ankommt. Ich dachte, dass man sie mit zittrigen Händen leichter trifft.

Bei Play-Stop wird es ja nur leicht größer, aber bei den Einstellungssymbolen ist es sicher etwas übertrieben von mir.

 

Noch ne Frage @all:

Im Schutz-Center, wenn da z.B. "Schutz für das System" aktiviert ist. Ist die Hintergrundfarbe da zu hell und sollte noch eher ins grau/silber reingehen, oder ist es gut so, weil dieser helle Grünton ja der Standard-Hintergrund ist wenn etwas aktiviert ist (GUI Buttons, Update etc.).

Share this post


Link to post
Noch ne Frage @all:

Im Schutz-Center, wenn da z.B. "Schutz für das System" aktiviert ist. Ist die Hintergrundfarbe da zu hell und sollte noch eher ins grau/silber reingehen, oder ist es gut so, weil dieser helle Grünton ja der Standard-Hintergrund ist wenn etwas aktiviert ist (GUI Buttons, Update etc.).

Ich finde es so ok - sieht halt nach einer Umrandung aus.

 

Was mir noch aufgefallen ist: Wenn man im Schutzzenter rechts über einer der Punkte fährt (Anti-Spam, --Banner etc.) ist zwischen Hintergrundfarbverlauf und Rahmen 1Px frei - mit Absicht?

 

 

Und warum hast du HIPS hinterlegt? Ist ja schließlich kein Klickelement. Ein einfacher Rahmen reicht da imho.

Share this post


Link to post
Was mir noch aufgefallen ist: Wenn man im Schutzzenter rechts über einer der Punkte fährt (Anti-Spam, --Banner etc.) ist zwischen Hintergrundfarbverlauf und Rahmen 1Px frei - mit Absicht?

 

By design.

Das ist bei allen diesen (nicht als Grafik hinterlegten - was IMO genial für eine GUI ist) Buttons so und wird irgendwie automatisch gemacht wenn man in denen einen Farbverlauf aktiviert. Bei den kleinen ist es nicht so toll, aber das ist denke ich minimal störend. Ich könnte hier aber auch nur mit Rahmen arbeiten - was haltet ihr davon?

 

Und warum hast du HIPS hinterlegt? Ist ja schließlich kein Klickelement. Ein einfacher Rahmen reicht da imho.

 

Ziel war die Erkennung: HIPS Ansicht aktiviert - analog bei der SB. Aber beim Hips fällt es stärker auf. Ich denke ein einfacher Rahmen ist hier eine gute Lösung.

 

Edit: Ein kleiner Bug ist noch drin - bitte nicht wundern. Wenn nur WebAv bzw. IM-AV (also nicht beides) deaktiviert ist, dann ist Anti-Phishing ja nur teilweise funktionstüchtig. Normalerweise wird die Schrift dann gelb, im hochgeladenen Beta Skin bleibt sie jedoch schwarz (da hab ich beim cleanup zuviel Code rausgeworfen)

Edited by SebastianLE

Share this post


Link to post

Stell doch Bitte mal das Bild für den Schutz rein wenn K1 bei XP deaktiviert ist. Ich würds selber tun aber bei mein XP Gerät ist das Netzteil defekt.

Share this post


Link to post
Stell doch Bitte mal das Bild für den Schutz rein wenn K1 bei XP deaktiviert ist. Ich würds selber tun aber bei mein XP Gerät ist das Netzteil defekt.

 

Du Fuchs ;) willst die Fehleransicht um die einzige optische Schäche zu sehen.

 

Ich hab es mal per GUI simuliert:

post-78003-1252668124_thumb.jpg

 

Ja ich weiss - bei "Schutz vor Netzwerkangriffen" passt es nicht ganz, aber wenn solch ein Fehler auftritt ist eine "schöne" Anzeige das geringste Problem.

Edited by SebastianLE

Share this post


Link to post

Habe gerade ein (erfolgreiches) Update gemacht. Das Benachrichtigungsfenster ist jetzt rot (seit dem neuen Skin). Heute morgen war es noch grün. Zufall?

post-77769-1252669557_thumb.jpg

 

EDIT: bei den zwei nachfolgenden Updates wars wieder grün.

Edited by Schulte

Share this post


Link to post
Habe gerade ein (erfolgreiches) Update gemacht. Das Benachrichtigungsfenster ist jetzt rot (seit dem neuen Skin).

 

Also ich habe da nichts geändert. Nutz du die KIS Releaseversion oder die Beta? Bei der Beta ist es möglich.

Share this post


Link to post
Also ich habe da nichts geändert. Nutz du die KIS Releaseversion oder die Beta? Bei der Beta ist es möglich.

Es handelt sich um die .463 (B) auf XPproSP3. Tun wirs mal als KIS-Macke ab, wie das leere Fenster.

Share this post


Link to post
Es handelt sich um die .463 (B) auf XPproSP3. Tun wirs mal als KIS-Macke ab, wie das leere Fenster.

 

OK. War das letzte Update vielleicht länger etwas her, sprich die Datenbanken veraltet?

Share this post


Link to post
OK. War das letzte Update vielleicht länger etwas her, sprich die Datenbanken veraltet?

Nein, kann nicht sein. Davor waren heute schon zwei Updates in grün, dann der Skinwechsel mit nachfolgendem Update in rot, dann wieder zwei grüne.

 

Ich glaube nicht, daß es großen Sinn macht, das "Warum" herausfinden zu wollen. Sind ja in dieser Version auch noch einige andere Darstellungsprobleme mit dem Benachrichtigungsfenster da.

Share this post


Link to post
Du Fuchs ;) willst die Fehleransicht um die einzige optische Schäche zu sehen.

 

Ich hab es mal per GUI simuliert:

post-78003-1252668124_thumb.jpg

 

Ja ich weiss - bei "Schutz vor Netzwerkangriffen" passt es nicht ganz, aber wenn solch ein Fehler auftritt ist eine "schöne" Anzeige das geringste Problem.

 

Hier wäre schön gewesen wenn es bei Störung /Ausfall das Modul gänzlich rot erscheint (wie bei KIS 2009), ich bin mir nicht sicher beim ersten Prototypen war es, so glaube ich umgesetzt, der Makel war aber das die Deaktivierung des Moduls auch rot dargestellt war.

Share this post


Link to post

Warum so zaghaft "Update läuft"(7 Bold)??

 

Fenster Schutz da kann der Link für Details der Module entfernt werden, es ist alles ersichtlich was installiert ist, was deaktiviert ist und wo eine Störung vorhanden ist - so zu sagen fast perfekt, vielleicht ändern der Farben für Deaktivierung (ausgegraut) und für Störung (rot) der Module.

 

Die auszuführende Funktion für den Vista Button bei Scan musst Du noch herausnehmen, es öffnet sich jedes mal ein neues Fenster für Untersuchung

Edited by dorsch

Share this post


Link to post
Hier wäre schön gewesen wenn es bei Störung /Ausfall das Modul gänzlich rot erscheint (wie bei KIS 2009), ich bin mir nicht sicher beim ersten Prototypen war es, so glaube ich umgesetzt, der Makel war aber das die Deaktivierung des Moduls auch rot dargestellt war.

 

Wird es auch hier. Bitte nicht von meinem Screenshot verwirren lassen, da habe ich nur schnell per GUI die Alarmanzeige "provoziert". (Dachte du wolltest nur sehen ob es passt) Wenn die Komponente nicht funktioniert, dann kann sie nicht den Status "grün" bekommen - sie ist also definitiv rot und es gibt auch kein grünes Häkchen, sondern ein rotes X. Glaub mir ;)

 

Warum so zaghaft "Update läuft"(7 Bold)??

 

Fenster Schutz da kann der Link für Details der Module entfernt werden, es ist alles ersichtlich was installiert ist, was deaktiviert ist und wo eine Störung vorhanden ist - so zu sagen fast perfekt, vielleicht ändern der Farben für Deaktivierung (ausgegraut) und für Störung (rot) der Module.

 

Update: Das wäre mir zu viel Text. Das rote von mir hier ist auch überflüssig (es gibt nur 1 Update und das erkennt man an der Prozentanzeige), ich habe es aber wegen der Einheitlichkeit (bei Scan wo es auch vorhanden ist macht es ja Sinn) und leichteren Erkennbarkeit gelassen.

 

Details: Kam ganz zum Schluss dazu - wers nicht braucht klickt nicht drauf :-9. Der einzige Mehrwert des Detailfensters ist eine kurze Erklärung der Komponenten.

 

Farben:

Grau = nicht installiert. (ein ausblenden nicht installierter Funktionen wäre zu aufwendig, da sich unzählige potentielle Kombinationen ergeben, und die grauen "Selectors" dann für jede angepasst werden müssten. KAV User werden eine Menge "grau" sehen...)

 

Rot = deaktiviert bzw. Störung. Wobei bei Störung klar dahintersteht das ein Fehler vorliegt und auch das Icon kein rotes "!", sondern ein rotes "X" ist. IMO eindeutig genug.

 

Gelb = nur teilweise funktionierend. (Bei Anti Phishing)

 

Die auszuführende Funktion für den Vista Button bei Scan musst Du noch herausnehmen, es öffnet sich jedes mal ein neues Fenster für Untersuchung

 

Was meinst du mit "Vista Button"? Play/Stop Buttons steuern die Scans, ein Klick im großen grauen Button öffnet und schließt die Detailansicht ohne (sichtbar) ein neues Fenster zu öffnen. Was soll ich hier herausnehmen?

Share this post


Link to post
...

Was meinst du mit "Vista Button"? Play/Stop Buttons steuern die Scans, ein Klick im großen grauen Button öffnet und schließt die Detailansicht ohne (sichtbar) ein neues Fenster zu öffnen. Was soll ich hier herausnehmen?

 

Nicht den Play/Stop Button sondern das unendliche onklick vom Fullscanbutton, das Ergebnis siehe Bild

 

 

Sebastian denkst Du Bitte auch daran, dass es nicht wenige sein dürften die den Skin auch für das CF2 anwenden würden und da hat sich in der Scheduler einiges geändert und konnte zu dem noch perfektioniert werden.

Edited by dorsch

Share this post


Link to post
Nicht den Play/Stop Button sondern das unendliche onklick vom Fullscanbutton, das Ergebnis siehe Bild

 

??? Das habe ich noch nie gesehen. Wie hast du das gemacht? Immer ganz schnell geklickt?

Normalerweise öffnet ein Klick die Detailansicht der nächste schließt sie. Das da so viele Fenster erscheinen hatte ich nie.

Kann das jemand reproduzieren? Ich prüfe es mal wenn ich nächste Woche wieder zu Hause bin.

 

Sebastian denkst Du Bitte auch daran, dass es nicht wenige sein dürften die den Skin auch für das CF2 anwenden würden und da hat sich in der Scheduler einiges geändert und konnte zu dem noch perfektioniert werden.

 

Steht im ersten Post. Released wird der Skin erst offiziell bei erscheinen des CF2. Dann wird er auch an dieses angepasst. Jetzt ist es sinnlos, da sich a.) noch zu vieles in den Betas ändert und b.) derzeit zahlreiche neue Fehler in den CF2 Beta Layout Dateien sind.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.