Jump to content

beta-tester

Members
  • Content Count

    5
  • Joined

  • Last visited

About beta-tester

  • Rank
    Candidate

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. hi, when i try to search for PXE, then i don't get any results. for that reason i accidently opened an additional thread to a similar topic. and i am still not sure, if there are more threads existing with a similar PXE topic.
  2. hi, i also opened a thread.
  3. oh, and the kaspersky-rescue-x86.iso (krd.iso) is just mounted via an entry in /etc/fstab: /srv/iso/kaspersky-rescue-x86.iso /srv/nfs/kaspersky-rescue-x86 auto ro,nofail,auto,loop 0 10 and nfs-exported via an entry in /etc/exports: /srv/nfs/kaspersky-rescue-x86 *(ro,async,no_subtree_check,root_squash,mp,fsid=345e2088-04f8-11e9-91c7-e716ee7b802a)
  4. forgot to tell the PXE menu entry to boot up free Kaspersky Rescue Disk: ######################################## LABEL kaspersky-rescue-x86 MENU LABEL Kaspersky Rescue CD KERNEL http://pxe-server/nfs/kaspersky-rescue-x86/boot/grub/k-x86_64 INITRD http://pxe-server/nfs/kaspersky-rescue-x86/boot/grub/initrd.xz,http://pxe-server/nfs/kaspersky-rescue-x86-initrd.xz APPEND netboot=nfs://192.168.0.1:/srv/nfs/kaspersky-rescue-x86 ro dostartx -- TEXT HELP Boot to Kaspersky Rescue CD ENDTEXT where http://pxe-server/nfs/kaspersky-rescue-x86-initrd.xz my customized initrd.xz is, that overlays the original broken init-script.
  5. hello, this is my very first post here in this forum. i have a tiny project, where is setup a PXE server to let PCs pxe boot into several different Linux Live systems. now i tried to get the free Kaspersky Rescue Disk to PXE boot, but i run into two problems. on the ISO file there are only SHA512 files, but the init-script is looking for md5 files only and has only md5sum checks. i changed the init script by replacing all "md5" to "sha512" and "MD5" to "SHA512" what fixed the first issue. when i run into the problem, that when the system successfuly booted up via PXE, it doesn't resolv networknames properly, because of a missing /etc/resolv.conf file. also that i could fix by customizing the init-script. but why there are those issues? and can it be fixed on the kaspersky site, so i don't have to create ma own init script inside the initrd.xz file? here the link to my project: RPi-PXE-Server here the patch i did to fix the issues of the init-script (relativ to the krd.iso from 2018-12-21): init.patch please fix that issue on kaspersky site... thank you.
×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.