Jump to content

josemalfa

Members
  • Content Count

    4
  • Joined

  • Last visited

About josemalfa

  • Rank
    Candidate
  1. Muchas gracias KikeSan por su contestación, pero por eso he abierto este post. Me dice que no es valido.
  2. Hola. Tengo Internet Security 2014 y quiero actualizar al 2015, el link que encuentro es para 32bit y tengo 64bit. Sabemos si no es compatible??? Aunque he visto que sí. Saludos.
×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.