Jump to content

git and flutter commands OpenSSL connection error

Go to solution Solved by Igor Kurzin,

Recommended Posts


If I try to do (cmd) git update-git-for-windows

returns the following error:

curl: (35) OpenSSL SSL_connect: Connection was reset in connection to gitforwindows.org:443

If I try to do (cmd) flutter upgrade

returns the following error:

ProcessException: Process exited abnormally: fatal: unable to access 'https://github.com/flutter/flutter.git/': OpenSSL SSL_connect: Connection was reset in connection to github.com:443 Command: git fetch --tags

If I disable Kaspersky Internet Security everything works fine again.

I have tried putting these commands in the exclusions but it doesn't work.

What I can do?

Thank you very much for the help.

All the best.

Link to comment
Share on other sites

2 hours ago, Jose Antonio Molina said:

What I can do?

Hello @Jose Antonio Molina


Tell us please:

  1. Windows OS version & build?
  2. KIS version & patch(x), x=letter, on the Windows taskbar, or hidden icons, right click the Kaspersky icon, select About
  3. Existing Git version
  4. In KIS Reports, are there any events/errors logged, in the timeframe that match the Git issues? IF "yes", SAVE the KIS Report -> top righthand corner of the Report window, upload to any cloud service of your choice & post the share link in your topic please? 

Thank you?

Edited by Flood and Flood's wife
Link to comment
Share on other sites


My Windows version is: Windows 11 Pro 21H2 22000.978

KIS version: (j)

Git version: 2.37.3.windows.1

In KIS Reports there is no error message or anything related to the problem.

Berny's solution "Network Settings > Do not scan encrypted connections" does not solve the problem.

At first, I had Kaspersky Internet Security installed, but everything was working fine, however, at some later point it stopped working, maybe it has to do with the upgrade from Windows 10 to Windows 11 or maybe it's something else.

I've also noticed that the Windows 11 news widget bar doesn't show me the news, I think because it can't connect to the server. However, if I disable Kaspersky protection, it often works again.

Thank you very much for your help.


José A.

  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...