Jump to content

KIS 20 freezes MacBook Pro (Catalina) after waking up. [merged] [Confirmed]

Yin Zhang
Go to solution Solved by Guest,

Recommended Posts


MacBook Pro freezes after waking up from sleep with KIS 20 installed.



MacBook Pro 13 Late 2013 running Catalina

MacBook Pro 16 running Catalina


How to reproduce:

Install KIS (or any other version).

Close the lid to put the MacBook Pro into sleep.

Leave it for several hours. (Wake a MacBook Pro shortly after it goes to sleep does not reproduce the problem.)

Open the lead, log into macOS, then the OS is very likely to freeze.

Link to comment
Share on other sites

  • Replies 87
  • Created
  • Last Reply

Top Posters In This Topic

  • 1 month later...

Had the same problem for years with multiple Kaspersky versions (18-20).


MacBook Pro 15 Late 2013 running any MacOS (High SIerra, Mojave, Catalina)

MacBook Pro 16 running Catalina


When you wake up Mac from long sleep, it freezes either at login screen or when you get to desktop. Beach ball for a minute then blank screen and you’re back to login screen with your previous session killed. You have to enter password again (fingerprint doesn’t work) and you’re in a new session with no opened apps.


I’m also using KIS 20 on iMac 27 (mid 2010), no problems there after long sleeps.

Link to comment
Share on other sites

I have a very similar problem. MBP 2018, Catalina 10.15.2. I’m new to Kaspersky, and contemplating requesting a refund. I use my laptop for work. If I put it to sleep for a couple of days due to the weekend, I plug in the power and open it, the system is nearly completely unresponsive, as if it’s crash. Tap the keyboard, press the power button, it just won’t wake. What barely “works” for me is to unplug the power, press the power button several times, tap on the keyboard, etc - and eventually if I’m lucky the mouse will appear on the black screen. Plug in the power, wait a little bit, tap on the keyboard, and again if I’m lucky, it will finally go to the login screen. 

After logging in, however - most of my applications act as if I don’t have an internet connection. Browser tabs won’t open, messaging apps are stuck at ‘connecting’. Turn off wifi, turn it on, close then re-open applications - nothing.

I eventually wind up rebooting the laptop, which restores everything to service. I would be hard-pressed to call this a solution.


The other issue I have, which is merely a frustration, is that a full scan completely consumes four of the six processor cores on the machine, and there is no clear way to reign it in - no way to ‘nice’ the process or limit it to going full bore only when the computer is idle, as other applications routinely do.

I had previously tried the free version of Kaspersky, and had similar problems. I then tried Bitdefender, which did not have these problems, but for some reason or another I decided to try the purchased Kaspersky product. I’m regretting it.

Link to comment
Share on other sites

Just an update… Uninstalled KIS after my previous post 2 days ago, had no problem since.

All Kaspersky applications have problems on Mac and sending bug reports to tech support doesn’t solve anything. Had problems with Kaspersky Password Manager on Macs last year, sent bug reports with logs, nothing changed.

My license is expiring in couple of months, I don’t think I’ll renew it again.

Link to comment
Share on other sites

I should add that I have Kaspersky installed on my PC at home, and have none of these issues. Which further corroborates user disco’s point that Kaspersky apps have problems on Mac.


Argh. Now I have to go through the whole dance of requesting a refund then uninstalling Kaspersky on the four devices it’s on, then finding a different AV solution. 


Link to comment
Share on other sites

  • 2 weeks later...

I have a late 2013 MacBook Air with latest Dec2019 KIS20 I note that not only do I get frequent freezes of system BUT more importantly it blocks all my browser eg Safari FireFox and Chrome from connection to the internet. This cost me a lot of money one day so ended up uninstalling and IMMEDIATELY solved both freezes and connection via browsers to web.
SO at present DONT have any protection. I note that there is a note saying “working on it” from some posting but what do I do about protection in the meantime this is a debacle and tantamount to taking money from customers and offering no solutions?

I have the Catalina version 15.3 installed. Everything was fine unto point of install but problem started with freezing and then led to blocking of all browser on line activity and meant that not only did it affect my online university course but also contact with essential http/s:// sites thus HAD to remove protection.

Link to comment
Share on other sites

Hello @nuptownboy,


  1. Before installing KIS20 was there any AV software installed?
  2. Before installing KIS20 was a KIS software compatibility check run? 

Please let us know the outcome?

Thank you🙏


Link to comment
Share on other sites

  • 3 weeks later...

This thread has been open since past 2 months and I don’t see any answer from the kaspersky tech team except a vague answer that its a known problem.

If it is known, why is it taking 2 months to fix it?.


With no answer in sight, today i decided to uninstall Kaspersky,. My mac keeps getting frozen and it was getting a big nuisance to keep logging back and setting up my development environment. 



Link to comment
Share on other sites

I have the same problem, after installing Kaspersky 2 days ago. (first time for me to put a program like this on a Mac)

What works for me is the following, after opening the lid, the screen says grey, but when I press the space bar a couple of times, I feel my watch unlocking my MacBook. After some time (duration is different every time) my MacBook comes to life. Annoying, but workable. 

I use a MacBook Air (mid 2013), macOS Catalina (10.15.3), watch series 5 (watchOS 6.1.3) and KIS (

Link to comment
Share on other sites

Hi All!

Known issue. We are working on a fix.

Hello Danila,

Is there an estimate on when the fix might be available? I am suffering from the exact same issue as the others in the thread. The only workaround I've found is to disable Real-Time Protection, but then what is the point of having Kaspersky installed if Real-Time Protection is disabled. This is very frustrating and I too am contemplating claiming a refund for the updated license after I realized that the issue is still there.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...