Jump to content

Can't disable "Visiting an untrustworthy website has been prevented " and "Detected connection to an insecure web resource" warnings


Recommended Posts


These warnings pop up whenever I connect to administer my LAN-connected devices like firewall, wifi Access Point etc. etc. and it's a pain having to keep cancelling the wanings.

The first warning is due to a self-signed certificate: "Visiting an untrustworthy website has been prevented ".


Then after I say "I understand the risk ..." up pops "Detected connection to an insecure web resource".

I've added the URLs to Trusted URLs under Safe Browsing but this doesn't change anything.

A search for this error comes up with nothing in either the forum or support, apart from this similar but unanswered question.

How does one disable it?

Link to comment
Share on other sites

Tx for the reply. Kaspersky really needs a settings search function!

My firewall's address was already listed but inactive. I activated it, saved, tried the site and then saw:

Secure Connection Failed

An error occurred during a connection to Certificate key usage inadequate for attempted operation.


    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the web site owners to inform them of this problem.


Then I restarted Firefox and then it finally worked fine! ?


  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...