Jump to content

Mac App Store blocked by KIS [19 and 2020, "Cannot Connect to the App Store" ]


kenj
 Share

Recommended Posts

Edit: I spoke too soon. I am still getting the "Cannot Connect To The App Store" on the Home Screen which is the "Features" tab. The other tabs; Top Charts, Categories, Purchased and Updates seem to be populating fully with images etc. They did not at first, but after turning protection off, opening app store, closing app store, turning protection on and restarting the iMac, it seems to work properly with the exception of the first screen "Featured" which shows "Cannot Connect To The App Store" Though I am happy with the improvement with the lates KIS version 20.0.0.829a I had the same problem in not being able to access the App Store on my 2011 iMac running High Sierra. The problem began a few days back. After countless fix attempts, to no avail, with the help Uncle Google, I finally thought that maybe Kaspersky Internet Security is the culprit. When I disabled it, the App store finally worked. Then I found this discussion, upgraded to 20.0.0.829a and it now is working fine. Thanks to everyone on this thread!
Link to comment
Share on other sites

  • Replies 64
  • Created
  • Last Reply

Top Posters In This Topic

SupR-Pingou, Is KIS up to 20.0.0.829a ? Please let me know? Thank you:pray_tone3:
Hello FLOOD , Yes my KIS version is up to the "a" version. From what I understood from PvT the issue is still present. From what I saw on my side images are probably showing up on certain tabs because they are in the mac cache system : I have the same thing on my side. When I try loading a page where you have an image showing up, next page is somehow loading but images etc don't on Apple music. Waiting for a fix from Kaspersky team (see my last post). Regards
Link to comment
Share on other sites

Hello FLOOD and SupR-Pingou, I have not "yet" reported to Technical Support, will try and get a brief message out to them shortly. Thank you SupR-Pingou what you have pointed out seems to be absolutely correct that it was the cache that was still giving me images on many of the App store tabs. As when I started up my iMac this morning, almost everything populated in the App Store, surprisingly even the first "Features" tab had populated fully. see below Although, when I followed the following: https://macreports.com/mac-cannot-connect-to-app-store-fix/ I was back to an empty "Features" and "Top Charts" tab, "cannot connect to the app store". The following tabs populating, but with some missing images. You may be able to suggest a better cache clearing as I do not believe I am doing so completely. If I turn NIS Protection off, all Mac App Store tabs completely and fully populate with all images. Best regards, Peter
Link to comment
Share on other sites

Maybe (hopefully) @PvT will come back and clarify.@PvT, if the issue persists, and if you've not contacted Technical Support, please do so, and please update your post with the INC#:pray_tone3:? Thank you all and best regards.
I have since messaged support and received the following INC# INC000010874560
Link to comment
Share on other sites

After upgrading my Mac to Catalina and get new apps TV & Music I discovered that KIS 20 protection make those 2 apps not working properly. TV app content not showing and Music iTunes Store is blank I try to uninstall & reinstall KIS 20 I try to reinstall Catalina upgrade Nothing fix the problem The only thing that can fix the problem is to stop KIS protection Once KIS protection turned off everything works fine Is there any fix to this issue
Link to comment
Share on other sites

  • 6 months later...
Guest
This topic is now closed to further replies.
 Share




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.