Jump to content

"Access denied" when trying to update Kaspersky's app

Go to solution Solved by harlan4096,

Recommended Posts

Hello support

I have Kaspersky Plus (c) and the app is notifying me to update to a newer version.

Problem is everytime I try to update, it pops a system error box: ERROR Access denied

I have tried starting app running as administrator, but it didn't solve the problem.

I didn't try to install a newer version .exe from the website to override late version because it pops a window saying the action will need to use a new and also my last free user/device slot.

What can I do to update the app without reinstalling it to avoid burning my last license slot?


Link to comment
Share on other sites

Hi there, Martin!

Please note that by posting here, you are reaching out to the Kaspersky community and not to the official Kaspersky support 

Reinstalling a product does not mean that you lose a license slot. 

a. Log in to https://my.kaspersky.com

b. Go to Devices and click on your PC. 

c. Under the PC screen image on the left, click on the link to disconnect your device. 

That way the occupied license slot will be freed, and you can reuse it for the new installation. 

The error you encounter seems to be related to your user account, which is (possibly) not an admin account for your PC. 

In such cases, the program should be installed over an account with admin rights. 

If that is not the case, please contact the support and send them a screenshot of the error and a gsi report. 

Take a screenshot: https://support.kaspersky.com/common/diagnostics/492

Generate report: https://support.kaspersky.com/common/diagnostics/3632

Have a nice day

Link to comment
Share on other sites

Thank you very much for both of your supports.

I decided to try the short solution first and move to the steps of the long one if the former didn't work.

For my scenario, updating the product downloading the .exe from the direct link was enough. The updater didn't warn me about license slot, in opposition to the warning received from the fresh install setup (my bad, I should have linked the warning image in my opening post).

In this case, I didn't have to disconnect my device nor check user rights privileges. Everything is updated and working fine now.

Thank you both again!

  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...