Jump to content

Kaspersky asks for Full Disk Access after upgrade to macOS 13 Ventura


Go to solution Solved by Danila T.,

Recommended Posts

Hello i upgraded to MacOS Ventura earlier today, since then Anti Virus started showing error that it doesn't have full disk access and asked my to enable full disk access as it did on first install. Anyway i followed instructions and turns out Ventura says Kasper Sky already have full-disk-access (it actually did before upgrade so should not have been removed because of upgrade). But i nevertheless tried explicitly turning the full-disk-off and then again on to see if that helps but it didn't. 

 

While doing this i noticed my internet has stopped working, i blamed it on my isp and spent considerable time with their support and they remotely tried to troubleshoot my wifi but i soon realised that every other device (including another similar macbook) were able to connect to internet w/o any problem. The problem was only with my device. So i tried restarting my mac, resetting networking, resetting dns, clearing dns cache, and at the very last, found out some network filters setup by Kaspersky my device went online as soon as i removed those filters. So apparently KIS is not compatible with Ventura on M1 macbooks (i'm only saying M1 because mine is M1)

 

Please please rectify it so i can get my protection back asap. It has wasted atleast 4 hours for me to troublshoot my wifi. 

  • Like 2
Link to comment
Share on other sites

Same exact issue. Moreover, after updating, all my internet connections went incredibly slow. After long trial and error, I fully solved by disabling the Kaspersky IDS content filter under "filters and proxies". No idea what exactly this is, but with this OFF internet got back to normal levels, while with that ON as it was by default any internet connection seems back to the 80's.

 

Screenshot 2022-10-25 at 22.02.09.png

  • Like 1
Link to comment
Share on other sites

49 minutes ago, Goran Kukovačec disse:

Fix this by REMOVING AV COMPONENTS from Full Disk Access by selecting them and clicking "-" at the bottom of the window, wait for them to reappear in the list, and then grant access.

Regards,

Goran

Goran, thank you. I had lost at least 1 hour. Solution worked in 5 seconds. Thank you

  • Like 1
Link to comment
Share on other sites

5 minutes ago, Goran Kukovačec said:

Both Kaspersky Internet Security and Kaspersky System Extension

Thank you Goran! That worked however I can't seem to get past the screen below. I click on Install system extension and it takes me back to the disk access page. image.thumb.png.0d28ef9d482c6dd4a4bbf6c67ab358c0.pngimage.thumb.png.602d72863367ede40f4634b3ebc80c06.png 

Link to comment
Share on other sites

1 minute ago, Goran Kukovačec said:

Did you remove Install Kaspersky Internet Security and wait for it to reappear and then enable it?

After I removed it, it never re-appeared. 

Link to comment
Share on other sites

Just now, Goran Kukovačec said:

Hopefully someone from Kaspersky will see this and help you... this thread is #1 result on google for "ventura kaspersky problem" 🙂

Remove Kaspersky. Reinstall, give all three components full disk access as I've described... worth a try,

Link to comment
Share on other sites

2 minutes ago, Goran Kukovačec said:

Remove Kaspersky. Reinstall, give all three components full disk access as I've described... worth a try,

Hopefully! I tried that also but no luck, on the phone with support now. Will post an update on this thread if I'm able to get it installed. 

  • Like 2
Link to comment
Share on other sites

  • The title was changed to Antivirus broke after the upgrade to macOS 13 Ventura
1 hour ago, Danila T. said:

 Hi all.

The problem in macOS 13 itself (when upgrading from the previous version). We reported it to Apple back at the beta stage. As you can see - it has not been fixed.

To solve the problem, among other things, you can do the following:
1) Uninstall the antivirus.
2) Reboot macOS - THIS IS IMPORTANT!!!

3) Install product again.
4) Open System Settings with Full Disk Access permissions.
5) Manually move there system extension. It is located here:

/Applications/Kaspersky\ Anti-Virus\ For\ Mac.app/Contents/MacOS/sysextctrld/Contents/Library/SystemExtensions/

6) turn off/on permission for the application

 

 

The solution above doesn't work: 

image.png.f875866da5f440b86149be1c51a98759.png

 

image.png.853dfe014e054dd6591a9f9a2ac81f3d.png

image.png.6d001ac780b853868132f879586990c4.png

image.png.63ec7932eea0ec00acce070cdea7cfcb.png

 

 

 

  • Like 1
Link to comment
Share on other sites

  • The title was changed to Kaspersky asks for Full Disk Access after upgrade to macOS 13 Ventura

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.