Jump to content

Wrong network time smartphone Cat S62 Pro + Cat S60


Ray_1
 Share

Recommended Posts

Hello,

I have Kaspersky Internet Security with VPN on my Cat S62 Pro phone. Almost every morning the time is wrong. Time shifts up to 10 minutes, which means the first appointment of the day could be 10 minutes too late 🙄 I have an alarm clock that reads for instance 8:29 in the morning and is set to go off at 8:30, but all my other clocks (PC, TV, other clocks) then would read something like 8:35.

As soon as I stop the alarm and make a phone call, network time synchronizes and all clocks read the same time. I have contacted Catphones.com support for a solution, they said it could be a third party app. I have only a few non-stock Android apps. Running the phone in safe mode resolved the problem, or at least, time was correct for two days. Then I had to reconnect to the internet and thus had to reboot in normal mode.  I can't really test safe mode for longer.

I had a similar problem with my previous phone, a Cat S60, running also Kaspersky, but without VPN. That phone would sometimes run up to an hour late during the day....

Catphones said they were sorry that a third party app caused problems with the phone and basically said it isn't their problem.  Searching the internet I found a similar problem with one of their other products: Motorola phones running Android on a Vodafone telephone network. That problem was resolved by contacting Vodafone support who contacted Motorola support, something to do with phone registration on the network. Motorola is a product from the same company.

Is this a problem caused by Kaspersky software preventing proper registration on the Vodafone network, or going into sleep mode at night? I have Vodafone, but also KPN. Time problem seems to go away when I call someone but persists every morning...

Link to comment
Share on other sites

  • 2 weeks later...

Every now and then I find out something new about this problem: It is mentioned by numerous people on Android phones, different brands, different networks. In my specific case, the phone will sync as soon as I call someone. I tested this yesterday and this morning, as soon as I hit the 'call' button, time syncs.

Time is sent by the network provider, my Android version 11 has no option to disable time-zone, only network time.

Someone mentioned on Vodafone forum that their Motorola had a problem with user accounts not being able to correctly identify on the Vodafone network, but nothing was resolved, only to disable network time... A possibility might be that AV software shields identity or other info from the network, and disabling network sync, or a more broader possibility is that the phone goes into eco-mode and doesn't periodically sync with network (I don't use the phone much and hardly ever use internet on it).

A French website for Android mentioned that the problem lies in Time Zone, switching from one to another creates problems, but I don't travel abroad, and don't live near borders.

A Vodafone/Motorola user mentioned he has 4 phones, 3 of them have the same sync problem. Only his youngest son has no problems. Older people might have more than one account, using more than one email address on their phone using different servers in different time zones. Younger people often have just one account that connects everything, or maybe just an email address of their ISP (located in their home country with local time).

No forum posts I have read thus far mentioned AntiVirus as probable cause, but it is safe to say that just about everyone with a smartphone has some sort of AV on it.

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Time was synchronous for about 10 days, but yesterday I activated WiFi for internet, this morning time was out of sync 3 minutes (3 minutes behind).  It's the only thing I did differently with the phone last week, before time changed again. I then make a call, and time immediately synchronizes with the service provider.

Still don't know how to fix this other than making a call every day...

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.