Jump to content

unable to boot Kaspersky rescue disk 18


Recommended Posts

hi, i own this:


it has BIOS (not UEFI).

i followed the instructions to create KRD using rufus on my USB flash drive. but rufus-3.11p recognizes the ISO as meant for UEFI only and even if i set the partition scheme as “MBR”, there is no option to change the target system from “UEFI (non-CSM)”; i chose “YES” to download the grub 2.02 but the resulting USB stick cannot be booted by my BIOS.

i tried the steps using rufus-3.5p and rufus-3.6p which automatically show option of the target system as “BIOS or UEFI”. but, attempting to boot from this flash drive resulted in the following:

GRUB loading

Welcome to GRUB

the only way to escape from this was CTRL+ALT+DEL.

after this i tried many such softwares, like Win32 Disk Imager, SARDU pro, ventoy, YUMI std, UUI, unetbootin, xboot, in both DD mode and ISO mode but none of them can boot the USB. the only change is that my USB stick has worn out. but i desperately need to scan my laptop with KRD-18. can someone tell me the right software to use and the right settings pertaining to my BIOS? thanks in advance.

Link to comment
Share on other sites

You should see a Kaspersky lab boot menu and then press ENTER for English.

Flash drives are very cheap - or maybe borrow one from a friend. If a different flash drive gives the same problem, then try changing your BIOS settings.

i have used KRD-10 in the past without any problems. the screen is stuck at the

GRUB loading: Welcome to GRUB

prompt. i have tried many flash drives. i dont know what BIOS setting to change. i have set the boot order to boot from the USB stick.

PS.: my graphics adapters (both onboard and discrete) are not in working condition. could that be the source of this problem?

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...