Jump to content

No internet connection when connecting to USA servers


Go to solution Solved by Chrisps,

Recommended Posts

Hello,

 

Can anybody assist me with this issue:

When i connect to any US location with Kaspersky Vpn i have no internet connection at all. 

Every other location besides US works just fine. 

On my andoiid devices the USA servers work just fine. The problem is only on my windows 10 22h2 laptop.

See screenshot.

Thank you

Capture.PNG

Link to comment
Share on other sites

I do not think it is a router issue as i have two routers in my home from separate ISPs . And it does not work on both of them. Even the affected laptop has a freshly installed windows on it. Baffles me😃

But why only USA locatioans and why only on windows????

 

Link to comment
Share on other sites

  • Solution

Hello ,

 

After performing intensive troubleshooting using sysinternal tools i managed to find the rootcause of this problem.

It is the build in secure dns option in the browser:

If you choose a secure dns provider like cloudflare or opendns the USA locations built from Kaspersky vpn will not work.Somehow this does not surprise me.😄😀

If you uncheck this option and stick with your ISP everything works fine.

See attached screenshot . Its self explanatory.

We can mark this as a solution.

Screenshot 2022-11-19 171414.png

  • Thanks 2
Link to comment
Share on other sites

Hello @Chrisps,

Well done 👍  and thank you for your feedback .

FYI :

My Browser setting is on my ISP

Spoiler

chrome_dns_01.jpg.2c85e5726e8ddd1e0b31e376dcc2a8df.jpg

My Network DNS server is pointing to 1.1.1.1 Cloudflare

Spoiler

chrome_dns_02.jpg.8d7a1a4822bc16342964537928458cf5.jpg

Connecting from Belgium (real location) to virtual location USA is no problem 🤔

Link to comment
Share on other sites

It work fine for me too now. Just tried it. After all i sent logs and traces to support.

Maybe it got fixed. Couple of days ago it did not work unless you choose you ISP as option.

Edited by Chrisps
  • Like 1
Link to comment
Share on other sites

Just a short follow up. I personally do not reccommend enabling secure dns in the browser in case you permanently use the secure connection. It does not play along well this setting. You will experience hickups and glitches with some locations. 

I have been testing it for some days now. Then again its my personal oppinion.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.