Jump to content

KSOS certificate problem with Thebat! Email Client

Go to solution Solved by harlan4096,

Recommended Posts

When I open Thebat! to download the new  mail messages KSOS launches a popup which reads that a certificate problem has been detected in the encrypted connection and offers me either to close the connection or to continue. I have chosen to continue but every time I open Thebat! I notice that the client takes a long time to check the mailboxes. This does not occur if KSOS is uninstalled from the operating system: windows 10 enterprise.
Do you have any ideas on how to fix this?
Thank you!


Edited by flaubert
Link to comment
Share on other sites

Hi, this didn't help me. I added gmail.c om to exclusions. Then I added TheBat to trusted apps. See screenshots. Yet, every time there is this message. It doesn't help that I have to switch to a mouse to click this annoying popup every time I receive new email... I loved TheBat precisely because mouse wasn't needed, and I didn't need to do many clicks to just load an email... please help! 





Link to comment
Share on other sites

@harlan4096, g-ec2.images-amazon.com is not a mail server. I think pictures are inserted into the email from this domain.

@Anna M, do you have Windows 7 or Windows 10(11)?

This setting will not work:



You need to add the program itself to trusted applications, and not a link to it.

  • Like 1
Link to comment
Share on other sites

Hi -- I have Windows 10. Thank you!

Adding each domain will prove to be a major pain given we all normally receive many emails with links to many domains! To be honest, it is a major pain at this moment. The problems started when I upgraded to the new version of TheBat.

Could you please teach me how to add TheBat itself to the trusted programs?

Also: will that mean that I have no email antivirus? 

I added smtp.gmail.com, pop.gmail.com, smtp.mail.ru, pop.mail.ru to the list of trusted addresses. We will see if that helps. 

Thank you again. 

  • Like 1
Link to comment
Share on other sites

@Anna M, try disabling encrypted connections scan in TheBat:

Open the main application window.

Click the More Tools button.

The Tools window opens.

In the Tools window, go to the Manage applications section.

Click the Application Control link to open the Application Control window.

In the Application Control window, click the Manage applications link to open the Manage applications window.

In the list select TheBat.
Double-click the application name to open the Application rules window.
In the Application rules window, go to the Exclusions tab.
Click on the Do not scan all traffic link and select Do not scan encrypted traffic.

In the Action column, click the icon to open the context menu and select Allow.

Click the Save button.






Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.