Jump to content

Kaspersky Mail Checker mcou.dll cannot be loaded: Solution for Windows 7?

Go to solution Solved by windowsWarr1or,

Recommended Posts

This problem started on my desktop … every time I click on an email I get warning that mcou.dll cannot load. I tried turning off and re-starting the mail security option in KTS, but that didn’t resolve. I found this thread which is now marked as closed. It references Windows 10 and did not work for me.

On my windows 7 system, after each ADMIN cmd entry, I was told the mcou.dll file could not be found (yet it is in the root folder of /Kaspersky Internet Security 21.2/. I posted this question on that thread, but thought I should start another thread given its CLOSED status.

On my laptop, this problem started a week ago. I was able to resolve by uninstalling and reinstalling KTS. I would rather not do that if there is an easier solution. I actually have a backup copy of the mcou.dll on my E: drive.

I tried to merely copy/paste into the C: location but was told I needed system permission to do so.

Perhaps there are other posts with the solution, but many posts seem to be in a language I cannot read. TY.


Link to comment
Share on other sites



1.) Close the mail client 

2.) In the bottom left hand corner click Start > Run 

3.) In the Open field copy and enter the following command: regsvr32 -u "C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 2020\mcou.dll" 

4.) Make sure the library has been successfully unregistered and click OK

5.) Close the mail client 


Link to comment
Share on other sites

Hi @nexon . Thank you, but that path does not exist on my computer. The path is the same as that mentioned in the post help for windows 10 system:
C:\Program Files (x86)\Kaspersky Lab\Kaspersky Total Security 21.2

I tried editing the above instructions with the proper path (Internet Security 2020 changed to Total Security 21.2) and received this error message:

The module "C:\Program Files (x86)\Kaspersky Lab\Kaspersky Total Security 21.2\mcou.dll" was loaded but the call to DllUnregisterServer failed with error code 0x8002801c.

Link to comment
Share on other sites

  • 2 weeks later...
  • Solution

Without valid fix responses and TOO much time trying to do an “easy fix”, I have uninstalled Kaspersky Total Security, saving my license. Then reinstalled. Problem gone. Not totally confident in this fix, as the program was working fine for years until, I assume, some automatic update broke it. Restore point created after fix so I can roll back to this state. Thank you to those who tried to help.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...