Jump to content

Google unable to Authenticate on Mac

Recommended Posts

In Mac Monterey, Internet Accounts won't open a browser, neither Safari nor Chrome, in order to truly try a password for authentication. So, it will never get to the point where I can add enter an 'app specific password' or any other password for that matter. Thus I was unable to add a new Google account, and Apple Mail would typically only work briefly before Internet Account demanded that I authenticate the account. Then, when I tried, it never opened the browser, just gave the message that it failed to authenticate try again later.

I tried virtually every option I could find within the Mac world to fix this. However, the problem only went away when I opened in Safe mode. Since I had NO other programs opening at login, I had to remove Kaspersky.

Problem solved. Except now I no longer have a security system in place.

Link to comment
Share on other sites

Hello @DonMatt


  1. Please log a case with  Kaspersky Support; on the support page select either Chat or Email, then select Application malfunction, Other template (see our image as a guide); Support may need logs, traces & other data, they will guide you; it may help Support if you include a video of the issue... 



  • If you do log the issue with Support, please share the outcome with the Community, when it's available? 

Thank you?


Link to comment
Share on other sites

Use these quick tips — 
Close Apple Mail and restart your Mac.
Deactivate Gmail on your Mac, then activate it again.
Remove Gmail from your Mac, then add it again.
Remove Gmail from Keychain and enter your password manually.
Turn off two-step authentication for your Google account.
Enable access for “less secure apps” in your Google account.
Add Gmail manually using “Other Mail Account” in Apple Mail.



Rachel Gomez

Link to comment
Share on other sites

  • 10 months later...


In case anyone else is still having this issue, I think I was able to figure it out.

Kaspersky Internet Security app seems to be causing the issue, but it only causes the issue for macOS running on intel processors (I have a MacBook running M1 chip and no issues to report).

The issue started after upgrading my device to macOS Ventura 13.4. When I first got the issue I reinstalled my macOS and the issue stoped (accounts were syncing correctly again), but when I updated to macOS Ventura 13.4.1 the issue started again.

Note that the sync issue is not only for email accounts, I also got calendar and other app sync issues (eg. Craft, Things3, Dropbox).

The only way I was able to fix the issue was to complete remove the Kaspersky Internet Security app (you need to go through the uninstall option, only removing the app from Application folder doesn't fix the issue).

I imagine we might not have more support for intel processors from Kaspersky, so I don't recommend it to older macOS devices.

Hoping this can help more people with this issue. @KasperSky  Would love to hear once you guys have a fix for this problem.


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...