Scenario
A traffic monitoring solution (man-in-the-middle) which tries to decrypt the connection to KSC initiated by mmc console over the TCP port 13291. To do this, it replaces the certificate by it's own, self signed in most cases.
KSC Administrator might be unaware of this fact.
They try to connect to KSC Server remotely but receive Invalid certificate error.
Troubleshooting steps
Make sure the problem is not reproduced when connecting to KSC Server locally by using the
Problem
The KSC Web Console is used to export a list of devices, but it is unable to export the column for the operating system.
Log in to the KSC Web Console.
Go to Assets (Devices) → Managed devices, and check the Operating System column.
Export the list to CSV or TXT
Operating System column cannot be displayed.
Reason and solution
This issue is fixed in KSC Linux 15.3.
Follow the steps to fix the issue in KSC for Windows:
Install Pyth
Problem Description, Symptoms & Impact
When deploying Auto patches from KSC, installing Network Agent or Kaspersky Endpoint Security, installation fails with bad junction errors.
Diagnostics
While Auto patch deployments over KSC will directly generate an event in Events section of KSC, manual Network Agent or KES installations will end with Fatal Error message and installation logs will contain information such as below:
Application: Kaspersky Security Cent
In certain cases, ‘Install updates and fix vulnerabilities’ task might fail with some error. Below example contains ‘Error verifying file signature’ error but you may use mentioned keywords and overall approach for investigation of other errors met while running ‘Install updates and fix vulnerabilities’ task. Here are some steps to investigate such problems:
First of all view list of updates aimed at installation on client. For this purpose in network agent trace file search for ‘Update
Description
You may want to allow certain users to do everything, but without giving them access to modify policies, manage users, or assign roles. However, when using default roles provided by KSC, some permissions are either too broad or unchangeable.
Steps to Create the Custom Role:
Open Kaspersky Security Center.
Go to Administration Server Properties → Users Roles.
Click “Add” to create a new role.
Enter a role name (e.g., Rule for Hospitals).
For any types of issues with tasks managed by KSC, we require export of task execution history in .txt file. Task execution history is a sequence of events generated by client computer during task execution.
Step-by-step guide
To export task execution history, follow these steps:
Open task results window.
In the upper part of the task results window, select problem computer.
Right-click some event in the lower part of the task results window,
This article is about Kaspersky Security Center for Windows (KSC for Windows)
Step-by-step guide
Make sure that System Management license is installed, otherwise KSC events won't be exported to SIEM. For more information please refer to SIEM integration: the most frequent error.
Specify Splunk Server address and port;
Login into Splunk Management console;
Press Settings → Configure data inputs;
In the o
KSC installer generates default passwords for service accounts (automatically created to run KSC service), KIPxeUser and KIScSvc.
Those passwords have 16 characters length, characters are taken randomly so that the password contain 3 out of 4 of the following groups of characters:
Lowercase characters (a – z)
Uppercase characters (A – Z)
Numbers (0-9)
Symbols (~ ! @ # $ % ^ & * - _ + = [ ] { } | \ : ' , . ? / ` ~ " < > ( )
Also the password cann
In some cases klakaut traces should be collected for diagnostics.
Step-by-step guide
To do so:
Import klakaut-on_x*.reg file.
Restart klakaut service.
net stop klakaut
net start klakaut
Enable another trace if required.
Reproduce the issue.
Impor
To troubleshoot SNMP functionality in KSC specific traces should be collected.
Step-by-step guide
To collect traces:
Download archive
Use trace-5-snmpagt.reg to start trace
Reproduce the issue
Use trace-off-snmpagt.reg to stop trace
Archive files and send to Kaspersky Support.
Description and cautions
The article is giving some use cases examples of KSC API calls to ease one's start using the API. In that KB we are looking at host isolation with KES/KEA scenario.
For the Windows version of cURL, you need to specify that the arguments need to be escaped with "\", otherwise there will be an error. For example: 'Authorization: KSCBasic user=\"YXBpLXVzZXI=\", pass=\"cGFzc3dvcmQ=\", internal=\"1\"'
Details
Prerequisites
internal use
This article is about Kaspersky Security Center for Windows (KSC for Windows)
Problem:
KSC certificate renewal or replacement is made incorrectly because the option to instantly replace the server certificate is used.
As a result, managed devices loose the connection with KSC and klmover command or re-installation of klnagent is required to restore the connectivity.
Cause:
After the certificate is renewed with "-t C" option, network agent
The problem is in the certificate - it has a 1024 bit long key. While Web Console now works only with 2048 bit long keys.
The customer needs to reissue KSC server certificate to 2048 key length.
What to do -
1. Generate reserve KSC certificate - for example by using command -
klsetsrvcert -t CR -g "dns_name" -o "RsaKeyLen:2048"
where DNS name is DNS name of KSC
2. Wait several days - hosts will connect to KSC and receive reserve cert.
The customer could check on c
Issue
An attempt to send POST request via KPSN API from a Windows client.:
curl --cert C:\\Users\\user_A\\Desktop\\kpsn_api
kpsn_api_crt.pem --key C:\\Users\\user_A\\Desktop\\kpsn_api
kpsn_api_key.pem -k -X POST -d "{\\"action
": \\"check_url\\",\\"data
": {\\"urls
": [\\"website1.com
"]}}" https://10.90.116.27:80/api/
Fails with the following error:
curl: (58) schannel: Failed to import cert file C:\\Users\\user_A\\Desktop\\kpsn_api
kpsn_api_crt.pem, last error is 0x80092002
Th
Advice and Solutions (Forum Knowledgebase) Disclaimer. Read before using materials.
Problem
You change the account of the administration server service via the klsrvswch tool. Note that this is the only way to change the account, manual modification (for example, via services.msc) is not supported.
Then, the you run the Install required updates and fix vulnerabilities task.
As a result, the task is cancelled and updates are not installed.
Diagnostics
The following
Problem
In Kaspersky Security Center Network Agent (klnagent) 15.1 and more recent versions, klmover tool requires klnagent uninstallation password to re-connect a managed host to another Administration Server: https://support.kaspersky.com/ksc/15.1/227839
If the password is not set in the policy, it is not required to be specified in command line via the parameter: -nauninstpwd
If klmover is executed directly through a Command Prompt, the parameter will work as expected. However, if
Scenario
After the deployment of KSC in the environment, the Backup task fails with the following error using the KSC Backup task or klbackup utility (screenshot is below).
All the permissions were correctly assigned on the shared folder, and ports were opened, but still the backup was failing. There were no blocking events in the Firewall traffic logs.
Error -1963 ('Database connection is broken " 'Connection failure{08S01};' LastStataement='select type from sys.system_object whe
Problem Description, Symptoms & Impact
The installation of the Network Agent isn't possible on a device because of the error System error 0x1F (A device attached to the system is not functioning.)
Diagnostics
In the MSI Log and Application Eventlog can be found the following line:
(1192/0x0 ("System container 'LOC-PUB-6EEB50F8D2EB46029DB4CCB77E0DA651' is corrupt")
Workaround & Solution
The issue comes from a corrupt cryptostorage in the OS. It's not a KL rel
Scenario
Administrator tries to install Kaspersky Security Center Network Agent (klnagent).
One of the errors occur:
Setup Wizard cannot process the command line
Failed to definitely identify the status of the installed application. Remove the application manually or use the setup wizard
In case of standalone package, installation error might be a little different:
Setup wizard cannot process the internal error
When looking cl
Advice and Solutions (Forum Knowledgebase) Disclaimer. Read before using materials. Product: KSC 11+ Applies also to the update utility version 4.1 and more recent. Scenarios You have installed KSWS on the KSC server and enabled Traffic Security component and Traffic Security uses MITM mechanism to analyze traffic. You use a 3rd party software or hardware appliance for traffic filtering and this appliance disrupts connections to HTTPS-enabled public update servers. It can be a hardware applian
Description and cautions You may experience low time to live value set in ICMP network packets sent by klnagents. The following can be seen in wire shark traffic dump: Explanation: There are two modes of distribution point search: 0 - search of the nearest DP using a tool similar to traceroute. It generates a number of ICMP packets to find out the neatest route to DP - this is the default mode. 1 - selection of random DP without sending such amount of ICMP packets. This mode is configured on
Advice and Solutions (Forum Knowledgebase) Disclaimer. Read before using materials.
Consider the following scenario:
You have a large local area network 10.36.0.0/16. There is a managed device with the following IP config: IPv4 address: 10.36.35.10 and Subnet Mask: 255.255.255.0. You create a new subnet condition for klnagent connection profile: 10.36.0.0/16.
Actual result:
The connection profile is not applied to the managed device.
The reason of this behavior is equali
The best practice is to back up your current Administration Server and then install the new version of Kaspersky Security Center.
To do so, follow these steps:
Back up the data of Kaspersky Security Center using one of the methods described below:
Backup and Restore Wizard
Backup task
Check if you can install Kaspersky Security Center on your current server. For system requirements, see Online Help.
Then export the list of currently inst
Description and cautions
That article is describing KSC rel. 13.2 to rel. 14.x SW upgrade procedure.
Prerequisites
KSC 13.2 on MS Windows
S/N
Action
Online-Help
1
Download the KSC 14 Version
2
Take the backup of KSC Administration
Advice and Solutions (Forum Knowledgebase) Disclaimer. Read before using materials.
The article is giving a working configuration instructions for domain authentication by using NTLM and Kerberos protocols.
NOTE: Domain authentication in OpenAPI over Kerberos protocol has the following restrictions:
Administration Server address must be specified exactly as the address for which the Service Principal Name (SPN) is registered for domain account name.
In the domain, yo