Jump to content

Store apps (aka modern app, metro app, UWP app) won't connect via tunneling like VPN [Closed]

Go to solution Solved by ChiriChitosan,

Recommended Posts

Hello, I'm using Kapsersky Internet Security 2019 with patch e Recently I set up new VPN using L2TP/PPTP protocols. when I connect to VPN it works properly on Firefox, Chrome, Internet Explorer, and many other Desktop apps. but when it comes to Windows Store apps, like Microsoft Edge and Cortana, OneNote, They refused to connect to network (both local(intranet) and internet) even Windows Store doesn't seem to have an access to network. Now I have firewalls disabled and using Windows default firewall to use VPN flawlessly. And...there's an exception: VPNs using additional adapters/drivers like OpenVPN and Kaspersky Secure Connection, are not affected. Do you have any similar issues on this? I have tried other than disabling firewall on KIS,
  1. unchecking 'Use default gateway on remote network' : looks like it seems connects but the traffics don't pass thru VPN.
  2. set LoopbackExemption on store apps : didn't work
  3. uncheck 'Automatic metric' : didn't work
  4. Hyper-V: my system uses Home edition of Windows 10 so this is not possible to try without pay for Pro edition.
Using Windows 10 1903 x64 with May updates
Link to comment
Share on other sites

Hello ChiriChitosan, Welcome! We need to ask some questions please to clarify so that we may assist if we can... Are there any errors (captured/visible) anywhere when Windows Store apps, e.g. Microsoft Edge, Cortana, OneNote, Windows Store refuse to connect to the networks (both local(intranet) and internet)? Are you able to perform a trace when trying to use one of the failing apps? Can you provide logs / reports of those errors please? Can you provide screen prints please? Can you please also provide GSI https://support.kaspersky.com/common/diagnostics/3632#block7, include "Windows logs" when generating the GSI. Please upload the GSI zip folder to a cloud storage of your choice and post back the link please? Re: 4. (imo) the use of Windows Home is not core to the problems being reported. And, in your assessment, how is KIS contributing to the connection problem? Also please provide the specific VPN-L2TP/PPTP details? Many thanks!
Link to comment
Share on other sites

  • Solution
Oops, It seems to be a temporary issue. I connected to that VPN and tried again to grab screenshot, log, GSI but gladly Now they connects to both internet and intranet(local) fine. it works even after sleep mode, change Wi-Fi access points. I'll post those if problem rises again. Thank you.
Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.