Jump to content

Some websites are suddenly not functioning properly, "Your connection is not private, cert date invalid"

Go to solution Solved by Schulte,

Recommended Posts

For the past 2 weeks or so I’m unable to visit protonmail.com. I’m getting the “Your connection is not private” message, with no option to advance manually. This persists regardless of which browser I use, with the exception of Tor.

Also, on odysee.com I’m not seeing icons and thumbnails anymore, and when doing a search on the site I receive no results. The site is working perfectly on my other devices.

Link to comment
Share on other sites

Hello @marnus,

all of the sites mentioned use a certificate from 'Let's Encrypt' for the site itself or for parts of the site (thumbnails).
They had to replace an expired certificate. Probably your browser does not know the new certificate.

See also this article:



Thank you. The only solution I haven’t tried is OS updates.  I doubt that Windows 7 will have updates available to fix the issue though. Really not keen on switching to Windows 10. This sucks.

Thanks again.

Link to comment
Share on other sites

Hi @marnus,

I am also using Win7 right now and have no problem with the certificates.
But unlike you, I'm running Firefox in the current version.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...