Jump to content

Kaspersky claims Hardware virtualization is not available — except it is avaiailable. Now what?


Go to solution Solved by Schulte,

Recommended Posts

On my notification I am redirected to a Kaspersky website page where I'm told I have to enable virtualization in the BIOS. Except it's already enabled and I have checked and rechecked it. systeminfo also confirms I have it.

 

Untitled.png

  • Like 1
Link to comment
Share on other sites

 

I have

3 minutes ago, harlan4096 said:

been there already (that is the website that a link in the antivirus notification takes you) and like I said I am 100% sure that I have it enabled it. FYI that website has no information other than how to enable it in BIOS in case it is disabled. That's why I opened this thread.

  • Like 1
Link to comment
Share on other sites

Posted (edited)
26 minutes ago, Schulte said:

Hello @Raiden,

in Windows only one hypervisor can be active at a time.
Some Windows features use a hypervisor themselves, e.g. 'Device Guard'. Is this one enabled?

What is "Device Guard"?

I only have Kaspersky on my Windows 11 as far as antivirus program is concerned. There is of course Microsoft's own built-in antivirus but that one is turned off automatically when Kaspersky is turned on.

 

 

 

Edited by Raiden
  • Like 1
Link to comment
Share on other sites

Probably the cause is one of these 2:

 

image.png.46564af77cfc53f9732fa2218a5f6745.png

 

Any Windows 11 feature that uses Device Guard, Windows Hyper-V enabled... or Windows SandBox enabled, I think also Linux subsystem also need Hyper-V enabled (not sure), will lead to a warning of Kaspersky own Hyper-V / Hardware virtualization protection.

  • Like 2
Link to comment
Share on other sites

22 minutes ago, harlan4096 said:

Probably the cause is one of these 2:

 

image.png.46564af77cfc53f9732fa2218a5f6745.png

 

Any Windows 11 feature that uses Device Guard, Windows Hyper-V enabled... or Windows SandBox enabled, I think also Linux subsystem also need Hyper-V enabled (not sure), will lead to a warning of Kaspersky own Hyper-V / Hardware virtualization protection.

I don't have "device guard". Never heard of it. Not available in my machine.

My Windows is the normal version that people buy in shops and use at home (aka Home edition) not server or enterprise or whatever other Windows versions that exist out there.

Link to comment
Share on other sites

  • Solution

Hello @Raiden,

'Device Guard' is now integrated into MS Defender.

Can you please check if 'Memory Integrity' is enabled under 'Settings > Update & Security > Windows Security > Device security > Core isolation details'? (Windows-Settings!)
This will enable 'Hypervisor-protected code integrity (HVCI)', then Kaspersky cannot use virtualization.

  • Like 4
Link to comment
Share on other sites

11 hours ago, Schulte said:

Hello @Raiden,

'Device Guard' is now integrated into MS Defender.

Can you please check if 'Memory Integrity' is enabled under 'Settings > Update & Security > Windows Security > Device security > Core isolation details'? (Windows-Settings!)
This will enable 'Hypervisor-protected code integrity (HVCI)', then Kaspersky cannot use virtualization.

Yes THAT's what I wanted. Precise answer. Thank you.

Finally something I recognize: Core Isolation in my settings, not "device guard".

I disabled core isolation's "memory integrity" switch and the antivirus finally sorted itself out.

  • Like 1
Link to comment
Share on other sites

Posted (edited)
7 minutes ago, harlan4096 said:

Yes, I forgot also that feature, Windows Core Isolation also seems incompatible with K. HyperVisor, because probably it uses some security features of Microsoft HyperV...

You forgot because Kaspersky has NOT put such an important piece of information in their info page (that the anti virus tells us to read):

https://support.kaspersky.com/us/common/safemoney/13713

That info page needs to be updated ASAP. Also in another area: the "Windows 10" subtitle is already outdated (since early last year already we have another Windows version on the market: Windows 11 so it should read "Windows 10 & 11"

 

Edited by Raiden
  • Like 2
Link to comment
Share on other sites

Posted (edited)

I decided to remove Kaspersky.

Because while this core isolation problem was solved, I discovered a new problem while trying to solve that: Kaspersky conflicts with AdGuard (an anti ad protection program that I have on my computer). Specifically I had set up AdGuard to be my DNS resolver instead of the usual (Windows Settings > Network & Internet). The reason is because I don't want to change the Windows's basic DNS settings - I want that to remain "Automatic" by default so I don't get connection problems with some public networks.

So I want to continue using AdGuard. Which means I have no choice but to stop using Kaspersky Security Cloud. Because KSC has no option to "allow" me to use AdGuard HTTP / DNS protection side by side (something I can do with AdGuard + Windows Defender).

Edited by Raiden
Link to comment
Share on other sites

  • 2 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.